summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2016-02-03 20:41:38 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2016-02-05 14:42:18 -0500
commitd3682b4562f02831b024afb303f3072fbcc37544 (patch)
tree514fe843e8e458f97840c7ec8e0c10189bba0006
parent5ac5951e2066a18541e50758d5177a2872299401 (diff)
downloadmeta-cloud-services-d3682b4562f02831b024afb303f3072fbcc37544.tar.gz
neutron: uprev to Liberty
Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-neutron_git.bb68
-rw-r--r--meta-openstack/recipes-devtools/python/python-neutronclient_git.bb26
2 files changed, 56 insertions, 38 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-neutron_git.bb b/meta-openstack/recipes-devtools/python/python-neutron_git.bb
index b9cf518..cadc80f 100644
--- a/meta-openstack/recipes-devtools/python/python-neutron_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-neutron_git.bb
@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6 6
7SRCNAME = "neutron" 7SRCNAME = "neutron"
8 8
9SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=stable/kilo \ 9SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=master \
10 file://neutron-server.init \ 10 file://neutron-server.init \
11 file://neutron-agent.init \ 11 file://neutron-agent.init \
12 file://l3_agent.ini \ 12 file://l3_agent.ini \
@@ -19,8 +19,8 @@ SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=stable/kilo \
19# TBD: update or drop 19# TBD: update or drop
20# file://uuid_wscheck.patch 20# file://uuid_wscheck.patch
21 21
22SRCREV = "7260e0e3fc2ea479e80e0962624aca7fd38a1f60" 22SRCREV = "6dcfe3a9362ae5fcf18e5cfb59663e43446cd59c"
23PV = "2015.1.0+git${SRCPV}" 23PV = "7.0.0+git${SRCPV}"
24 24
25S = "${WORKDIR}/git" 25S = "${WORKDIR}/git"
26 26
@@ -258,30 +258,44 @@ DEPENDS += " \
258 python-pbr \ 258 python-pbr \
259 " 259 "
260 260
261RDEPENDS_${PN} += "python-paste \ 261RDEPENDS_${PN} += " \
262 python-pastedeploy \ 262 python-pbr \
263 python-routes \ 263 python-paste \
264 python-amqplib \ 264 python-pastedeploy \
265 python-anyjson \ 265 python-debtcollector \
266 python-alembic \ 266 python-eventlet \
267 python-eventlet \ 267 python-pecan \
268 python-greenlet \ 268 python-greenlet \
269 python-httplib2 \ 269 python-httplib2 \
270 python-iso8601 \ 270 python-requests \
271 python-kombu \ 271 python-jinja2 \
272 python-netaddr \ 272 python-keystonemiddleware \
273 python-neutronclient \ 273 python-netaddr \
274 python-sqlalchemy \ 274 python-neutronclient \
275 python-webob \ 275 python-retrying \
276 python-keystoneclient \ 276 python-ryu \
277 python-oslo.config \ 277 python-sqlalchemy \
278 python-oslo.rootwrap \ 278 python-webob \
279 python-pyudev \ 279 python-keystoneclient \
280 python-novaclient \ 280 python-alembic \
281 python-mako \ 281 python-six \
282 python-markupsafe \ 282 python-stevedore \
283 python-pyparsing \ 283 python-oslo.concurrency \
284 python-pbr \ 284 python-oslo.config \
285 python-oslo.context \
286 python-oslo.db \
287 python-oslo.i18n \
288 python-oslo.log \
289 python-oslo.messaging \
290 python-oslo.middleware \
291 python-oslo.policy \
292 python-oslo.rootwrap \
293 python-oslo.serialization \
294 python-oslo.service \
295 python-oslo.utils \
296 python-oslo.versionedobjects \
297 python-novaclient \
298 python-routes \
285 " 299 "
286 300
287RDEPENDS_${SRCNAME} = "${PN} \ 301RDEPENDS_${SRCNAME} = "${PN} \
diff --git a/meta-openstack/recipes-devtools/python/python-neutronclient_git.bb b/meta-openstack/recipes-devtools/python/python-neutronclient_git.bb
index 16a2e92..bcbefaa 100644
--- a/meta-openstack/recipes-devtools/python/python-neutronclient_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-neutronclient_git.bb
@@ -9,24 +9,28 @@ DEPENDS += " \
9 python-pbr \ 9 python-pbr \
10 " 10 "
11 11
12RDEPENDS_${PN} +="python-cliff \ 12RDEPENDS_${PN} +="\
13 python-httplib2 \ 13 python-pbr \
14 python-iso8601 \ 14 python-cliff \
15 python-prettytable \ 15 python-iso8601 \
16 python-pyparsing \ 16 python-netaddr \
17 python-simplejson \ 17 python-oslo.i18n \
18 python-pbr \ 18 python-oslo.serialization \
19 python-oslo.utils \
20 python-requests \
21 python-keystoneclient \
22 python-simplejson \
23 python-six \
24 python-babel \
19 " 25 "
20 26
21PR = "r0"
22
23SRC_URI = "git://github.com/openstack/python-neutronclient.git;branch=master \ 27SRC_URI = "git://github.com/openstack/python-neutronclient.git;branch=master \
24 file://neutronclient-use-csv-flag-instead-of-json.patch \ 28 file://neutronclient-use-csv-flag-instead-of-json.patch \
25 file://neutron-api-check.sh \ 29 file://neutron-api-check.sh \
26 " 30 "
27 31
28PV = "2.4.0+git${SRCPV}" 32PV = "3.1.0+git${SRCPV}"
29SRCREV = "aa1215a5ad063b299d32ef319eb63d5210249a9b" 33SRCREV = "3e115991c1cf9ec7cf4252440fa8d6015a5f53ce"
30S = "${WORKDIR}/git" 34S = "${WORKDIR}/git"
31 35
32inherit setuptools monitor rmargparse 36inherit setuptools monitor rmargparse