summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Asselstine <asselsm@gmail.com>2016-02-03 20:41:05 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2016-02-05 14:42:17 -0500
commitac446f3bc8a6df622f3551952f055064847f6f0e (patch)
treea1673a657773054aacc6b0799bbaa8dff7ff90c5
parent529228a7d12d954ea4113879f8e9c200ebcc9ce8 (diff)
downloadmeta-cloud-services-ac446f3bc8a6df622f3551952f055064847f6f0e.tar.gz
python-oslo*: uprev to versions required by liberty
This set of updates is fairly straightforward, for the most part it is an update of the git SHA and an update of the dependencies. Signed-off-by: Mark Asselstine <asselsm@gmail.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-oslo.context_git.bb7
-rw-r--r--meta-openstack/recipes-devtools/python/python-oslo.log_git.bb12
-rw-r--r--meta-openstack/recipes-devtools/python/python-oslo.messaging_git.bb27
-rw-r--r--meta-openstack/recipes-devtools/python/python-oslo.serialization_git.bb12
-rw-r--r--meta-openstack/recipes-devtools/python/python-oslo.utils_git.bb15
5 files changed, 52 insertions, 21 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-oslo.context_git.bb b/meta-openstack/recipes-devtools/python/python-oslo.context_git.bb
index ec2651e..3543cae 100644
--- a/meta-openstack/recipes-devtools/python/python-oslo.context_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-oslo.context_git.bb
@@ -4,13 +4,11 @@ SECTION = "devel/python"
4LICENSE = "Apache-2.0" 4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2" 5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6 6
7PR = "r0"
8
9SRCNAME = "oslo.context" 7SRCNAME = "oslo.context"
10SRC_URI = "git://github.com/openstack/${SRCNAME}.git" 8SRC_URI = "git://github.com/openstack/${SRCNAME}.git"
11 9
12PV = "0.1.0" 10PV = "0.8.0+git${SRCPV}"
13SRCREV = "205479f254e2bc90c0c142f1f75df500ae94f916" 11SRCREV = "5e677dc2322618dc9b4ac7683b24f91e4e7f5ce2"
14S = "${WORKDIR}/git" 12S = "${WORKDIR}/git"
15 13
16inherit setuptools 14inherit setuptools
@@ -25,4 +23,5 @@ DEPENDS += " \
25RDEPENDS_${PN} += " \ 23RDEPENDS_${PN} += " \
26 bash \ 24 bash \
27 python-pbr \ 25 python-pbr \
26 python-babel \
28 " 27 "
diff --git a/meta-openstack/recipes-devtools/python/python-oslo.log_git.bb b/meta-openstack/recipes-devtools/python/python-oslo.log_git.bb
index bfcbe31..d4f7fe0 100644
--- a/meta-openstack/recipes-devtools/python/python-oslo.log_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-oslo.log_git.bb
@@ -4,13 +4,11 @@ SECTION = "devel/python"
4LICENSE = "Apache-2.0" 4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=34400b68072d710fecd0a2940a0d1658" 5LIC_FILES_CHKSUM = "file://LICENSE;md5=34400b68072d710fecd0a2940a0d1658"
6 6
7PR = "r0"
8
9SRCNAME = "oslo.log" 7SRCNAME = "oslo.log"
10SRC_URI = "git://github.com/openstack/${SRCNAME}.git" 8SRC_URI = "git://github.com/openstack/${SRCNAME}.git"
11 9
12PV = "0.3.0" 10PV = "1.13.0+git${SRCPV}"
13SRCREV = "5139941a0c8d63ae33421a2082e35fae0f800b67" 11SRCREV = "60d9aa05d45bf948106f79ad7257080a731af6c5"
14S = "${WORKDIR}/git" 12S = "${WORKDIR}/git"
15 13
16inherit setuptools 14inherit setuptools
@@ -25,10 +23,14 @@ DEPENDS += " \
25RDEPENDS_${PN} += " \ 23RDEPENDS_${PN} += " \
26 bash \ 24 bash \
27 python-pbr \ 25 python-pbr \
26 python-six \
27 python-babel \
28 python-iso8601 \ 28 python-iso8601 \
29 python-oslo.config \ 29 python-oslo.config \
30 python-oslo.context \ 30 python-oslo.context \
31 python-oslo.i18n \ 31 python-oslo.i18n \
32 python-oslo.utils \ 32 python-oslo.utils \
33 python-oslo.serialization\ 33 python-oslo.serialization \
34 python-pyinotify \
35 python-debtcollector \
34 " 36 "
diff --git a/meta-openstack/recipes-devtools/python/python-oslo.messaging_git.bb b/meta-openstack/recipes-devtools/python/python-oslo.messaging_git.bb
index 8841ec0..e6c8bf4 100644
--- a/meta-openstack/recipes-devtools/python/python-oslo.messaging_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-oslo.messaging_git.bb
@@ -4,13 +4,11 @@ SECTION = "devel/python"
4LICENSE = "Apache-2.0" 4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=c46f31914956e4579f9b488e71415ac8" 5LIC_FILES_CHKSUM = "file://LICENSE;md5=c46f31914956e4579f9b488e71415ac8"
6 6
7PR = "r0"
8
9SRCNAME = "oslo.messaging" 7SRCNAME = "oslo.messaging"
10SRC_URI = "git://github.com/openstack/${SRCNAME}.git" 8SRC_URI = "git://github.com/openstack/${SRCNAME}.git"
11 9
12PV = "1.6.0" 10PV = "2.7.0+git${SRCPV}"
13SRCREV = "68cd8cfecc12a40b61a7b8557aad7b5a4e1f1c6d" 11SRCREV = "4f49b7e25373d624ae9146dd46d92b90022c979f"
14S = "${WORKDIR}/git" 12S = "${WORKDIR}/git"
15 13
16inherit setuptools 14inherit setuptools
@@ -26,4 +24,25 @@ DEPENDS += " \
26RDEPENDS_${PN} += " \ 24RDEPENDS_${PN} += " \
27 bash \ 25 bash \
28 python-pbr \ 26 python-pbr \
27 python-cachetools \
28 python-trollius \
29 python-aioeventlet \
30 python-futurist \
31 python-oslo.config \
32 python-oslo.context \
33 python-oslo.log \
34 python-oslo.utils \
35 python-oslo.serialization \
36 python-oslo.middleware \
37 python-oslo.service \
38 python-oslo.i18n \
39 python-stevedore \
40 python-six \
41 python-eventlet \
42 python-greenlet \
43 python-webob \
44 python-pyyaml \
45 python-amqp \
46 python-kombu \
47 python-aioeventlet \
29 " 48 "
diff --git a/meta-openstack/recipes-devtools/python/python-oslo.serialization_git.bb b/meta-openstack/recipes-devtools/python/python-oslo.serialization_git.bb
index db2869c..32b1cc3 100644
--- a/meta-openstack/recipes-devtools/python/python-oslo.serialization_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-oslo.serialization_git.bb
@@ -4,13 +4,11 @@ SECTION = "devel/python"
4LICENSE = "Apache-2.0" 4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=34400b68072d710fecd0a2940a0d1658" 5LIC_FILES_CHKSUM = "file://LICENSE;md5=34400b68072d710fecd0a2940a0d1658"
6 6
7PR = "r0"
8
9SRCNAME = "oslo.serialization" 7SRCNAME = "oslo.serialization"
10SRC_URI = "git://github.com/openstack/${SRCNAME}.git" 8SRC_URI = "git://github.com/openstack/${SRCNAME}.git"
11 9
12PV = "1.3.0" 10PV = "1.11.0+git${SRCPV}"
13SRCREV = "c89b3f80393b224e4c93f546bc00a4a36c5fb279" 11SRCREV = "a8626ea9f9e37bf4129096cc2295f63516fb768e"
14S = "${WORKDIR}/git" 12S = "${WORKDIR}/git"
15 13
16inherit setuptools 14inherit setuptools
@@ -25,4 +23,10 @@ DEPENDS += " \
25# RDEPENDS_default: 23# RDEPENDS_default:
26RDEPENDS_${PN} += " \ 24RDEPENDS_${PN} += " \
27 python-pbr \ 25 python-pbr \
26 python-six \
27 python-babel \
28 python-iso8601 \
29 python-oslo.utils \
30 python-pytz \
31 python-msgpack \
28 " 32 "
diff --git a/meta-openstack/recipes-devtools/python/python-oslo.utils_git.bb b/meta-openstack/recipes-devtools/python/python-oslo.utils_git.bb
index 33c7e53..a833f6c 100644
--- a/meta-openstack/recipes-devtools/python/python-oslo.utils_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-oslo.utils_git.bb
@@ -4,13 +4,11 @@ SECTION = "devel/python"
4LICENSE = "Apache-2.0" 4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=34400b68072d710fecd0a2940a0d1658" 5LIC_FILES_CHKSUM = "file://LICENSE;md5=34400b68072d710fecd0a2940a0d1658"
6 6
7PR = "r0"
8
9SRCNAME = "oslo.utils" 7SRCNAME = "oslo.utils"
10SRC_URI = "git://github.com/openstack/${SRCNAME}.git" 8SRC_URI = "git://github.com/openstack/${SRCNAME}.git"
11 9
12PV = "1.3.0" 10PV = "2.7.0+git${SRCPV}"
13SRCREV = "ed4e2d775a56b9d47ed314f96dccd9221a91e241" 11SRCREV = "6aa24675e890e0bb61967a3e4c5e6aa8cf3dedcf"
14S = "${WORKDIR}/git" 12S = "${WORKDIR}/git"
15 13
16inherit setuptools 14inherit setuptools
@@ -25,4 +23,13 @@ DEPENDS += " \
25# RDEPENDS_default: 23# RDEPENDS_default:
26RDEPENDS_${PN} += " \ 24RDEPENDS_${PN} += " \
27 python-pbr \ 25 python-pbr \
26 python-babel \
27 python-six \
28 python-iso8601 \
29 python-oslo.i18n \
30 python-monotonic \
31 python-pytz \
32 python-netaddr \
33 python-netifaces \
34 python-debtcollector \
28 " 35 "