summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCollin Richards <collin.richards@ni.com>2016-06-20 17:21:56 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2016-06-21 09:36:42 -0400
commita896c8ee774ff56dccd58040f72f4a09e1b9fe9c (patch)
tree52644549233627e9d0fa6f425c31f6058eca9d4f
parent6873e619c795a3261dcf2c7ed3a04d826dec6de3 (diff)
downloadmeta-cloud-services-a896c8ee774ff56dccd58040f72f4a09e1b9fe9c.tar.gz
salt: Add the salt test suite
* Add salt-tests - package for salt test suite The salt test suite can be run from: /usr/lib/python2.7/site-packages/salt-tests/tests/runtests.py Signed-off-by: Collin Richards <collin.richards@ni.com> Natinst-ReviewBoard-ID: 142234 Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--meta-openstack/recipes-support/salt/salt_2016.3.0.bb11
1 files changed, 11 insertions, 0 deletions
diff --git a/meta-openstack/recipes-support/salt/salt_2016.3.0.bb b/meta-openstack/recipes-support/salt/salt_2016.3.0.bb
index f3bbdba..a99296a 100644
--- a/meta-openstack/recipes-support/salt/salt_2016.3.0.bb
+++ b/meta-openstack/recipes-support/salt/salt_2016.3.0.bb
@@ -35,7 +35,10 @@ S = "${WORKDIR}/${SRCNAME}-${PV}"
35 35
36inherit setuptools update-rc.d 36inherit setuptools update-rc.d
37 37
38# Note ${PN}-tests must be before ${PN}-common in the PACKAGES variable
39# in order for ${PN}-tests to own the correct FILES.
38PACKAGES += "\ 40PACKAGES += "\
41 ${PN}-tests \
39 ${PN}-api \ 42 ${PN}-api \
40 ${PN}-cloud \ 43 ${PN}-cloud \
41 ${PN}-common \ 44 ${PN}-common \
@@ -62,6 +65,9 @@ do_install_append() {
62 install -m 0644 ${WORKDIR}/cloud ${D}${sysconfdir}/${PN}/cloud 65 install -m 0644 ${WORKDIR}/cloud ${D}${sysconfdir}/${PN}/cloud
63 install -m 0644 ${WORKDIR}/roster ${D}${sysconfdir}/${PN}/roster 66 install -m 0644 ${WORKDIR}/roster ${D}${sysconfdir}/${PN}/roster
64 install -d ${D}${sysconfdir}/${PN}/cloud.conf.d ${D}${sysconfdir}/${PN}/cloud.profiles.d ${D}${sysconfdir}/${PN}/cloud.providers.d 67 install -d ${D}${sysconfdir}/${PN}/cloud.conf.d ${D}${sysconfdir}/${PN}/cloud.profiles.d ${D}${sysconfdir}/${PN}/cloud.providers.d
68
69 install -d ${D}${PYTHON_SITEPACKAGES_DIR}/${PN}-tests/
70 cp -r ${S}/tests/ ${D}${PYTHON_SITEPACKAGES_DIR}/${PN}-tests/
65} 71}
66 72
67ALLOW_EMPTY_${PN} = "1" 73ALLOW_EMPTY_${PN} = "1"
@@ -147,4 +153,9 @@ RSUGGESTS_${PN}-cloud = "python-netaddr python-botocore"
147CONFFILES_${PN}-cloud = "${sysconfdir}/${PN}/cloud" 153CONFFILES_${PN}-cloud = "${sysconfdir}/${PN}/cloud"
148FILES_${PN}-cloud = "${bindir}/${PN}-cloud ${sysconfdir}/${PN}/cloud.conf.d/ ${sysconfdir}/${PN}/cloud.profiles.d/ ${sysconfdir}/${PN}/cloud.providers.d/ ${CONFFILES_${PN}-cloud}" 154FILES_${PN}-cloud = "${bindir}/${PN}-cloud ${sysconfdir}/${PN}/cloud.conf.d/ ${sysconfdir}/${PN}/cloud.profiles.d/ ${sysconfdir}/${PN}/cloud.providers.d/ ${CONFFILES_${PN}-cloud}"
149 155
156SUMMARY_${PN}-tests = "salt stack test suite"
157DESCRIPTION_${PN}-tests ="${DESCRIPTION_COMMON} This particular package provides the salt unit test suite."
158RDEPENDS_${PN}-tests = "${PN}-common python-salttesting python-tests python-image bash"
159FILES_${PN}-tests = "${PYTHON_SITEPACKAGES_DIR}/salt-tests/tests/"
160
150FILES_${PN}-bash-completion = "${sysconfdir}/bash_completion.d/${PN}-common" 161FILES_${PN}-bash-completion = "${sysconfdir}/bash_completion.d/${PN}-common"