summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2016-02-03 20:41:43 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2016-02-05 14:42:18 -0500
commita833f549270c3707fb6521b0571c23e76e0ecc9b (patch)
tree2c13d3cb430219174b0f584429aa402947b6ac3d
parent62cf4f5a509fd0278c1de998fba8cfa6cbfeded7 (diff)
downloadmeta-cloud-services-a833f549270c3707fb6521b0571c23e76e0ecc9b.tar.gz
keystone: uprev to Liberty
Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-keystone_git.bb13
-rw-r--r--meta-openstack/recipes-devtools/python/python-keystoneclient_git.bb6
-rw-r--r--meta-openstack/recipes-devtools/python/python-keystonemiddleware_git.bb5
3 files changed, 12 insertions, 12 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-keystone_git.bb b/meta-openstack/recipes-devtools/python/python-keystone_git.bb
index 58aa449..a8d1181 100644
--- a/meta-openstack/recipes-devtools/python/python-keystone_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-keystone_git.bb
@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6 6
7SRCNAME = "keystone" 7SRCNAME = "keystone"
8 8
9SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=stable/kilo \ 9SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=master \
10 file://keystone.conf \ 10 file://keystone.conf \
11 file://identity.sh \ 11 file://identity.sh \
12 file://keystone \ 12 file://keystone \
@@ -19,8 +19,8 @@ SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=stable/kilo \
19# file://keystone-remove-git-commands-in-tests.patch 19# file://keystone-remove-git-commands-in-tests.patch
20# file://keystone-explicitly-import-localcontext-from-oslo.me.patch 20# file://keystone-explicitly-import-localcontext-from-oslo.me.patch
21 21
22SRCREV = "5d3b31f9c3d34599ff8a83eeb7530fc6e0b1b67b" 22SRCREV = "8dcd82fb9c76d43f26338bee293b32f4af473ad9"
23PV = "2015.1.0+git${SRCPV}" 23PV = "8.0.0+git${SRCPV}"
24 24
25S = "${WORKDIR}/git" 25S = "${WORKDIR}/git"
26 26
@@ -144,9 +144,6 @@ do_install_append() {
144 -i ${KEYSTONE_PACKAGE_DIR}/tests/test_overrides.conf 144 -i ${KEYSTONE_PACKAGE_DIR}/tests/test_overrides.conf
145 fi 145 fi
146 146
147 cp run_tests.sh ${KEYSTONE_CONF_DIR}
148
149
150 if ${@base_contains('DISTRO_FEATURES', 'OpenLDAP', 'true', 'false', d)}; 147 if ${@base_contains('DISTRO_FEATURES', 'OpenLDAP', 'true', 'false', d)};
151 then 148 then
152 sed -i -e '/^\[identity\]/a \ 149 sed -i -e '/^\[identity\]/a \
@@ -287,6 +284,10 @@ RDEPENDS_${PN} += " \
287 python-fixtures \ 284 python-fixtures \
288 python-oslotest \ 285 python-oslotest \
289 python-functools32 \ 286 python-functools32 \
287 python-six \
288 python-routes \
289 python-pycadf \
290 python-cryptography \
290 " 291 "
291 292
292RDEPENDS_${SRCNAME}-tests += " bash" 293RDEPENDS_${SRCNAME}-tests += " bash"
diff --git a/meta-openstack/recipes-devtools/python/python-keystoneclient_git.bb b/meta-openstack/recipes-devtools/python/python-keystoneclient_git.bb
index f4810e5..495f1e3 100644
--- a/meta-openstack/recipes-devtools/python/python-keystoneclient_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-keystoneclient_git.bb
@@ -4,7 +4,6 @@ SECTION = "devel/python"
4LICENSE = "Apache-2.0" 4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=4a4d0e932ffae1c0131528d30d419c55" 5LIC_FILES_CHKSUM = "file://LICENSE;md5=4a4d0e932ffae1c0131528d30d419c55"
6 6
7PR = "r0"
8SRCNAME = "keystoneclient" 7SRCNAME = "keystoneclient"
9 8
10SRC_URI = "\ 9SRC_URI = "\
@@ -13,8 +12,8 @@ SRC_URI = "\
13 file://keystone-api-check.sh \ 12 file://keystone-api-check.sh \
14 " 13 "
15 14
16PV = "1.6.0+git${SRCPV}" 15PV = "1.7.1+git${SRCPV}"
17SRCREV = "f6ab133f25f00e041cd84aa8bbfb422594d1942f" 16SRCREV = "28138b588224c6b0503620ac2e24bd37dad25370"
18S = "${WORKDIR}/git" 17S = "${WORKDIR}/git"
19 18
20inherit setuptools monitor rmargparse 19inherit setuptools monitor rmargparse
@@ -34,6 +33,7 @@ RDEPENDS_${PN} += " \
34 python-oslo.config \ 33 python-oslo.config \
35 python-oslo.serialization \ 34 python-oslo.serialization \
36 python-pbr \ 35 python-pbr \
36 python-argparse \
37 " 37 "
38 38
39PACKAGECONFIG ?= "bash-completion" 39PACKAGECONFIG ?= "bash-completion"
diff --git a/meta-openstack/recipes-devtools/python/python-keystonemiddleware_git.bb b/meta-openstack/recipes-devtools/python/python-keystonemiddleware_git.bb
index 35c5b49..50d3d95 100644
--- a/meta-openstack/recipes-devtools/python/python-keystonemiddleware_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-keystonemiddleware_git.bb
@@ -4,15 +4,14 @@ SECTION = "devel/python"
4LICENSE = "Apache-2.0" 4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=4a4d0e932ffae1c0131528d30d419c55" 5LIC_FILES_CHKSUM = "file://LICENSE;md5=4a4d0e932ffae1c0131528d30d419c55"
6 6
7PR = "r0"
8SRCNAME = "keystonemiddleware" 7SRCNAME = "keystonemiddleware"
9 8
10SRC_URI = "\ 9SRC_URI = "\
11 git://git.openstack.org/openstack/keystonemiddleware;branch=master \ 10 git://git.openstack.org/openstack/keystonemiddleware;branch=master \
12 " 11 "
13 12
14PV = "1.6.1+git${SRCPV}" 13PV = "2.3.0+git${SRCPV}"
15SRCREV = "6ff732b3893a7e71f7b9a7318e8a4daaf906ebbf" 14SRCREV = "62805857ea39710ba14ab9a4e6c606dc336c6b56"
16S = "${WORKDIR}/git" 15S = "${WORKDIR}/git"
17 16
18inherit setuptools 17inherit setuptools