summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2016-02-03 20:41:34 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2016-02-05 14:42:18 -0500
commit6dc7b04104dc4fc8240621b4b98cce9c5799eff9 (patch)
tree020816f2844fc72105797e26fb5ee4fb5fba99d5
parent0b712214df95d079962cb5682ca75924c9c86ffc (diff)
downloadmeta-cloud-services-6dc7b04104dc4fc8240621b4b98cce9c5799eff9.tar.gz
glance: uprev to Liberty
Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-glance_git.bb31
-rw-r--r--meta-openstack/recipes-devtools/python/python-glanceclient_git.bb5
-rw-r--r--meta-openstack/recipes-devtools/python/python-glancestore_git.bb4
3 files changed, 30 insertions, 10 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-glance_git.bb b/meta-openstack/recipes-devtools/python/python-glance_git.bb
index 79235af..e6f5f5f 100644
--- a/meta-openstack/recipes-devtools/python/python-glance_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-glance_git.bb
@@ -4,18 +4,17 @@ SECTION = "devel/python"
4LICENSE = "Apache-2.0" 4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2" 5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6 6
7PR = "r0"
8SRCNAME = "glance" 7SRCNAME = "glance"
9 8
10SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=stable/kilo \ 9SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=master \
11 file://glance.init \ 10 file://glance.init \
12 " 11 "
13 12
14# removed. juno uses store library: file://0001-glance-store-only-load-known-stores-not-all-stores.patch 13# removed. juno uses store library: file://0001-glance-store-only-load-known-stores-not-all-stores.patch
15# file://glance-change-builtin-tests-config-location.patch 14# file://glance-change-builtin-tests-config-location.patch
16 15
17SRCREV = "93b0d5fce3a41e4a3a549f98f78b6681cbc3ea95" 16SRCREV = "69516fad5f651a085a047a337a05c58b39023c1b"
18PV = "2015.1.0+git${SRCPV}" 17PV = "11.0.0+git${SRCPV}"
19 18
20S = "${WORKDIR}/git" 19S = "${WORKDIR}/git"
21 20
@@ -150,7 +149,10 @@ pkg_postinst_${SRCNAME}-setup () {
150PACKAGES += " ${SRCNAME}-tests ${SRCNAME} ${SRCNAME}-setup ${SRCNAME}-api ${SRCNAME}-registry" 149PACKAGES += " ${SRCNAME}-tests ${SRCNAME} ${SRCNAME}-setup ${SRCNAME}-api ${SRCNAME}-registry"
151ALLOW_EMPTY_${SRCNAME}-setup = "1" 150ALLOW_EMPTY_${SRCNAME}-setup = "1"
152 151
153FILES_${PN} = "${libdir}/*" 152FILES_${PN} = " \
153 ${libdir}/* \
154 ${datadir}/etc/${SRCNAME}* \
155 "
154 156
155FILES_${SRCNAME}-tests = "${sysconfdir}/${SRCNAME}/run_tests.sh" 157FILES_${SRCNAME}-tests = "${sysconfdir}/${SRCNAME}/run_tests.sh"
156 158
@@ -201,6 +203,25 @@ RDEPENDS_${PN} += "python-greenlet \
201 python-enum34 \ 203 python-enum34 \
202 python-semantic-version \ 204 python-semantic-version \
203 python-oslo.vmware \ 205 python-oslo.vmware \
206 python-oslo.concurrency \
207 python-oslo.context \
208 python-oslo.service \
209 python-oslo.utils \
210 python-stevedore \
211 python-futurist \
212 python-taskflow \
213 python-keystonemiddleware \
214 python-wsme \
215 python-pyopenssl \
216 python-six \
217 python-oslo.db \
218 python-oslo.log \
219 python-oslo.messaging \
220 python-oslo.middleware \
221 python-oslo.policy \
222 python-oslo.serialization \
223 python-castellan \
224 python-cryptography \
204 " 225 "
205 226
206RDEPENDS_${SRCNAME} = "${PN} \ 227RDEPENDS_${SRCNAME} = "${PN} \
diff --git a/meta-openstack/recipes-devtools/python/python-glanceclient_git.bb b/meta-openstack/recipes-devtools/python/python-glanceclient_git.bb
index ab32be8..f9edf6d 100644
--- a/meta-openstack/recipes-devtools/python/python-glanceclient_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-glanceclient_git.bb
@@ -9,9 +9,8 @@ DEPENDS += " \
9 python-pbr \ 9 python-pbr \
10 " 10 "
11 11
12SRCREV = "db6420b44779411d6d1f238f6b887f83f1988986" 12SRCREV = "86635868c1eb3aec0c065c12cb9928c613940f36"
13PV = "0.19.0+git${SRCPV}" 13PV = "1.1.0+git${SRCPV}"
14PR = "r0"
15 14
16SRC_URI = "\ 15SRC_URI = "\
17 git://github.com/openstack/${BPN}.git;protocol=https \ 16 git://github.com/openstack/${BPN}.git;protocol=https \
diff --git a/meta-openstack/recipes-devtools/python/python-glancestore_git.bb b/meta-openstack/recipes-devtools/python/python-glancestore_git.bb
index 932c5d9..0abf521 100644
--- a/meta-openstack/recipes-devtools/python/python-glancestore_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-glancestore_git.bb
@@ -4,8 +4,8 @@ SECTION = "devel/python"
4LICENSE = "Apache-2.0" 4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2" 5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6 6
7SRCREV = "ea88e503b617a7ac9a0ae7e537d6517e9992a104" 7SRCREV = "c816b38d9f12be75d989409cbab6dfefa8f49dc3"
8PV = "0.4.0+git${SRCPV}" 8PV = "0.9.1+git${SRCPV}"
9 9
10SRC_URI = "\ 10SRC_URI = "\
11 git://github.com/openstack/glance_store.git \ 11 git://github.com/openstack/glance_store.git \