summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCollin Richards <collin.richards@ni.com>2016-06-20 17:21:55 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2016-06-21 09:36:42 -0400
commit6873e619c795a3261dcf2c7ed3a04d826dec6de3 (patch)
treeb2016cde1c229da015571fa79cdea732d0cb4406
parent454b16a0b9734bf9908d64e5a6fdca0023df474b (diff)
downloadmeta-cloud-services-6873e619c795a3261dcf2c7ed3a04d826dec6de3.tar.gz
python-salttesting: initial version
This package provides testing tools used by the salt project. Signed-off-by: Collin Richards <collin.richards@ni.com> Natinst-ReviewBoard-ID: 142234 Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-salttesting_2015.2.16.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-salttesting_2015.2.16.bb b/meta-openstack/recipes-devtools/python/python-salttesting_2015.2.16.bb
new file mode 100644
index 0000000..78ad879
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-salttesting_2015.2.16.bb
@@ -0,0 +1,20 @@
1SUMMARY = "Common testing tools used in the Salt Stack projects"
2HOMEPAGE = "https://github.com/saltstack/salt-testing"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=f36f1e9e3e30f90180efdf7e40d943e5"
6SRCNAME = "salt-testing"
7
8SRC_URI = "https://github.com/saltstack/salt-testing/archive/v${PV}.tar.gz;downloadfilename=salt-testing-v${PV}.tar.gz"
9SRC_URI[md5sum] = "8ca55a796e9ad7ba72bc143043753ccf"
10SRC_URI[sha256sum] = "0ef4be6a8a9b505ae1c328394dfad50493674af6100c7e2c220f374533d86edc"
11
12S = "${WORKDIR}/${SRCNAME}-${PV}"
13
14RDEPENDS_${PN} = "\
15 python-mock \
16 python-unittest \
17"
18
19inherit setuptools
20