summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2016-02-03 20:41:37 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2016-02-05 14:42:18 -0500
commit5ac5951e2066a18541e50758d5177a2872299401 (patch)
tree4d45fd543868c91daaf02452b4505a856c0bb460
parent527c2cbc8999cf2ea6a69db777b29da15c7a6ccf (diff)
downloadmeta-cloud-services-5ac5951e2066a18541e50758d5177a2872299401.tar.gz
heat: uprev to Liberty
Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-heat_git.bb42
1 files changed, 37 insertions, 5 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-heat_git.bb b/meta-openstack/recipes-devtools/python/python-heat_git.bb
index 7abb4d0..c2b2da7 100644
--- a/meta-openstack/recipes-devtools/python/python-heat_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-heat_git.bb
@@ -4,10 +4,9 @@ SECTION = "devel/python"
4LICENSE = "Apache-2.0" 4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2" 5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6 6
7PR = "r0"
8SRCNAME = "heat" 7SRCNAME = "heat"
9 8
10SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=stable/kilo \ 9SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=master \
11 file://heat.conf \ 10 file://heat.conf \
12 file://heat.init \ 11 file://heat.init \
13 file://autoscaling_example.template \ 12 file://autoscaling_example.template \
@@ -16,8 +15,8 @@ SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=stable/kilo \
16 file://heat-tests-change-project_dir-path.patch \ 15 file://heat-tests-change-project_dir-path.patch \
17" 16"
18 17
19SRCREV = "6db88597dba0b79b2501f43b704c93b2728a5ec6" 18SRCREV = "4348b7ababd1048e17ec354ca38c903c908cd74e"
20PV = "2015.1.0+git${SRCPV}" 19PV = "5.0.0+git${SRCPV}"
21S = "${WORKDIR}/git" 20S = "${WORKDIR}/git"
22 21
23SERVICECREATE_PACKAGES = "${SRCNAME}-setup ${SRCNAME}-templates ${SRCNAME}-cfn" 22SERVICECREATE_PACKAGES = "${SRCNAME}-setup ${SRCNAME}-templates ${SRCNAME}-cfn"
@@ -184,7 +183,7 @@ RDEPENDS_${PN} += " \
184 python-paste \ 183 python-paste \
185 python-sqlalchemy-migrate \ 184 python-sqlalchemy-migrate \
186 python-stevedore \ 185 python-stevedore \
187 python-suds \ 186 python-suds-jurko \
188 python-paramiko \ 187 python-paramiko \
189 python-babel \ 188 python-babel \
190 python-iso8601 \ 189 python-iso8601 \
@@ -213,6 +212,39 @@ RDEPENDS_${PN} += " \
213 python-pytz \ 212 python-pytz \
214 python-pbr \ 213 python-pbr \
215 python-oslo.log \ 214 python-oslo.log \
215 python-croniter \
216 python-cryptography \
217 python-keystonemiddleware \
218 python-netaddr \
219 python-oslo.cache \
220 python-oslo.concurrency \
221 python-oslo.context \
222 python-oslo.db \
223 python-oslo.i18n \
224 python-oslo.messaging \
225 python-oslo.middleware \
226 python-oslo.policy \
227 python-oslo.reports \
228 python-oslo.serialization \
229 python-oslo.service \
230 python-oslo.utils \
231 python-osprofiler \
232 python-oslo.versionedobjects \
233 python-pycrypto \
234 python-barbicanclient \
235 python-ceilometerclient \
236 python-cinderclient \
237 python-designateclient \
238 python-magnumclient \
239 python-manilaclient \
240 python-mistralclient \
241 python-neutronclient \
242 python-novaclient \
243 python-saharaclient \
244 python-troveclient \
245 python-zaqarclient \
246 python-requests \
247 python-six \
216 " 248 "
217 249
218RDEPENDS_${SRCNAME}-engine = "${PN} ${SRCNAME}-templates ${SRCNAME}-common postgresql postgresql-client python-psycopg2 tgt ${SRCNAME}-cfn" 250RDEPENDS_${SRCNAME}-engine = "${PN} ${SRCNAME}-templates ${SRCNAME}-common postgresql postgresql-client python-psycopg2 tgt ${SRCNAME}-cfn"