summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2016-02-03 20:41:36 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2016-02-05 14:42:18 -0500
commit527c2cbc8999cf2ea6a69db777b29da15c7a6ccf (patch)
tree14f0f58e83bfc764bd79182dfde0e64a5b47c78b
parent1bc9251fec740a9b1304d9de9921673a2799d7fd (diff)
downloadmeta-cloud-services-527c2cbc8999cf2ea6a69db777b29da15c7a6ccf.tar.gz
cinder: uprev to Liberty
Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-cinder_git.bb50
-rw-r--r--meta-openstack/recipes-devtools/python/python-cinderclient_git.bb8
2 files changed, 45 insertions, 13 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-cinder_git.bb b/meta-openstack/recipes-devtools/python/python-cinder_git.bb
index ceb17d8..7e689e7 100644
--- a/meta-openstack/recipes-devtools/python/python-cinder_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-cinder_git.bb
@@ -4,10 +4,9 @@ SECTION = "devel/python"
4LICENSE = "Apache-2.0" 4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2" 5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6 6
7PR = "r0"
8SRCNAME = "cinder" 7SRCNAME = "cinder"
9 8
10SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=stable/kilo \ 9SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=master \
11 file://cinder.conf \ 10 file://cinder.conf \
12 file://cinder.init \ 11 file://cinder.init \
13 file://cinder-volume \ 12 file://cinder-volume \
@@ -15,14 +14,14 @@ SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=stable/kilo \
15 file://glusterfs_setup.sh \ 14 file://glusterfs_setup.sh \
16 file://lvm_iscsi_setup.sh \ 15 file://lvm_iscsi_setup.sh \
17 file://add-cinder-volume-types.sh \ 16 file://add-cinder-volume-types.sh \
18 file://cinder-builtin-tests-config-location.patch \
19 " 17 "
20 18
21# file://0001-run_tests-respect-tools-dir.patch 19# file://0001-run_tests-respect-tools-dir.patch
22# file://fix_cinder_memory_leak.patch 20# file://fix_cinder_memory_leak.patch
21# file://cinder-builtin-tests-config-location.patch
23 22
24SRCREV = "5987bb2290f629e59b0bcced2f8fe22cdeb9cc6d" 23SRCREV = "61026d4e4f2a58dd84ffb2e4e40ab99860b9316a"
25PV = "2015.1.0+git${SRCPV}" 24PV = "7.0.0+git${SRCPV}"
26S = "${WORKDIR}/git" 25S = "${WORKDIR}/git"
27 26
28inherit setuptools update-rc.d identity default_configs hosts openstackchef monitor 27inherit setuptools update-rc.d identity default_configs hosts openstackchef monitor
@@ -49,9 +48,9 @@ python () {
49} 48}
50SERVICECREATE_PACKAGES[vardeps] += "KEYSTONE_HOST" 49SERVICECREATE_PACKAGES[vardeps] += "KEYSTONE_HOST"
51 50
52do_install_prepend() { 51#do_install_prepend() {
53 sed 's:%PYTHON_SITEPACKAGES_DIR%:${PYTHON_SITEPACKAGES_DIR}:g' -i ${S}/${SRCNAME}/tests/conf_fixture.py 52# sed 's:%PYTHON_SITEPACKAGES_DIR%:${PYTHON_SITEPACKAGES_DIR}:g' -i ${S}/${SRCNAME}/tests/conf_fixture.py
54} 53#}
55 54
56CINDER_LVM_VOLUME_BACKING_FILE_SIZE ?= "2G" 55CINDER_LVM_VOLUME_BACKING_FILE_SIZE ?= "2G"
57CINDER_NFS_VOLUME_SERVERS_DEFAULT = "controller:/etc/cinder/nfs_volumes" 56CINDER_NFS_VOLUME_SERVERS_DEFAULT = "controller:/etc/cinder/nfs_volumes"
@@ -162,7 +161,7 @@ pkg_postinst_${SRCNAME}-setup () {
162PACKAGES += "${SRCNAME}-tests ${SRCNAME} ${SRCNAME}-setup ${SRCNAME}-api ${SRCNAME}-volume ${SRCNAME}-scheduler ${SRCNAME}-backup" 161PACKAGES += "${SRCNAME}-tests ${SRCNAME} ${SRCNAME}-setup ${SRCNAME}-api ${SRCNAME}-volume ${SRCNAME}-scheduler ${SRCNAME}-backup"
163ALLOW_EMPTY_${SRCNAME}-setup = "1" 162ALLOW_EMPTY_${SRCNAME}-setup = "1"
164 163
165RDEPENDS_${SRCNAME}-tests += " bash" 164RDEPENDS_${SRCNAME}-tests += " bash python"
166 165
167FILES_${PN} = "${libdir}/* /etc/tgt" 166FILES_${PN} = "${libdir}/* /etc/tgt"
168 167
@@ -207,7 +206,7 @@ RDEPENDS_${PN} += "lvm2 \
207 python-paste \ 206 python-paste \
208 python-sqlalchemy-migrate \ 207 python-sqlalchemy-migrate \
209 python-stevedore \ 208 python-stevedore \
210 python-suds \ 209 python-suds-jurko \
211 python-paramiko \ 210 python-paramiko \
212 python-babel \ 211 python-babel \
213 python-iso8601 \ 212 python-iso8601 \
@@ -218,9 +217,40 @@ RDEPENDS_${PN} += "lvm2 \
218 python-cinderclient \ 217 python-cinderclient \
219 python-oslo.config \ 218 python-oslo.config \
220 python-oslo.rootwrap \ 219 python-oslo.rootwrap \
220 python-oslo.concurrency \
221 python-oslo.context \
222 python-oslo.db \
223 python-oslo.log \
224 python-oslo.messaging \
225 python-oslo.middleware \
226 python-oslo.policy \
227 python-oslo.reports \
228 python-oslo.serialization \
229 python-oslo.service \
230 python-oslo.utils \
231 python-oslo.versionedobjects \
221 python-pbr \ 232 python-pbr \
222 python-taskflow \ 233 python-taskflow \
223 python-rtslib-fb \ 234 python-rtslib-fb \
235 python-keystonemiddleware \
236 python-netaddr \
237 python-osprofiler \
238 python-pycrypto \
239 python-pyparsing \
240 python-barbicanclient \
241 python-glanceclient \
242 python-novaclient \
243 python-swiftclient \
244 python-requests \
245 python-retrying \
246 python-taskflow \
247 python-rtslib-fb \
248 python-six \
249 python-oslo.i18n \
250 python-oslo.vmware \
251 python-os-brick \
252 python-enum34 \
253 python-routes \
224 " 254 "
225 255
226RDEPENDS_${SRCNAME} = "${PN} \ 256RDEPENDS_${SRCNAME} = "${PN} \
diff --git a/meta-openstack/recipes-devtools/python/python-cinderclient_git.bb b/meta-openstack/recipes-devtools/python/python-cinderclient_git.bb
index 7e8e780..e264694 100644
--- a/meta-openstack/recipes-devtools/python/python-cinderclient_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-cinderclient_git.bb
@@ -5,7 +5,6 @@ LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=3572962e13e5e739b30b0864365e0795" 5LIC_FILES_CHKSUM = "file://LICENSE;md5=3572962e13e5e739b30b0864365e0795"
6DEPENDS = "python-setuptools-git" 6DEPENDS = "python-setuptools-git"
7 7
8PR = "r0"
9SRCNAME = "python-cinderclient" 8SRCNAME = "python-cinderclient"
10 9
11SRC_URI = "\ 10SRC_URI = "\
@@ -14,8 +13,8 @@ SRC_URI = "\
14 file://cinder-api-check.sh \ 13 file://cinder-api-check.sh \
15 " 14 "
16 15
17PV="1.1.1+git${SRCPV}" 16PV="1.4.0+git${SRCPV}"
18SRCREV="9e94d814c6ae07c3d5e8242754aebcce150265cc" 17SRCREV="c167dda40cc65fe437a12b815ef91bbde4efb6bb"
19S = "${WORKDIR}/git" 18S = "${WORKDIR}/git"
20 19
21inherit setuptools monitor rmargparse 20inherit setuptools monitor rmargparse
@@ -30,6 +29,9 @@ RDEPENDS_${PN} += "python-prettytable \
30 python-requests \ 29 python-requests \
31 python-setuptools-git \ 30 python-setuptools-git \
32 python-pbr \ 31 python-pbr \
32 python-keystoneclient \
33 python-babel \
34 python-six \
33 " 35 "
34 36
35PACKAGECONFIG ?= "bash-completion" 37PACKAGECONFIG ?= "bash-completion"