summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Asselstine <asselsm@gmail.com>2016-02-03 20:41:40 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2016-02-05 14:42:18 -0500
commit35583d3dafa9894aeb27c6fc6177a4ed9dc89a09 (patch)
treeaa1fbe1aabe84c5a072636653e652dc5061cf956
parentedaa3d6e6b4a94f073b19df6cd2d2ea1f18e37d9 (diff)
downloadmeta-cloud-services-35583d3dafa9894aeb27c6fc6177a4ed9dc89a09.tar.gz
horizon: uprev to Liberty
Signed-off-by: Mark Asselstine <asselsm@gmail.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-horizon_git.bb119
1 files changed, 63 insertions, 56 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-horizon_git.bb b/meta-openstack/recipes-devtools/python/python-horizon_git.bb
index cf62d44..2a96190 100644
--- a/meta-openstack/recipes-devtools/python/python-horizon_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-horizon_git.bb
@@ -9,72 +9,79 @@ DEPENDS += " \
9 python-pbr \ 9 python-pbr \
10 " 10 "
11 11
12RDEPENDS_${PN} += " python-django \ 12RDEPENDS_${PN} += " \
13 python-django-appconf \ 13 python-pbr \
14 python-django-compressor \ 14 python-babel \
15 python-django-nose \ 15 python-django \
16 python-django-openstack-auth \ 16 python-pint \
17 python-netaddr \ 17 python-django-babel \
18 python-ceilometerclient \ 18 python-django-compressor \
19 python-cinderclient \ 19 python-django-openstack-auth \
20 python-glanceclient \ 20 python-django-pyscss \
21 python-heatclient \ 21 python-eventlet \
22 python-keystoneclient \ 22 python-httplib2 \
23 python-troveclient \ 23 python-iso8601 \
24 python-saharaclient \ 24 python-kombu \
25 python-lesscpy \ 25 python-netaddr \
26 python-novaclient \ 26 python-oslo.concurrency \
27 python-nose-exclude \ 27 python-oslo.config \
28 python-neutronclient \ 28 python-oslo.i18n \
29 python-pytz \ 29 python-oslo.policy \
30 python-pbr \ 30 python-oslo.serialization \
31 python-six \ 31 python-oslo.utils \
32 python-swiftclient \ 32 python-pyscss \
33 python-lockfile \ 33 python-ceilometerclient \
34 python-pyyaml \ 34 python-cinderclient \
35 python-pint \ 35 python-glanceclient \
36 python-xstatic \ 36 python-heatclient \
37 python-xstatic-jquery \ 37 python-keystoneclient \
38 python-xstatic-angular \ 38 python-neutronclient \
39 python-xstatic-angular-cookies \ 39 python-novaclient \
40 python-xstatic-angular-mock \ 40 python-saharaclient \
41 python-xstatic-angular-bootstrap \ 41 python-swiftclient \
42 python-xstatic-angular-irdragndrop \ 42 python-troveclient \
43 python-xstatic-angular-lrdragndrop \ 43 python-pytz \
44 python-xstatic-magic-search \ 44 python-pyyaml \
45 python-xstatic-d3 \ 45 python-six \
46 python-xstatic-hogan \ 46 python-xstatic \
47 python-xstatic-jasmine \ 47 python-xstatic-angular \
48 python-xstatic-jquery-migrate \ 48 python-xstatic-angular-bootstrap \
49 python-xstatic-jquery-quicksearch \ 49 python-xstatic-angular-gettext \
50 python-xstatic-jquery-tablesorter \ 50 python-xstatic-angular-lrdragndrop \
51 python-xstatic-jsencrypt \ 51 python-xstatic-bootstrap-datepicker \
52 python-xstatic-qunit \ 52 python-xstatic-bootstrap-scss \
53 python-xstatic-rickshaw \ 53 python-xstatic-bootswatch \
54 python-xstatic-spin \ 54 python-xstatic-d3 \
55 python-xstatic-bootstrap-datepicker \ 55 python-xstatic-hogan \
56 python-xstatic-bootstrap-scss \ 56 python-xstatic-font-awesome \
57 python-xstatic-font-awesome \ 57 python-xstatic-jasmine \
58 python-xstatic-jquery-ui \ 58 python-xstatic-jquery \
59 python-xstatic-smart-table \ 59 python-xstatic-jquery-migrate \
60 python-xstatic-term.js \ 60 python-xstatic-jquery-quicksearch \
61 python-pyscss \ 61 python-xstatic-jquery-tablesorter \
62 python-django-pyscss \ 62 python-xstatic-jquery-ui \
63 " 63 python-xstatic-jsencrypt \
64 python-xstatic-magic-search \
65 python-xstatic-mdi \
66 python-xstatic-rickshaw \
67 python-xstatic-roboto-fontface \
68 python-xstatic-smart-table \
69 python-xstatic-spin \
70 python-xstatic-term.js \
71 "
64 72
65SRCNAME = "horizon" 73SRCNAME = "horizon"
66 74
67SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=stable/kilo \ 75SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=master \
68 file://horizon.init \ 76 file://horizon.init \
69 file://fix_bindir_path.patch \ 77 file://fix_bindir_path.patch \
70 file://openstack-dashboard-apache.conf \ 78 file://openstack-dashboard-apache.conf \
71 file://local_settings.py \ 79 file://local_settings.py \
72 file://horizon-use-full-package-path-to-test-directories.patch \ 80 file://horizon-use-full-package-path-to-test-directories.patch \
73 file://Compatibility-fix-for-pyscss-1.3.4.patch \
74 " 81 "
75 82
76SRCREV = "b99cf48ff346494198fb9740495eacc14fa406bf" 83SRCREV = "593f0b78eea8efbb6d833d66acc7ab4dc852159b"
77PV = "2015.1.0+git${SRCPV}p1" 84PV = "8.0.0+git${SRCPV}"
78S = "${WORKDIR}/git" 85S = "${WORKDIR}/git"
79 86
80inherit setuptools update-rc.d python-dir default_configs openstackchef monitor 87inherit setuptools update-rc.d python-dir default_configs openstackchef monitor