summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2016-02-03 20:41:35 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2016-02-05 14:42:18 -0500
commit1bc9251fec740a9b1304d9de9921673a2799d7fd (patch)
tree199286f88403fdde6c6dfdbcf406cdc25ac8469f
parent6dc7b04104dc4fc8240621b4b98cce9c5799eff9 (diff)
downloadmeta-cloud-services-1bc9251fec740a9b1304d9de9921673a2799d7fd.tar.gz
ceilometer: uprev to Liberty
Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-ceilometer_git.bb30
-rw-r--r--meta-openstack/recipes-devtools/python/python-ceilometerclient_git.bb18
2 files changed, 37 insertions, 11 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-ceilometer_git.bb b/meta-openstack/recipes-devtools/python/python-ceilometer_git.bb
index 3860ca5..2825e60 100644
--- a/meta-openstack/recipes-devtools/python/python-ceilometer_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-ceilometer_git.bb
@@ -4,10 +4,9 @@ SECTION = "devel/python"
4LICENSE = "Apache-2.0" 4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2" 5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6 6
7PR = "r0"
8SRCNAME = "ceilometer" 7SRCNAME = "ceilometer"
9 8
10SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=stable/kilo \ 9SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=master \
11 file://ceilometer.conf \ 10 file://ceilometer.conf \
12 file://ceilometer.init \ 11 file://ceilometer.init \
13 file://fix_ceilometer_memory_leak.patch \ 12 file://fix_ceilometer_memory_leak.patch \
@@ -16,8 +15,8 @@ SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=stable/kilo \
16# file://ceilometer-builtin-tests-config-location.patch 15# file://ceilometer-builtin-tests-config-location.patch
17 16
18 17
19SRCREV = "b0447ed8e7bee371bf7095c86e47d717abe89edc" 18SRCREV = "026a5d475e1958bf761e41c2bb426b09e0f3d270"
20PV = "2015.1.0+git${SRCPV}" 19PV = "5.0.0+git${SRCPV}"
21S = "${WORKDIR}/git" 20S = "${WORKDIR}/git"
22 21
23CEILOMETER_SECRET ?= "12121212" 22CEILOMETER_SECRET ?= "12121212"
@@ -202,7 +201,7 @@ RDEPENDS_${PN} += " \
202 python-paste \ 201 python-paste \
203 python-sqlalchemy-migrate \ 202 python-sqlalchemy-migrate \
204 python-stevedore \ 203 python-stevedore \
205 python-suds \ 204 python-suds-jurko \
206 python-paramiko \ 205 python-paramiko \
207 python-babel \ 206 python-babel \
208 python-iso8601 \ 207 python-iso8601 \
@@ -237,6 +236,27 @@ RDEPENDS_${PN} += " \
237 python-croniter \ 236 python-croniter \
238 python-ipaddr \ 237 python-ipaddr \
239 python-pysnmp \ 238 python-pysnmp \
239 python-retrying \
240 python-jsonpath-rw-ext \
241 python-jsonschema \
242 python-kafka \
243 python-keystonemiddleware \
244 python-oslo.context \
245 python-oslo.db \
246 python-oslo.concurrency \
247 python-oslo.i18n \
248 python-oslo.log \
249 python-oslo.policy \
250 python-oslo.reports \
251 python-oslo.service \
252 python-oslo.messaging \
253 python-oslo.middleware \
254 python-oslo.utils \
255 python-neutronclient \
256 python-novaclient \
257 python-requests \
258 python-six \
259 python-tooz \
240 " 260 "
241 261
242RDEPENDS_${SRCNAME}-controller = "${PN} ${SRCNAME}-common ${SRCNAME}-alarm-notifier ${SRCNAME}-alarm-evaluator ${SRCNAME}-agent-notification ${SRCNAME}-reseller \ 262RDEPENDS_${SRCNAME}-controller = "${PN} ${SRCNAME}-common ${SRCNAME}-alarm-notifier ${SRCNAME}-alarm-evaluator ${SRCNAME}-agent-notification ${SRCNAME}-reseller \
diff --git a/meta-openstack/recipes-devtools/python/python-ceilometerclient_git.bb b/meta-openstack/recipes-devtools/python/python-ceilometerclient_git.bb
index 35760a9..a830e51 100644
--- a/meta-openstack/recipes-devtools/python/python-ceilometerclient_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-ceilometerclient_git.bb
@@ -9,27 +9,33 @@ DEPENDS += " \
9 python-pbr \ 9 python-pbr \
10 " 10 "
11 11
12RDEPENDS_${PN} +="python-cliff \ 12RDEPENDS_${PN} +=" \
13 python-cliff \
13 python-httplib2 \ 14 python-httplib2 \
14 python-iso8601 \ 15 python-iso8601 \
15 python-prettytable \ 16 python-prettytable \
16 python-pyparsing \ 17 python-pyparsing \
17 python-simplejson \ 18 python-simplejson \
18 python-pbr \ 19 python-pbr \
20 python-oslo.i18n \
21 python-oslo.serialization \
22 python-oslo.utils \
23 python-keystoneclient \
24 python-requests \
25 python-six \
26 python-stevedore \
19 " 27 "
20 28
21PR = "r0"
22
23SRC_URI = "\ 29SRC_URI = "\
24 git://github.com/openstack/python-ceilometerclient.git;branch=master \ 30 git://github.com/openstack/python-ceilometerclient.git;branch=master \
25 file://fix_ceilometerclient_memory_leak.patch \ 31 file://fix_ceilometerclient_memory_leak.patch \
26 " 32 "
27 33
28PV = "1.0.13+git${SRCPV}" 34PV = "1.5.0+git${SRCPV}"
29SRCREV = "f8765ce532a45391c5366be8fa0f583f96a30d22" 35SRCREV = "daed7e59c383f1ca74d75160cbc99fbd89675648"
30S = "${WORKDIR}/git" 36S = "${WORKDIR}/git"
31 37
32inherit setuptools 38inherit setuptools rmargparse
33 39
34 40
35PACKAGECONFIG ?= "bash-completion" 41PACKAGECONFIG ?= "bash-completion"