diff options
author | Bruce Ashfield <bruce.ashfield@windriver.com> | 2014-09-03 01:08:14 -0400 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@windriver.com> | 2014-09-03 01:08:14 -0400 |
commit | 0881d9805118707ece89be147612d02a27e3201b (patch) | |
tree | b4dbfa68c0ca243637ca4c292ff066867319c177 | |
parent | f3c2d6637bfc0839214b68dcf36fc5cfb64c2cbc (diff) | |
download | meta-cloud-services-0881d9805118707ece89be147612d02a27e3201b.tar.gz |
nova: update to juno configuration requirements
To boot a nested guest in juno, we need to relocate the virtualization
type config setting into the [libvirt] section.
With this, we can sucessfully launch a guest.
Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
3 files changed, 370 insertions, 5 deletions
diff --git a/meta-openstack-qemu/recipes-devtools/python/python-nova_git.bbappend b/meta-openstack-qemu/recipes-devtools/python/python-nova_git.bbappend index 45f4307..b2e3dff 100644 --- a/meta-openstack-qemu/recipes-devtools/python/python-nova_git.bbappend +++ b/meta-openstack-qemu/recipes-devtools/python/python-nova_git.bbappend | |||
@@ -6,6 +6,6 @@ do_install_append() { | |||
6 | TEMPLATE_CONF_DIR=${S}${sysconfdir}/${SRCNAME} | 6 | TEMPLATE_CONF_DIR=${S}${sysconfdir}/${SRCNAME} |
7 | NOVA_CONF_DIR=${D}/${sysconfdir}/nova | 7 | NOVA_CONF_DIR=${D}/${sysconfdir}/nova |
8 | 8 | ||
9 | sed -e "s:^libvirt_type.*=.*$:libvirt_type = qemu:" \ | 9 | sed -e "s:^virt_type.*=.*$:virt_type = qemu:" \ |
10 | -i ${NOVA_CONF_DIR}/nova.conf | 10 | -i ${NOVA_CONF_DIR}/nova.conf |
11 | } | 11 | } |
diff --git a/meta-openstack/recipes-devtools/python/python-nova/nova.conf b/meta-openstack/recipes-devtools/python/python-nova/nova.conf index fbaaa78..59a6b52 100644 --- a/meta-openstack/recipes-devtools/python/python-nova/nova.conf +++ b/meta-openstack/recipes-devtools/python/python-nova/nova.conf | |||
@@ -2,8 +2,6 @@ | |||
2 | # firewall_driver = nova.virt.libvirt.firewall.IptablesFirewallDriver | 2 | # firewall_driver = nova.virt.libvirt.firewall.IptablesFirewallDriver |
3 | firewall_driver = nova.virt.firewall.NoopFirewallDriver | 3 | firewall_driver = nova.virt.firewall.NoopFirewallDriver |
4 | compute_driver = libvirt.LibvirtDriver | 4 | compute_driver = libvirt.LibvirtDriver |
5 | libvirt_type = kvm | ||
6 | libvirt_cpu_mode = none | ||
7 | default_floating_pool = public | 5 | default_floating_pool = public |
8 | fixed_range = | 6 | fixed_range = |
9 | force_dhcp_release = True | 7 | force_dhcp_release = True |
@@ -21,7 +19,6 @@ my_ip = %CONTROLLER_IP% | |||
21 | glance_host = %CONTROLLER_IP% | 19 | glance_host = %CONTROLLER_IP% |
22 | lock_path=/var/lock/nova/ | 20 | lock_path=/var/lock/nova/ |
23 | state_path=/var/run/nova/ | 21 | state_path=/var/run/nova/ |
24 | libvirt_images_type = %LIBVIRT_IMAGES_TYPE% | ||
25 | 22 | ||
26 | #VNC | 23 | #VNC |
27 | vnc_enabled = True | 24 | vnc_enabled = True |
@@ -96,4 +93,7 @@ admin_tenant_name = %SERVICE_TENANT_NAME% | |||
96 | admin_user = %SERVICE_USER% | 93 | admin_user = %SERVICE_USER% |
97 | admin_password = %SERVICE_PASSWORD% | 94 | admin_password = %SERVICE_PASSWORD% |
98 | 95 | ||
99 | 96 | [libvirt] | |
97 | virt_type = kvm | ||
98 | libvirt_cpu_mode = none | ||
99 | libvirt_images_type = %LIBVIRT_IMAGES_TYPE% | ||
diff --git a/meta-openstack/recipes-devtools/python/python-nova/nova.conf.sample b/meta-openstack/recipes-devtools/python/python-nova/nova.conf.sample new file mode 100644 index 0000000..260296a --- /dev/null +++ b/meta-openstack/recipes-devtools/python/python-nova/nova.conf.sample | |||
@@ -0,0 +1,365 @@ | |||
1 | [DEFAULT] | ||
2 | |||
3 | # | ||
4 | # Options defined in oslo.messaging | ||
5 | # | ||
6 | |||
7 | # Use durable queues in amqp. (boolean value) | ||
8 | # Deprecated group/name - [DEFAULT]/rabbit_durable_queues | ||
9 | #amqp_durable_queues=false | ||
10 | |||
11 | # Auto-delete queues in amqp. (boolean value) | ||
12 | #amqp_auto_delete=false | ||
13 | |||
14 | # Size of RPC connection pool. (integer value) | ||
15 | #rpc_conn_pool_size=30 | ||
16 | |||
17 | # Qpid broker hostname. (string value) | ||
18 | #qpid_hostname=localhost | ||
19 | |||
20 | # Qpid broker port. (integer value) | ||
21 | #qpid_port=5672 | ||
22 | |||
23 | # Qpid HA cluster host:port pairs. (list value) | ||
24 | #qpid_hosts=$qpid_hostname:$qpid_port | ||
25 | |||
26 | # Username for Qpid connection. (string value) | ||
27 | #qpid_username= | ||
28 | |||
29 | # Password for Qpid connection. (string value) | ||
30 | #qpid_password= | ||
31 | |||
32 | # Space separated list of SASL mechanisms to use for auth. | ||
33 | # (string value) | ||
34 | #qpid_sasl_mechanisms= | ||
35 | |||
36 | # Seconds between connection keepalive heartbeats. (integer | ||
37 | # value) | ||
38 | #qpid_heartbeat=60 | ||
39 | |||
40 | # Transport to use, either 'tcp' or 'ssl'. (string value) | ||
41 | #qpid_protocol=tcp | ||
42 | |||
43 | # Whether to disable the Nagle algorithm. (boolean value) | ||
44 | #qpid_tcp_nodelay=true | ||
45 | |||
46 | # The qpid topology version to use. Version 1 is what was | ||
47 | # originally used by impl_qpid. Version 2 includes some | ||
48 | # backwards-incompatible changes that allow broker federation | ||
49 | # to work. Users should update to version 2 when they are | ||
50 | # able to take everything down, as it requires a clean break. | ||
51 | # (integer value) | ||
52 | #qpid_topology_version=1 | ||
53 | |||
54 | # SSL version to use (valid only if SSL enabled). valid values | ||
55 | # are TLSv1, SSLv23 and SSLv3. SSLv2 may be available on some | ||
56 | # distributions. (string value) | ||
57 | #kombu_ssl_version= | ||
58 | |||
59 | # SSL key file (valid only if SSL enabled). (string value) | ||
60 | #kombu_ssl_keyfile= | ||
61 | |||
62 | # SSL cert file (valid only if SSL enabled). (string value) | ||
63 | #kombu_ssl_certfile= | ||
64 | |||
65 | # SSL certification authority file (valid only if SSL | ||
66 | # enabled). (string value) | ||
67 | #kombu_ssl_ca_certs= | ||
68 | |||
69 | # How long to wait before reconnecting in response to an AMQP | ||
70 | # consumer cancel notification. (floating point value) | ||
71 | #kombu_reconnect_delay=1.0 | ||
72 | |||
73 | # The RabbitMQ broker address where a single node is used. | ||
74 | # (string value) | ||
75 | #rabbit_host=localhost | ||
76 | |||
77 | # The RabbitMQ broker port where a single node is used. | ||
78 | # (integer value) | ||
79 | #rabbit_port=5672 | ||
80 | |||
81 | # RabbitMQ HA cluster host:port pairs. (list value) | ||
82 | #rabbit_hosts=$rabbit_host:$rabbit_port | ||
83 | |||
84 | # Connect over SSL for RabbitMQ. (boolean value) | ||
85 | #rabbit_use_ssl=false | ||
86 | |||
87 | # The RabbitMQ userid. (string value) | ||
88 | #rabbit_userid=guest | ||
89 | |||
90 | # The RabbitMQ password. (string value) | ||
91 | #rabbit_password=guest | ||
92 | |||
93 | # the RabbitMQ login method (string value) | ||
94 | #rabbit_login_method=AMQPLAIN | ||
95 | |||
96 | # The RabbitMQ virtual host. (string value) | ||
97 | #rabbit_virtual_host=/ | ||
98 | |||
99 | # How frequently to retry connecting with RabbitMQ. (integer | ||
100 | # value) | ||
101 | #rabbit_retry_interval=1 | ||
102 | |||
103 | # How long to backoff for between retries when connecting to | ||
104 | # RabbitMQ. (integer value) | ||
105 | #rabbit_retry_backoff=2 | ||
106 | |||
107 | # Maximum number of RabbitMQ connection retries. Default is 0 | ||
108 | # (infinite retry count). (integer value) | ||
109 | #rabbit_max_retries=0 | ||
110 | |||
111 | # Use HA queues in RabbitMQ (x-ha-policy: all). If you change | ||
112 | # this option, you must wipe the RabbitMQ database. (boolean | ||
113 | # value) | ||
114 | #rabbit_ha_queues=false | ||
115 | |||
116 | # If passed, use a fake RabbitMQ provider. (boolean value) | ||
117 | #fake_rabbit=false | ||
118 | |||
119 | # ZeroMQ bind address. Should be a wildcard (*), an ethernet | ||
120 | # interface, or IP. The "host" option should point or resolve | ||
121 | # to this address. (string value) | ||
122 | #rpc_zmq_bind_address=* | ||
123 | |||
124 | # MatchMaker driver. (string value) | ||
125 | #rpc_zmq_matchmaker=oslo.messaging._drivers.matchmaker.MatchMakerLocalhost | ||
126 | |||
127 | # ZeroMQ receiver listening port. (integer value) | ||
128 | #rpc_zmq_port=9501 | ||
129 | |||
130 | # Number of ZeroMQ contexts, defaults to 1. (integer value) | ||
131 | #rpc_zmq_contexts=1 | ||
132 | |||
133 | # Maximum number of ingress messages to locally buffer per | ||
134 | # topic. Default is unlimited. (integer value) | ||
135 | #rpc_zmq_topic_backlog=<None> | ||
136 | |||
137 | # Directory for holding IPC sockets. (string value) | ||
138 | #rpc_zmq_ipc_dir=/var/run/openstack | ||
139 | |||
140 | # Name of this node. Must be a valid hostname, FQDN, or IP | ||
141 | # address. Must match "host" option, if running Nova. (string | ||
142 | # value) | ||
143 | #rpc_zmq_host=nova | ||
144 | |||
145 | # Seconds to wait before a cast expires (TTL). Only supported | ||
146 | # by impl_zmq. (integer value) | ||
147 | #rpc_cast_timeout=30 | ||
148 | |||
149 | # Heartbeat frequency. (integer value) | ||
150 | #matchmaker_heartbeat_freq=300 | ||
151 | |||
152 | # Heartbeat time-to-live. (integer value) | ||
153 | #matchmaker_heartbeat_ttl=600 | ||
154 | |||
155 | # Size of RPC greenthread pool. (integer value) | ||
156 | #rpc_thread_pool_size=64 | ||
157 | |||
158 | # Driver or drivers to handle sending notifications. (multi | ||
159 | # valued) | ||
160 | #notification_driver= | ||
161 | |||
162 | # AMQP topic used for OpenStack notifications. (list value) | ||
163 | # Deprecated group/name - [rpc_notifier2]/topics | ||
164 | #notification_topics=notifications | ||
165 | |||
166 | # Seconds to wait for a response from a call. (integer value) | ||
167 | #rpc_response_timeout=60 | ||
168 | |||
169 | # A URL representing the messaging driver to use and its full | ||
170 | # configuration. If not set, we fall back to the rpc_backend | ||
171 | # option and driver specific configuration. (string value) | ||
172 | #transport_url=<None> | ||
173 | |||
174 | # The messaging driver to use, defaults to rabbit. Other | ||
175 | # drivers include qpid and zmq. (string value) | ||
176 | #rpc_backend=rabbit | ||
177 | |||
178 | # The default exchange under which topics are scoped. May be | ||
179 | # overridden by an exchange name specified in the | ||
180 | # transport_url option. (string value) | ||
181 | #control_exchange=openstack | ||
182 | |||
183 | |||
184 | [keystone_authtoken] | ||
185 | |||
186 | # | ||
187 | # Options defined in keystoneclient.middleware.auth_token | ||
188 | # | ||
189 | |||
190 | # Prefix to prepend at the beginning of the path. Deprecated, | ||
191 | # use identity_uri. (string value) | ||
192 | #auth_admin_prefix= | ||
193 | |||
194 | # Host providing the admin Identity API endpoint. Deprecated, | ||
195 | # use identity_uri. (string value) | ||
196 | #auth_host=127.0.0.1 | ||
197 | |||
198 | # Port of the admin Identity API endpoint. Deprecated, use | ||
199 | # identity_uri. (integer value) | ||
200 | #auth_port=35357 | ||
201 | |||
202 | # Protocol of the admin Identity API endpoint (http or https). | ||
203 | # Deprecated, use identity_uri. (string value) | ||
204 | #auth_protocol=https | ||
205 | |||
206 | # Complete public Identity API endpoint (string value) | ||
207 | #auth_uri=<None> | ||
208 | |||
209 | # Complete admin Identity API endpoint. This should specify | ||
210 | # the unversioned root endpoint e.g. https://localhost:35357/ | ||
211 | # (string value) | ||
212 | #identity_uri=<None> | ||
213 | |||
214 | # API version of the admin Identity API endpoint (string | ||
215 | # value) | ||
216 | #auth_version=<None> | ||
217 | |||
218 | # Do not handle authorization requests within the middleware, | ||
219 | # but delegate the authorization decision to downstream WSGI | ||
220 | # components (boolean value) | ||
221 | #delay_auth_decision=false | ||
222 | |||
223 | # Request timeout value for communicating with Identity API | ||
224 | # server. (boolean value) | ||
225 | #http_connect_timeout=<None> | ||
226 | |||
227 | # How many times are we trying to reconnect when communicating | ||
228 | # with Identity API Server. (integer value) | ||
229 | #http_request_max_retries=3 | ||
230 | |||
231 | # This option is deprecated and may be removed in a future | ||
232 | # release. Single shared secret with the Keystone | ||
233 | # configuration used for bootstrapping a Keystone | ||
234 | # installation, or otherwise bypassing the normal | ||
235 | # authentication process. This option should not be used, use | ||
236 | # `admin_user` and `admin_password` instead. (string value) | ||
237 | #admin_token=<None> | ||
238 | |||
239 | # Keystone account username (string value) | ||
240 | #admin_user=<None> | ||
241 | |||
242 | # Keystone account password (string value) | ||
243 | #admin_password=<None> | ||
244 | |||
245 | # Keystone service account tenant name to validate user tokens | ||
246 | # (string value) | ||
247 | #admin_tenant_name=admin | ||
248 | |||
249 | # Env key for the swift cache (string value) | ||
250 | #cache=<None> | ||
251 | |||
252 | # Required if Keystone server requires client certificate | ||
253 | # (string value) | ||
254 | #certfile=<None> | ||
255 | |||
256 | # Required if Keystone server requires client certificate | ||
257 | # (string value) | ||
258 | #keyfile=<None> | ||
259 | |||
260 | # A PEM encoded Certificate Authority to use when verifying | ||
261 | # HTTPs connections. Defaults to system CAs. (string value) | ||
262 | #cafile=<None> | ||
263 | |||
264 | # Verify HTTPS connections. (boolean value) | ||
265 | #insecure=false | ||
266 | |||
267 | # Directory used to cache files related to PKI tokens (string | ||
268 | # value) | ||
269 | #signing_dir=<None> | ||
270 | |||
271 | # Optionally specify a list of memcached server(s) to use for | ||
272 | # caching. If left undefined, tokens will instead be cached | ||
273 | # in-process. (list value) | ||
274 | # Deprecated group/name - [DEFAULT]/memcache_servers | ||
275 | #memcached_servers=<None> | ||
276 | |||
277 | # In order to prevent excessive effort spent validating | ||
278 | # tokens, the middleware caches previously-seen tokens for a | ||
279 | # configurable duration (in seconds). Set to -1 to disable | ||
280 | # caching completely. (integer value) | ||
281 | #token_cache_time=300 | ||
282 | |||
283 | # Determines the frequency at which the list of revoked tokens | ||
284 | # is retrieved from the Identity service (in seconds). A high | ||
285 | # number of revocation events combined with a low cache | ||
286 | # duration may significantly reduce performance. (integer | ||
287 | # value) | ||
288 | #revocation_cache_time=10 | ||
289 | |||
290 | # (optional) if defined, indicate whether token data should be | ||
291 | # authenticated or authenticated and encrypted. Acceptable | ||
292 | # values are MAC or ENCRYPT. If MAC, token data is | ||
293 | # authenticated (with HMAC) in the cache. If ENCRYPT, token | ||
294 | # data is encrypted and authenticated in the cache. If the | ||
295 | # value is not one of these options or empty, auth_token will | ||
296 | # raise an exception on initialization. (string value) | ||
297 | #memcache_security_strategy=<None> | ||
298 | |||
299 | # (optional, mandatory if memcache_security_strategy is | ||
300 | # defined) this string is used for key derivation. (string | ||
301 | # value) | ||
302 | #memcache_secret_key=<None> | ||
303 | |||
304 | # (optional) indicate whether to set the X-Service-Catalog | ||
305 | # header. If False, middleware will not ask for service | ||
306 | # catalog on token validation and will not set the X-Service- | ||
307 | # Catalog header. (boolean value) | ||
308 | #include_service_catalog=true | ||
309 | |||
310 | # Used to control the use and type of token binding. Can be | ||
311 | # set to: "disabled" to not check token binding. "permissive" | ||
312 | # (default) to validate binding information if the bind type | ||
313 | # is of a form known to the server and ignore it if not. | ||
314 | # "strict" like "permissive" but if the bind type is unknown | ||
315 | # the token will be rejected. "required" any form of token | ||
316 | # binding is needed to be allowed. Finally the name of a | ||
317 | # binding method that must be present in tokens. (string | ||
318 | # value) | ||
319 | #enforce_token_bind=permissive | ||
320 | |||
321 | # If true, the revocation list will be checked for cached | ||
322 | # tokens. This requires that PKI tokens are configured on the | ||
323 | # Keystone server. (boolean value) | ||
324 | #check_revocations_for_cached=false | ||
325 | |||
326 | # Hash algorithms to use for hashing PKI tokens. This may be a | ||
327 | # single algorithm or multiple. The algorithms are those | ||
328 | # supported by Python standard hashlib.new(). The hashes will | ||
329 | # be tried in the order given, so put the preferred one first | ||
330 | # for performance. The result of the first hash will be stored | ||
331 | # in the cache. This will typically be set to multiple values | ||
332 | # only while migrating from a less secure algorithm to a more | ||
333 | # secure one. Once all the old tokens are expired this option | ||
334 | # should be set to a single value for better performance. | ||
335 | # (list value) | ||
336 | #hash_algorithms=md5 | ||
337 | |||
338 | |||
339 | [matchmaker_redis] | ||
340 | |||
341 | # | ||
342 | # Options defined in oslo.messaging | ||
343 | # | ||
344 | |||
345 | # Host to locate redis. (string value) | ||
346 | #host=127.0.0.1 | ||
347 | |||
348 | # Use this port to connect to redis host. (integer value) | ||
349 | #port=6379 | ||
350 | |||
351 | # Password for Redis server (optional). (string value) | ||
352 | #password=<None> | ||
353 | |||
354 | |||
355 | [matchmaker_ring] | ||
356 | |||
357 | # | ||
358 | # Options defined in oslo.messaging | ||
359 | # | ||
360 | |||
361 | # Matchmaker ring file (JSON). (string value) | ||
362 | # Deprecated group/name - [DEFAULT]/matchmaker_ringfile | ||
363 | #ringfile=/etc/oslo/matchmaker_ring.json | ||
364 | |||
365 | |||