summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMustapha Lansana <Mustapha.Lansana@windriver.com>2014-07-30 21:10:33 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-09-26 09:09:22 -0400
commit0304d8c53bdad18348f37526a4de08e52b9ace19 (patch)
tree3df043e603073767c89ca2eb0da041fa2691e210
parentb23d78ca58c54251138a9edabeaab3982e4eebc8 (diff)
downloadmeta-cloud-services-0304d8c53bdad18348f37526a4de08e52b9ace19.tar.gz
openstack: restart daemons exposed by the following services in openstack
Openstackchef class provides the framework to reconfigure openstack at run-time. These services are inheriting openstackchef so that script file(s), specified in the respective recipe file, using the variables below are restarted by the decentralized openstackchef class framework when reconfiguring openstack: INITSCRIPT_PACKAGES: The list of init-scripts to start/stop when reconfiguring openstack. INITSCIPT_NAME_x: The name of the init-script mentioned above. INITSCRIPT_PARAMS_X: This parameter defines the run-level and priority for the init-script. However, the only parameter in this variable that is of interest to openstackchef class is the priority of the init-script. Changes to none of the above variables is shown by this patch set, however, it's to point out that openstackchef makes the assumption that these variables are set in the service's recipe file. Failure to set these variables, could lead to the service not working properly after the stack is re-configured. Signed-off-by: Mustapha Lansana <Mustapha.Lansana@windriver.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-horizon_git.bb2
-rw-r--r--meta-openstack/recipes-extended/glusterfs/glusterfs_3.4.2.bbappend6
-rw-r--r--meta-openstack/recipes-extended/rabbitmq/rabbitmq-server_3.2.4.bb2
3 files changed, 8 insertions, 2 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-horizon_git.bb b/meta-openstack/recipes-devtools/python/python-horizon_git.bb
index 428507a..a767bee 100644
--- a/meta-openstack/recipes-devtools/python/python-horizon_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-horizon_git.bb
@@ -60,7 +60,7 @@ SRCREV="bd998fb6094fb16d084c90de1eed619aca4c31ef"
60PV="2014.2.b3+git${SRCPV}" 60PV="2014.2.b3+git${SRCPV}"
61S = "${WORKDIR}/git" 61S = "${WORKDIR}/git"
62 62
63inherit setuptools update-rc.d python-dir default_configs 63inherit setuptools update-rc.d python-dir default_configs openstackchef
64 64
65# no longer required. kept as reference. 65# no longer required. kept as reference.
66# do_install[dirs] += "${D}/usr/share/bin" 66# do_install[dirs] += "${D}/usr/share/bin"
diff --git a/meta-openstack/recipes-extended/glusterfs/glusterfs_3.4.2.bbappend b/meta-openstack/recipes-extended/glusterfs/glusterfs_3.4.2.bbappend
new file mode 100644
index 0000000..b52d27a
--- /dev/null
+++ b/meta-openstack/recipes-extended/glusterfs/glusterfs_3.4.2.bbappend
@@ -0,0 +1,6 @@
1#
2# Copyright (C) 2013 Wind River Systems, Inc.
3#
4inherit openstackchef
5
6
diff --git a/meta-openstack/recipes-extended/rabbitmq/rabbitmq-server_3.2.4.bb b/meta-openstack/recipes-extended/rabbitmq/rabbitmq-server_3.2.4.bb
index 101d098..6ac3e59 100644
--- a/meta-openstack/recipes-extended/rabbitmq/rabbitmq-server_3.2.4.bb
+++ b/meta-openstack/recipes-extended/rabbitmq/rabbitmq-server_3.2.4.bb
@@ -46,7 +46,7 @@ do_install() {
46 mv ${D}/plugins ${RABBIT_LIB_DIR}/plugins 46 mv ${D}/plugins ${RABBIT_LIB_DIR}/plugins
47} 47}
48 48
49inherit useradd update-rc.d 49inherit useradd update-rc.d openstackchef
50 50
51USERADD_PACKAGES = "${PN}" 51USERADD_PACKAGES = "${PN}"
52GROUPADD_PARAM_${PN} = "--system rabbitmq" 52GROUPADD_PARAM_${PN} = "--system rabbitmq"