summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2014-08-26 15:27:49 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-08-27 12:17:43 -0400
commit4d4176d8ab960f4636a497a0cf7e7c9cbe50b868 (patch)
treec7a7af876e5af3df578b27d3b16d1c66c2c89bb6
parentc2e835140fe2a2898fb7124c9038f632a3b8d464 (diff)
downloadmeta-cloud-services-4d4176d8ab960f4636a497a0cf7e7c9cbe50b868.tar.gz
apache2: restore mistakely removed bbappend
Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--meta-openstack/recipes-httpd/apache2/apache2_2.4.10.bbappend15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-openstack/recipes-httpd/apache2/apache2_2.4.10.bbappend b/meta-openstack/recipes-httpd/apache2/apache2_2.4.10.bbappend
new file mode 100644
index 0000000..7aca867
--- /dev/null
+++ b/meta-openstack/recipes-httpd/apache2/apache2_2.4.10.bbappend
@@ -0,0 +1,15 @@
1INC := "${@int(PRINC) + 1}"
2
3do_install_append() {
4 sed -i -e 's/#ServerName.*$/ServerName 127.0.0.1:80/' ${D}${sysconfdir}/apache2/httpd.conf
5
6 # default layout for htdocsdir in 2.4.7 is different, create the following for
7 # backward compatibility reasons
8
9 mkdir -p ${D}${datadir}/${BPN}/default-site
10 ln -sf ../htdocs ${D}${datadir}/${BPN}/default-site/htdocs
11
12 sed -i '30i if [ ! -e /var/log/apache2 ]; then ln -sf /var/apache2/logs/ /var/log/apache2; fi' ${D}/etc/init.d/apache2
13}
14
15FILES_${PN} += "${datadir}/${BPN}/default-site"