diff options
author | Guojian Zhou <guojian.zhou@windriver.com> | 2015-08-19 22:56:10 -0400 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@windriver.com> | 2015-08-20 13:38:48 -0400 |
commit | bd7a3f804950ae454d025aa8773789441a63820c (patch) | |
tree | accc6e8bf6f8f14de6e771c0fed0564ba7004cb8 | |
parent | 7c0b2edd50fb11c5e8ea86b533d7caea50cf3d6d (diff) | |
download | meta-cloud-services-bd7a3f804950ae454d025aa8773789441a63820c.tar.gz |
Add the ruby-shadow recipe for the puppet tool
The puppet could not add or change the user's password automatically,
because the puppet tool requires the "libshadow" to implement this feature.
Failure information without the "libshadow" feature:
==================================================================
Debug: /User[username]: Provider useradd does not support features
manages_passwords; not managing attribute password
Signed-off-by: Guojian Zhou <guojian.zhou@windriver.com>
Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com>
Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r-- | meta-openstack/recipes-support/puppet/puppet_3.7.3.bb | 1 | ||||
-rw-r--r-- | meta-openstack/recipes-support/ruby-shadow/ruby-shadow_git.bb | 23 |
2 files changed, 24 insertions, 0 deletions
diff --git a/meta-openstack/recipes-support/puppet/puppet_3.7.3.bb b/meta-openstack/recipes-support/puppet/puppet_3.7.3.bb index f201a7b..c1743e6 100644 --- a/meta-openstack/recipes-support/puppet/puppet_3.7.3.bb +++ b/meta-openstack/recipes-support/puppet/puppet_3.7.3.bb | |||
@@ -23,6 +23,7 @@ RDEPENDS_${PN} += " \ | |||
23 | ruby \ | 23 | ruby \ |
24 | facter \ | 24 | facter \ |
25 | hiera \ | 25 | hiera \ |
26 | ruby-shadow \ | ||
26 | " | 27 | " |
27 | 28 | ||
28 | RUBY_INSTALL_GEMS = "puppet-${PV}.gem" | 29 | RUBY_INSTALL_GEMS = "puppet-${PV}.gem" |
diff --git a/meta-openstack/recipes-support/ruby-shadow/ruby-shadow_git.bb b/meta-openstack/recipes-support/ruby-shadow/ruby-shadow_git.bb new file mode 100644 index 0000000..72be016 --- /dev/null +++ b/meta-openstack/recipes-support/ruby-shadow/ruby-shadow_git.bb | |||
@@ -0,0 +1,23 @@ | |||
1 | SUMMARY = "Shadow Password Module" | ||
2 | HOMEPAGE = "https://github.com/apalmblad/ruby-shadow" | ||
3 | LICENSE = "PD" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=137882914e5269b7268f0fe8e28a3f89" | ||
5 | |||
6 | PV = "2.4.1" | ||
7 | |||
8 | SRC_URI = "git://github.com/apalmblad/ruby-shadow.git" | ||
9 | SRCREV = "4231a4838fd50022b112838f114ee0586e119605" | ||
10 | S = "${WORKDIR}/git" | ||
11 | |||
12 | inherit ruby | ||
13 | |||
14 | DEPENDS += " \ | ||
15 | ruby \ | ||
16 | " | ||
17 | |||
18 | RDEPENDS_${PN} += " \ | ||
19 | ruby \ | ||
20 | " | ||
21 | |||
22 | RUBY_INSTALL_GEMS = "ruby-shadow-${PV}.gem" | ||
23 | FILES_${PN}-dbg += "/usr/lib64/ruby/gems/*/gems/ruby-shadow-${PV}/.debug/shadow.so" | ||