summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorzangrc <zangrc.fnst@cn.fujitsu.com>2020-10-20 14:51:34 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-10-27 23:28:50 -0400
commitbd3c9b2bb3247db1b5d159d032256621f334f959 (patch)
treec210265386a5808dcf8e1e1a261eec8522a420a3
parent04127165a1c828ea1b529d5410c9596ada9c7cc5 (diff)
downloadmeta-cloud-services-bd3c9b2bb3247db1b5d159d032256621f334f959.tar.gz
python3-saharaclient: upgrade 2.3.0 -> 3.2.1
Consolidate inc and bb files into a single bb file. Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-saharaclient.inc28
-rw-r--r--meta-openstack/recipes-devtools/python/python3-saharaclient_git.bb30
2 files changed, 29 insertions, 29 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-saharaclient.inc b/meta-openstack/recipes-devtools/python/python-saharaclient.inc
deleted file mode 100644
index 91549ae..0000000
--- a/meta-openstack/recipes-devtools/python/python-saharaclient.inc
+++ /dev/null
@@ -1,28 +0,0 @@
1DESCRIPTION = "CLI and python client library for OpenStack Sahara"
2HOMEPAGE = "https://launchpad.net/sahara"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6
7DEPENDS += " \
8 ${PYTHON_PN}-pip \
9 ${PYTHON_PN}-pbr \
10 "
11
12# Satisfy setup.py 'setup_requires'
13DEPENDS += " \
14 ${PYTHON_PN}-pbr-native \
15"
16
17RDEPENDS_${PN} += " \
18 ${PYTHON_PN}-pbr \
19 "
20
21SRCNAME = "saharaclient"
22
23SRC_URI = "git://github.com/openstack/python-saharaclient.git;branch=master"
24
25PV = "2.3.0+git${SRCPV}"
26SRCREV = "3107b452467537f4eef3d9ecfb5e35d110d19662"
27S = "${WORKDIR}/git"
28
diff --git a/meta-openstack/recipes-devtools/python/python3-saharaclient_git.bb b/meta-openstack/recipes-devtools/python/python3-saharaclient_git.bb
index 806cd76..9ec4c56 100644
--- a/meta-openstack/recipes-devtools/python/python3-saharaclient_git.bb
+++ b/meta-openstack/recipes-devtools/python/python3-saharaclient_git.bb
@@ -1,2 +1,30 @@
1require python-saharaclient.inc 1DESCRIPTION = "CLI and python client library for OpenStack Sahara"
2HOMEPAGE = "https://launchpad.net/sahara"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6
7DEPENDS += " \
8 ${PYTHON_PN}-pip \
9 ${PYTHON_PN}-pbr \
10 "
11
12# Satisfy setup.py 'setup_requires'
13DEPENDS += " \
14 ${PYTHON_PN}-pbr-native \
15"
16
17RDEPENDS_${PN} += " \
18 ${PYTHON_PN}-pbr \
19 "
20
21SRCNAME = "saharaclient"
22
2inherit setuptools3 23inherit setuptools3
24
25SRC_URI = "git://github.com/openstack/python-saharaclient.git;branch=master"
26
27PV = "3.2.1+git${SRCPV}"
28SRCREV = "a9fee07108c432e20a3ca7760541d4fcb4f14811"
29S = "${WORKDIR}/git"
30