summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorzangrc <zangrc.fnst@cn.fujitsu.com>2020-10-27 13:04:52 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-11-03 16:33:06 -0500
commit9ee8a81a4608daae2d63a0a9a2bcba4bff833571 (patch)
treeae49ee6622a388e373ff66c7f7f42d10f5c5d1d2
parentf7fd778f4340959ff9d2cd5256abf454297d6927 (diff)
downloadmeta-cloud-services-9ee8a81a4608daae2d63a0a9a2bcba4bff833571.tar.gz
python3-positional: Consolidate in a single file
Consolidate inc and bb files into a single bb file. Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-positional.inc21
-rw-r--r--meta-openstack/recipes-devtools/python/python3-positional_1.2.1.bb23
2 files changed, 21 insertions, 23 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-positional.inc b/meta-openstack/recipes-devtools/python/python-positional.inc
deleted file mode 100644
index 736e691..0000000
--- a/meta-openstack/recipes-devtools/python/python-positional.inc
+++ /dev/null
@@ -1,21 +0,0 @@
1DESCRIPTION = "Library to enforce positional or key-word arguments"
2HOMEPAGE = "https://github.com/morganfainberg/positional"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=5335066555b14d832335aa4660d6c376"
6
7SRC_URI[md5sum] = "4afcffd8e2ba733fd7a50f137a2ee893"
8SRC_URI[sha256sum] = "cf48ea169f6c39486d5efa0ce7126a97bed979a52af6261cf255a41f9a74453a"
9
10inherit pypi
11
12CLEANBROKEN = "1"
13
14# Satisfy setup.py 'setup_requires'
15DEPENDS += " \
16 ${PYTHON_PN}-pbr-native \
17 "
18
19RDEPENDS_${PN} += " \
20 ${PYTHON_PN}-wrapt \
21"
diff --git a/meta-openstack/recipes-devtools/python/python3-positional_1.2.1.bb b/meta-openstack/recipes-devtools/python/python3-positional_1.2.1.bb
index 3081cd2..5e2f178 100644
--- a/meta-openstack/recipes-devtools/python/python3-positional_1.2.1.bb
+++ b/meta-openstack/recipes-devtools/python/python3-positional_1.2.1.bb
@@ -1,2 +1,21 @@
1inherit setuptools3 1DESCRIPTION = "Library to enforce positional or key-word arguments"
2require python-positional.inc 2HOMEPAGE = "https://github.com/morganfainberg/positional"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=5335066555b14d832335aa4660d6c376"
6
7SRC_URI[md5sum] = "4afcffd8e2ba733fd7a50f137a2ee893"
8SRC_URI[sha256sum] = "cf48ea169f6c39486d5efa0ce7126a97bed979a52af6261cf255a41f9a74453a"
9
10inherit setuptools3 pypi
11
12CLEANBROKEN = "1"
13
14# Satisfy setup.py 'setup_requires'
15DEPENDS += " \
16 ${PYTHON_PN}-pbr-native \
17 "
18
19RDEPENDS_${PN} += " \
20 ${PYTHON_PN}-wrapt \
21"