summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2013-08-11 00:04:39 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2013-08-28 18:41:59 -0400
commit106487af8f1d02f556d69f5274cf10a6c04c73dc (patch)
tree4484b8d3819ff8137a36d3cd5f027034680c7cf5
parenta4a9a068bae9a8a7bfb269e480e4ed3ed74ffd3d (diff)
downloadmeta-cloud-services-106487af8f1d02f556d69f5274cf10a6c04c73dc.tar.gz
openstack: rename and clarify image names
Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--meta-openstack/DOC10
-rw-r--r--meta-openstack/README24
-rw-r--r--meta-openstack/recipes-extended/images/openstack-image-compute.bb (renamed from meta-openstack/recipes-extended/images/nova-image-compute.bb)0
-rw-r--r--meta-openstack/recipes-extended/images/openstack-image-controller.bb (renamed from meta-openstack/recipes-extended/images/nova-image-controller.bb)0
-rw-r--r--meta-openstack/recipes-extended/images/openstack-image-network.bb16
5 files changed, 37 insertions, 13 deletions
diff --git a/meta-openstack/DOC b/meta-openstack/DOC
index 66fa085..160e67a 100644
--- a/meta-openstack/DOC
+++ b/meta-openstack/DOC
@@ -52,14 +52,16 @@ necessary revisions in the README file.
52 52
53Building an image 53Building an image
54----------------- 54-----------------
55* There are two new target images: nova-image-compute and nova-image-controller 55
56that contain the packagegroups with the same name, that have been describe 56* There are three new target images: openstack-image-compute,
57in the previous section. 57openstack-image-network and openstack-image-controller that contain the
58packagegroups with the same name, that have been described in the previous
59section.
58 60
59* Once a buildir has been initialized you have to append the necessary layers 61* Once a buildir has been initialized you have to append the necessary layers
60to the bblayers.conf file: 62to the bblayers.conf file:
61 /meta-virtualization \ 63 /meta-virtualization \
62 /meta-openstack \ 64 /meta-cloud/meta-openstack \
63 /meta-openembedded/meta-oe \ 65 /meta-openembedded/meta-oe \
64 /meta-openembedded/meta-networking \ 66 /meta-openembedded/meta-networking \
65 67
diff --git a/meta-openstack/README b/meta-openstack/README
index 215d686..b60b3d2 100644
--- a/meta-openstack/README
+++ b/meta-openstack/README
@@ -12,20 +12,19 @@ This layer depends on:
12 12
13URI: git://github.com/openembedded/oe-core.git 13URI: git://github.com/openembedded/oe-core.git
14branch: master 14branch: master
15tag: yocto-1.4.1 15revision: HEAD
16prio: default
16 17
17URI: git://github.com/openembedded/meta-oe.git 18URI: git://github.com/openembedded/meta-oe.git
18branch: dylan
19revision: HEAD
20patches: 0001-python-sqlalchemy-update-to-0.7.9.patch 19patches: 0001-python-sqlalchemy-update-to-0.7.9.patch
20revision: HEAD
21layers: meta-oe 21layers: meta-oe
22 meta-networking 22 meta-networking
23 meta-ruby 23 meta-ruby
24 24
25URI: git://git.yoctoproject.org/meta-virtualization 25URI: git://git.yoctoproject.org/meta-virtualization
26branch: master 26branch: master
27revision: 7040db74c375ef55d1b040f53071be29590882de 27revision: head
28patches: 0001-linux-yocto-Added-3.8-kernel-bbappend.patch
29 28
30The patches for the layers can be found in the patches folder. They can be 29The patches for the layers can be found in the patches folder. They can be
31applied using git am. 30applied using git am.
@@ -33,7 +32,12 @@ applied using git am.
33Maintenance 32Maintenance
34----------- 33-----------
35 34
36Maintainers: Mihai Prica <prica.mihai@gmail.com> 35Send pull requests, patches, comments or questions to meta-virtualization@yoctoproject.org
36
37When sending single patches, please using something like:
38'git send-email -1 --to meta-virtualization@yoctoproject.org --subject-prefix=meta-virtualization][PATCH'
39
40Maintainers: Bruce Ashfield <bruce.ashfield@windriver.com>
37 41
38License 42License
39------- 43-------
@@ -45,8 +49,10 @@ in tree for individual recipes is under the LICENSE stated in each recipe
45Target images 49Target images
46------------- 50-------------
47 51
48There are two target images: nova-image-compute and nova-image-controller. 52There are target images: openstack-image-compute, openstack-image-network,
49This contain the packagegroups with the same name and can be used to create 53openstack-image-controller.
54
55They contain the packagegroups with the same name and can be used to create
50the two types of targets. There are no extra configurations required to build 56the two types of targets. There are no extra configurations required to build
51these images. 57these images.
52 58
diff --git a/meta-openstack/recipes-extended/images/nova-image-compute.bb b/meta-openstack/recipes-extended/images/openstack-image-compute.bb
index 632b21b..632b21b 100644
--- a/meta-openstack/recipes-extended/images/nova-image-compute.bb
+++ b/meta-openstack/recipes-extended/images/openstack-image-compute.bb
diff --git a/meta-openstack/recipes-extended/images/nova-image-controller.bb b/meta-openstack/recipes-extended/images/openstack-image-controller.bb
index b4bba86..b4bba86 100644
--- a/meta-openstack/recipes-extended/images/nova-image-controller.bb
+++ b/meta-openstack/recipes-extended/images/openstack-image-controller.bb
diff --git a/meta-openstack/recipes-extended/images/openstack-image-network.bb b/meta-openstack/recipes-extended/images/openstack-image-network.bb
new file mode 100644
index 0000000..e4dfa29
--- /dev/null
+++ b/meta-openstack/recipes-extended/images/openstack-image-network.bb
@@ -0,0 +1,16 @@
1DESCRIPTION = "Openstack network node image"
2LICENSE = "MIT"
3
4IMAGE_INSTALL = "\
5 ${CORE_IMAGE_BASE_INSTALL} \
6 ${ROOTFS_PKGMANAGE_BOOTSTRAP} \
7 packagegroup-core-basic \
8 packagegroup-cloud-network \
9 "
10
11IMAGE_FEATURES += " ssh-server-openssh"
12
13inherit core-image
14
15# Ensure extra space for guest images
16IMAGE_ROOTFS_EXTRA_SPACE = "2000000"