summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorzhengruoqin <zhengrq.fnst@cn.fujitsu.com>2020-10-20 14:42:37 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-10-27 23:27:51 -0400
commit62733df83129cdbea5de91d60999d67c932257e8 (patch)
tree724266e902cae0362adbda5d7ce24cdb17ebd9f3
parent03b8a9cd67cca4cd7fe9ca3a03f58ab5c66f7254 (diff)
downloadmeta-cloud-services-62733df83129cdbea5de91d60999d67c932257e8.tar.gz
python3-testresources: upgrade 0.2.7 -> 2.0.1
Consolidate inc and bb files into a single bb file. -License-Update: The checked file is changed to PKG-INFO. Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-testresources.inc10
-rw-r--r--meta-openstack/recipes-devtools/python/python3-testresources_0.2.7.bb2
-rw-r--r--meta-openstack/recipes-devtools/python/python3-testresources_2.0.1.bb19
3 files changed, 19 insertions, 12 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-testresources.inc b/meta-openstack/recipes-devtools/python/python-testresources.inc
deleted file mode 100644
index 67ad6c4..0000000
--- a/meta-openstack/recipes-devtools/python/python-testresources.inc
+++ /dev/null
@@ -1,10 +0,0 @@
1DESCRIPTION = "Testresources, a pyunit extension for managing expensive test resources"
2HOMEPAGE = "https://pypi.python.org/pypi/testtools/"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://README;md5=038679cd2cf27bb2acc70257bfee0f41"
6
7SRC_URI[md5sum] = "db2e774be2a6f5754cbbf4c537f823d0"
8SRC_URI[sha256sum] = "ad0a117383dd463827b199eaa92829b4d6a3147fbd97459820df53bae81d7231"
9
10inherit pypi
diff --git a/meta-openstack/recipes-devtools/python/python3-testresources_0.2.7.bb b/meta-openstack/recipes-devtools/python/python3-testresources_0.2.7.bb
deleted file mode 100644
index 79a535c..0000000
--- a/meta-openstack/recipes-devtools/python/python3-testresources_0.2.7.bb
+++ /dev/null
@@ -1,2 +0,0 @@
1require python-testresources.inc
2inherit setuptools3
diff --git a/meta-openstack/recipes-devtools/python/python3-testresources_2.0.1.bb b/meta-openstack/recipes-devtools/python/python3-testresources_2.0.1.bb
new file mode 100644
index 0000000..111be3c
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-testresources_2.0.1.bb
@@ -0,0 +1,19 @@
1DESCRIPTION = "Testresources, a pyunit extension for managing expensive test resources"
2HOMEPAGE = "https://pypi.python.org/pypi/testtools/"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://PKG-INFO;md5=eb75e5ad7c7ff3315ffafae1403e94b2"
6
7SRC_URI[md5sum] = "8873ab443db5569528964f524228a2d7"
8SRC_URI[sha256sum] = "ee9d1982154a1e212d4e4bac6b610800bfb558e4fb853572a827bc14a96e4417"
9
10inherit setuptools3 pypi
11
12DEPENDS += " \
13 python3-pbr-native \
14"
15
16RDEPENDS_${PN} += " \
17 python3-unittest \
18 python3-pbr \
19"