summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2013-10-31 00:56:52 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2013-11-25 15:25:35 -0500
commitf6a3429956683bd19aa9bdfa05da3cb57451ce2c (patch)
tree6f0560bcc92b421111bd4a3dadfd49d975d0c64c
parent6d7c9b7f4a9ebdc07b4bb21aad49f6434bc5c5dc (diff)
downloadmeta-cloud-services-f6a3429956683bd19aa9bdfa05da3cb57451ce2c.tar.gz
horizon: update to the havana version
While updating to the havana release version, we also switch to git based builds. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-horizon_git.bb (renamed from meta-openstack/recipes-devtools/python/python-horizon_2013.1.3.bb)26
1 files changed, 17 insertions, 9 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-horizon_2013.1.3.bb b/meta-openstack/recipes-devtools/python/python-horizon_git.bb
index fdd0bd0..02a17ea 100644
--- a/meta-openstack/recipes-devtools/python/python-horizon_2013.1.3.bb
+++ b/meta-openstack/recipes-devtools/python/python-horizon_git.bb
@@ -12,7 +12,8 @@ DEPENDS_${PN} += "python-django \
12 python-glanceclient \ 12 python-glanceclient \
13 python-keystoneclient \ 13 python-keystoneclient \
14 python-novaclient \ 14 python-novaclient \
15 python-quantumclient \ 15 python-neutronclient \
16 python-heatclient \
16 python-pytz \ 17 python-pytz \
17 python-django-appconf \ 18 python-django-appconf \
18 python-six \ 19 python-six \
@@ -20,21 +21,23 @@ DEPENDS_${PN} += "python-django \
20 python-lockfile \ 21 python-lockfile \
21 " 22 "
22 23
23PR = "r0" 24PR = "r1"
24SRCNAME = "horizon" 25SRCNAME = "horizon"
25 26
26SRC_URI = "https://launchpad.net/horizon/grizzly/${PV}/+download/${SRCNAME}-${PV}.tar.gz \ 27SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=stable/havana \
27 file://horizon.init \ 28 file://horizon.init \
28 file://fix_bindir_path.patch \ 29 file://fix_bindir_path.patch \
29 " 30 "
30 31
31SRC_URI[md5sum] = "8edb861987dffe3017eada91d3009f0a" 32SRCREV="a93c611e7185234d4a4ce36ba182cf321c2113fe"
32SRC_URI[sha256sum] = "4dbf05e75313d9d6ac966de1d139f26647ab537a3d1f418a3e4424210b4c05fd" 33PV="2013.2+git${SRCPV}"
33 34S = "${WORKDIR}/git"
34S = "${WORKDIR}/${SRCNAME}-${PV}"
35 35
36inherit setuptools update-rc.d python-dir 36inherit setuptools update-rc.d python-dir
37 37
38# no longer required. kept as reference.
39# do_install[dirs] += "${D}/usr/share/bin"
40
38do_install_append() { 41do_install_append() {
39 DASHBOARD_DIR=${D}${PYTHON_SITEPACKAGES_DIR}/openstack_dashboard 42 DASHBOARD_DIR=${D}${PYTHON_SITEPACKAGES_DIR}/openstack_dashboard
40 sed -e "s:^LANGUAGE_CODE =.*:LANGUAGE_CODE = 'en-us':g" \ 43 sed -e "s:^LANGUAGE_CODE =.*:LANGUAGE_CODE = 'en-us':g" \
@@ -51,7 +54,8 @@ do_install_append() {
51 install -m 0755 ${WORKDIR}/horizon ${D}${sysconfdir}/init.d/horizon 54 install -m 0755 ${WORKDIR}/horizon ${D}${sysconfdir}/init.d/horizon
52 fi 55 fi
53 56
54 mv ${D}${datadir}/bin ${DASHBOARD_DIR}/bin 57 # no longer required. kept as reference.
58 # mv ${D}${datadir}/bin ${DASHBOARD_DIR}/bin
55} 59}
56 60
57PACKAGES += "${SRCNAME}" 61PACKAGES += "${SRCNAME}"
@@ -69,15 +73,19 @@ RDEPENDS_${PN} += "nodejs \
69 python-django-compressor \ 73 python-django-compressor \
70 python-django-openstack-auth \ 74 python-django-openstack-auth \
71 python-netaddr \ 75 python-netaddr \
76 python-ceilometerclient \
72 python-cinderclient \ 77 python-cinderclient \
73 python-glanceclient \ 78 python-glanceclient \
79 python-heatclient \
74 python-keystoneclient \ 80 python-keystoneclient \
81 python-lesscpy \
75 python-novaclient \ 82 python-novaclient \
76 python-quantumclient \ 83 python-neutronclient \
77 python-pytz \ 84 python-pytz \
78 python-six \ 85 python-six \
79 python-swiftclient \ 86 python-swiftclient \
80 python-lockfile \ 87 python-lockfile \
88 python-pyyaml \
81 " 89 "
82 90
83RDEPENDS_${SRCNAME} = "${PN}" 91RDEPENDS_${SRCNAME} = "${PN}"