summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2014-11-05 12:11:39 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-11-05 12:11:39 -0500
commitff7384602b97d6bf2e4588773fa9014d08a1db50 (patch)
tree0006289731a1d5d50f5ba6b32f72e5d60115ea3c
parent6ee6f37a3de3cc07707d13d8a793ef6bdaaf3d7b (diff)
downloadmeta-cloud-services-ff7384602b97d6bf2e4588773fa9014d08a1db50.tar.gz
nova: allow empty schemes at python 2.7.3
The upstream project is concerned with a bug in empty schemes with 2.7.3. But since Yocto is 2.7.3 and we get an empty scheme via websockify, no VNC consoles are possible. Rather than upreving python (big change), we aren't being hit by the referenced bug, so we simply make sure that the condition can never be true. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-nova/websocketproxy-allow-empty-schemes-at-python-2.7.3.patch34
-rw-r--r--meta-openstack/recipes-devtools/python/python-nova_git.bb1
2 files changed, 35 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-nova/websocketproxy-allow-empty-schemes-at-python-2.7.3.patch b/meta-openstack/recipes-devtools/python/python-nova/websocketproxy-allow-empty-schemes-at-python-2.7.3.patch
new file mode 100644
index 0000000..e7ff9cb
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-nova/websocketproxy-allow-empty-schemes-at-python-2.7.3.patch
@@ -0,0 +1,34 @@
1From 0d727a196e2fe1e13956e2417b7a325be858b2db Mon Sep 17 00:00:00 2001
2From: Bruce Ashfield <bruce.ashfield@windriver.com>
3Date: Wed, 5 Nov 2014 11:21:48 -0500
4Subject: [PATCH] websocketproxy: allow empty schemes at python 2.7.3
5
6The upstream project is concerned with a bug in empty schemes with
72.7.3. But since Yocto is 2.7.3 and we get an empty scheme via websockify,
8no VNC consoles are possible.
9
10Rather than upreving python (big change), we aren't being hit by the
11referenced bug, so we simply make sure that the condition can never
12be true.
13
14Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
15---
16 nova/console/websocketproxy.py | 2 +-
17 1 file changed, 1 insertion(+), 1 deletion(-)
18
19diff --git a/nova/console/websocketproxy.py b/nova/console/websocketproxy.py
20index 4d32ff4328bb..85e3ab43293f 100644
21--- a/nova/console/websocketproxy.py
22+++ b/nova/console/websocketproxy.py
23@@ -45,7 +45,7 @@ class NovaProxyRequestHandlerBase(object):
24 # The nova expected behavior is to have token
25 # passed to the method GET of the request
26 parse = urlparse.urlparse(self.path)
27- if parse.scheme not in ('http', 'https'):
28+ if parse.scheme not in ('http', 'https') and False:
29 # From a bug in urlparse in Python < 2.7.4 we cannot support
30 # special schemes (cf: http://bugs.python.org/issue9374)
31 if sys.version_info < (2, 7, 4):
32--
331.9.1
34
diff --git a/meta-openstack/recipes-devtools/python/python-nova_git.bb b/meta-openstack/recipes-devtools/python/python-nova_git.bb
index a950bf8..d68725b 100644
--- a/meta-openstack/recipes-devtools/python/python-nova_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-nova_git.bb
@@ -17,6 +17,7 @@ SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=master \
17 file://nova-fix-location-to-doc-directory.patch \ 17 file://nova-fix-location-to-doc-directory.patch \
18 file://nova-fix-location-to-plugin-directory.patch \ 18 file://nova-fix-location-to-plugin-directory.patch \
19 file://neutron-api-set-default-binding-vnic_type.patch \ 19 file://neutron-api-set-default-binding-vnic_type.patch \
20 file://websocketproxy-allow-empty-schemes-at-python-2.7.3.patch \
20 " 21 "
21 22
22SRC_URI += "file://nova-all \ 23SRC_URI += "file://nova-all \