summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2014-10-21 09:19:24 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-10-21 09:19:24 -0400
commitf54a303020a35a6dc0219c7b0a140e31585c938d (patch)
treed5b90114c47523775dd55de79b4bdbacd7ffd01a
parent9be49d7dd9cad6f115d1a0c59e33324e1fef7d79 (diff)
downloadmeta-cloud-services-f54a303020a35a6dc0219c7b0a140e31585c938d.tar.gz
horizon: reorder and update dependencies
Horizon had a rather large set of duplicated DEPENDS, to work around bitbake evaluation order issues. We can now unify the DEPENDS into a single list, and leave RDEPENDS to deal with arch specific differences. We also add missing horizon juno dependencies. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-horizon_git.bb50
1 files changed, 17 insertions, 33 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-horizon_git.bb b/meta-openstack/recipes-devtools/python/python-horizon_git.bb
index 94b85aa..542e553 100644
--- a/meta-openstack/recipes-devtools/python/python-horizon_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-horizon_git.bb
@@ -9,25 +9,31 @@ DEPENDS += " \
9 python-pbr \ 9 python-pbr \
10 " 10 "
11 11
12RDEPENDS_${PN} += "python-django \ 12RDEPENDS_${PN} += " python-django \
13 python-django-appconf \
13 python-django-compressor \ 14 python-django-compressor \
14 python-django-nose \ 15 python-django-nose \
15 python-django-openstack-auth \ 16 python-django-openstack-auth \
16 python-netaddr \ 17 python-netaddr \
18 python-ceilometerclient \
17 python-cinderclient \ 19 python-cinderclient \
18 python-glanceclient \ 20 python-glanceclient \
21 python-heatclient \
19 python-keystoneclient \ 22 python-keystoneclient \
20 python-nose-exclude \ 23 python-troveclient \
24 python-saharaclient \
25 python-lesscpy \
21 python-novaclient \ 26 python-novaclient \
27 python-nose-exclude \
22 python-neutronclient \ 28 python-neutronclient \
23 python-heatclient \
24 python-pytz \ 29 python-pytz \
25 python-django-appconf \ 30 python-pbr \
26 python-six \ 31 python-six \
27 python-swiftclient \ 32 python-swiftclient \
28 python-lockfile \ 33 python-lockfile \
29 python-pbr \ 34 python-pyyaml \
30 python-troveclient \ 35 python-xstatic \
36 python-xstatic-jquery \
31 python-xstatic-angular \ 37 python-xstatic-angular \
32 python-xstatic-angular-cookies \ 38 python-xstatic-angular-cookies \
33 python-xstatic-angular-mock \ 39 python-xstatic-angular-mock \
@@ -44,9 +50,12 @@ RDEPENDS_${PN} += "python-django \
44 python-xstatic-bootstrap-datepicker \ 50 python-xstatic-bootstrap-datepicker \
45 python-xstatic-bootstrap-scss \ 51 python-xstatic-bootstrap-scss \
46 python-xstatic-font-awesome \ 52 python-xstatic-font-awesome \
53 python-xstatic-jquery-ui \
54 python-pyscss \
55 python-django-pyscss \
47 " 56 "
48 57
49PR = "r2" 58PR = "r3"
50SRCNAME = "horizon" 59SRCNAME = "horizon"
51 60
52SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=master \ 61SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=master \
@@ -146,32 +155,7 @@ RDEP_ARCH_VAR_i686 = "nodejs"
146RDEP_ARCH_VAR_x86-64 = "nodejs" 155RDEP_ARCH_VAR_x86-64 = "nodejs"
147RDEP_ARCH_VAR_ia32 = "nodejs" 156RDEP_ARCH_VAR_ia32 = "nodejs"
148 157
149RDEPENDS_${PN} += " python-django \ 158RDEPENDS_${PN} += " \
150 python-django-appconf \
151 python-django-compressor \
152 python-django-nose \
153 python-django-openstack-auth \
154 python-netaddr \
155 python-ceilometerclient \
156 python-cinderclient \
157 python-glanceclient \
158 python-heatclient \
159 python-keystoneclient \
160 python-troveclient \
161 python-saharaclient \
162 python-lesscpy \
163 python-novaclient \
164 python-nose-exclude \
165 python-neutronclient \
166 python-pytz \
167 python-six \
168 python-swiftclient \
169 python-lockfile \
170 python-pyyaml \
171 python-xstatic \
172 python-xstatic-jquery \
173 python-pyscss \
174 python-django-pyscss \
175 ${RDEP_ARCH_VAR} \ 159 ${RDEP_ARCH_VAR} \
176 " 160 "
177 161