diff options
author | Bruce Ashfield <bruce.ashfield@windriver.com> | 2013-11-14 23:07:24 -0500 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@windriver.com> | 2013-11-25 15:25:38 -0500 |
commit | d36d9a4408b2432175ce824b39952f732ac156d1 (patch) | |
tree | 7c44b80bef6dce36464f656ac6a9ee89f3742ff9 | |
parent | 6825d41b388566c8c74307b66ec74ea3d32da749 (diff) | |
download | meta-cloud-services-d36d9a4408b2432175ce824b39952f732ac156d1.tar.gz |
images: add variables for package additions
By default the controller and compute images use IMAGE_INSTALL= to
set their package lists. This doesn't allow a local.conf to add
packages via IMAGE_INSTALL += <FOO>.
To allow package addition, but yet still control the base package list,
there are two variables that can now be used to add packages:
${OPENSTACK_COMPUTE_EXTRA_INSTALL}
${OPENSTACK_CONTROLLER_EXTRA_INSTALL}
Which variable does what, should be self explanitory.
Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r-- | meta-openstack/recipes-extended/images/openstack-image-compute.bb | 3 | ||||
-rw-r--r-- | meta-openstack/recipes-extended/images/openstack-image-controller.bb | 3 |
2 files changed, 6 insertions, 0 deletions
diff --git a/meta-openstack/recipes-extended/images/openstack-image-compute.bb b/meta-openstack/recipes-extended/images/openstack-image-compute.bb index 4657471..34c773f 100644 --- a/meta-openstack/recipes-extended/images/openstack-image-compute.bb +++ b/meta-openstack/recipes-extended/images/openstack-image-compute.bb | |||
@@ -1,10 +1,13 @@ | |||
1 | DESCRIPTION = "Openstack compute node image" | 1 | DESCRIPTION = "Openstack compute node image" |
2 | LICENSE = "MIT" | 2 | LICENSE = "MIT" |
3 | 3 | ||
4 | OPENSTACK_COMPUTE_EXTRA_INSTALL ?= "" | ||
5 | |||
4 | IMAGE_INSTALL = " \ | 6 | IMAGE_INSTALL = " \ |
5 | packagegroup-core-boot \ | 7 | packagegroup-core-boot \ |
6 | ${ROOTFS_PKGMANAGE_BOOTSTRAP} \ | 8 | ${ROOTFS_PKGMANAGE_BOOTSTRAP} \ |
7 | packagegroup-cloud-compute \ | 9 | packagegroup-cloud-compute \ |
10 | ${OPENSTACK_COMPUTE_EXTRA_INSTALL} \ | ||
8 | " | 11 | " |
9 | 12 | ||
10 | IMAGE_FEATURES += "ssh-server-openssh" | 13 | IMAGE_FEATURES += "ssh-server-openssh" |
diff --git a/meta-openstack/recipes-extended/images/openstack-image-controller.bb b/meta-openstack/recipes-extended/images/openstack-image-controller.bb index a57b54b..1f5b6d4 100644 --- a/meta-openstack/recipes-extended/images/openstack-image-controller.bb +++ b/meta-openstack/recipes-extended/images/openstack-image-controller.bb | |||
@@ -1,12 +1,15 @@ | |||
1 | DESCRIPTION = "Openstack controller node image" | 1 | DESCRIPTION = "Openstack controller node image" |
2 | LICENSE = "MIT" | 2 | LICENSE = "MIT" |
3 | 3 | ||
4 | OPENSTACK_CONTROLLER_EXTRA_INSTALL ?= "" | ||
5 | |||
4 | IMAGE_INSTALL = "\ | 6 | IMAGE_INSTALL = "\ |
5 | ${CORE_IMAGE_BASE_INSTALL} \ | 7 | ${CORE_IMAGE_BASE_INSTALL} \ |
6 | ${ROOTFS_PKGMANAGE_BOOTSTRAP} \ | 8 | ${ROOTFS_PKGMANAGE_BOOTSTRAP} \ |
7 | packagegroup-core-basic \ | 9 | packagegroup-core-basic \ |
8 | packagegroup-cloud-controller \ | 10 | packagegroup-cloud-controller \ |
9 | packagegroup-cloud-network \ | 11 | packagegroup-cloud-network \ |
12 | ${OPENSTACK_CONTROLLER_EXTRA_INSTALL} \ | ||
10 | " | 13 | " |
11 | 14 | ||
12 | IMAGE_FEATURES += " ssh-server-openssh" | 15 | IMAGE_FEATURES += " ssh-server-openssh" |