summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2014-10-17 13:20:31 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-10-17 13:20:31 -0400
commit987b63efbac4dd891947bf6820c2f161cc0454c4 (patch)
treef4186a17e83308b6f9aa74c89d85b884f5e8272f
parent848bc28047dff0029f15ab95cd0f7b14ebf5a159 (diff)
downloadmeta-cloud-services-987b63efbac4dd891947bf6820c2f161cc0454c4.tar.gz
core: update to juno-rc1 candidate release
Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-barbican_git.bb4
-rw-r--r--meta-openstack/recipes-devtools/python/python-ceilometer_git.bb9
-rw-r--r--meta-openstack/recipes-devtools/python/python-cinder_git.bb4
-rw-r--r--meta-openstack/recipes-devtools/python/python-glance_git.bb4
-rw-r--r--meta-openstack/recipes-devtools/python/python-heat_git.bb4
-rw-r--r--meta-openstack/recipes-devtools/python/python-keystone_git.bb4
-rw-r--r--meta-openstack/recipes-devtools/python/python-keystonemiddleware_git.bb4
-rw-r--r--meta-openstack/recipes-devtools/python/python-neutron_git.bb4
-rw-r--r--meta-openstack/recipes-devtools/python/python-nova_git.bb4
-rw-r--r--meta-openstack/recipes-devtools/python/python-swift_git.bb4
10 files changed, 24 insertions, 21 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-barbican_git.bb b/meta-openstack/recipes-devtools/python/python-barbican_git.bb
index e683743..469b1f7 100644
--- a/meta-openstack/recipes-devtools/python/python-barbican_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-barbican_git.bb
@@ -15,8 +15,8 @@ SRC_URI = "git://github.com/openstack/barbican.git;branch=master \
15 file://barbican-handle-white-space-in-date-strings.patch \ 15 file://barbican-handle-white-space-in-date-strings.patch \
16 " 16 "
17 17
18SRCREV="ada968e162d9795613bfb346a1018f63ef7025cc" 18SRCREV="1000ca44f264b09c0347ac56815a4f0ef02cf0eb"
19PV="2014.2.b3+git${SRCPV}" 19PV="2014.2.rc1+git${SRCPV}"
20S = "${WORKDIR}/git" 20S = "${WORKDIR}/git"
21 21
22inherit update-rc.d setuptools identity hosts useradd default_configs openstackchef monitor 22inherit update-rc.d setuptools identity hosts useradd default_configs openstackchef monitor
diff --git a/meta-openstack/recipes-devtools/python/python-ceilometer_git.bb b/meta-openstack/recipes-devtools/python/python-ceilometer_git.bb
index 90ac1c6..89f890a 100644
--- a/meta-openstack/recipes-devtools/python/python-ceilometer_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-ceilometer_git.bb
@@ -16,8 +16,8 @@ SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=master \
16# file://ceilometer-builtin-tests-config-location.patch 16# file://ceilometer-builtin-tests-config-location.patch
17 17
18 18
19SRCREV="500388c3fe8be48be046908acd549f5e28608921" 19SRCREV="42c3d487aac5d383f5224ffc4d402387562895df"
20PV="2014.2.b3+git${SRCPV}" 20PV="2014.2.rc1+git${SRCPV}"
21S = "${WORKDIR}/git" 21S = "${WORKDIR}/git"
22 22
23CEILOMETER_SECRET ?= "12121212" 23CEILOMETER_SECRET ?= "12121212"
@@ -104,7 +104,9 @@ do_install_append() {
104 install -m 0755 ${WORKDIR}/ceilometer-agent-notification.init.sh ${D}${sysconfdir}/init.d/ceilometer-agent-notification 104 install -m 0755 ${WORKDIR}/ceilometer-agent-notification.init.sh ${D}${sysconfdir}/init.d/ceilometer-agent-notification
105 fi 105 fi
106 106
107 cp setup-test-env.sh ${CEILOMETER_CONF_DIR} 107 if [ -e "setup-test-env.sh" ]; then
108 cp setup-test-env.sh ${CEILOMETER_CONF_DIR}
109 fi
108} 110}
109 111
110CHEF_SERVICES_CONF_FILES :="\ 112CHEF_SERVICES_CONF_FILES :="\
@@ -138,6 +140,7 @@ PACKAGES += " ${SRCNAME}-reseller"
138 140
139ALLOW_EMPTY_${SRCNAME}-setup = "1" 141ALLOW_EMPTY_${SRCNAME}-setup = "1"
140ALLOW_EMPTY_${SRCNAME}-reseller = "1" 142ALLOW_EMPTY_${SRCNAME}-reseller = "1"
143ALLOW_EMPTY_${SRCNAME}-tests = "1"
141 144
142FILES_${PN} = "${libdir}/*" 145FILES_${PN} = "${libdir}/*"
143 146
diff --git a/meta-openstack/recipes-devtools/python/python-cinder_git.bb b/meta-openstack/recipes-devtools/python/python-cinder_git.bb
index 5ae149d..acb841a 100644
--- a/meta-openstack/recipes-devtools/python/python-cinder_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-cinder_git.bb
@@ -20,8 +20,8 @@ SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=master \
20 file://cinder-builtin-tests-config-location.patch \ 20 file://cinder-builtin-tests-config-location.patch \
21 " 21 "
22 22
23SRCREV="58eda5d1f41082a7e1ffef66239be30b8ac1321a" 23SRCREV="9ba3603d8f2cf33b33265012b2cb2480eba7b35a"
24PV="2014.2.b3+git${SRCPV}" 24PV="2014.2.rc1+git${SRCPV}"
25S = "${WORKDIR}/git" 25S = "${WORKDIR}/git"
26 26
27inherit setuptools update-rc.d identity default_configs hosts openstackchef monitor 27inherit setuptools update-rc.d identity default_configs hosts openstackchef monitor
diff --git a/meta-openstack/recipes-devtools/python/python-glance_git.bb b/meta-openstack/recipes-devtools/python/python-glance_git.bb
index 53f2d5b..fd884b5 100644
--- a/meta-openstack/recipes-devtools/python/python-glance_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-glance_git.bb
@@ -14,8 +14,8 @@ SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=master \
14 14
15# removed. juno uses store library: file://0001-glance-store-only-load-known-stores-not-all-stores.patch 15# removed. juno uses store library: file://0001-glance-store-only-load-known-stores-not-all-stores.patch
16 16
17SRCREV="7374d9347eeb6b354484984f06fd7e58fed50046" 17SRCREV="675a39a74faad5f7fe4eb94e1dcf7f4359ed2285"
18PV="2014.2.b3+git${SRCPV}" 18PV="2014.2.rc1+git${SRCPV}"
19 19
20S = "${WORKDIR}/git" 20S = "${WORKDIR}/git"
21 21
diff --git a/meta-openstack/recipes-devtools/python/python-heat_git.bb b/meta-openstack/recipes-devtools/python/python-heat_git.bb
index 8971e41..9c1ecae 100644
--- a/meta-openstack/recipes-devtools/python/python-heat_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-heat_git.bb
@@ -16,8 +16,8 @@ SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=master \
16 file://heat-tests-change-project_dir-path.patch \ 16 file://heat-tests-change-project_dir-path.patch \
17" 17"
18 18
19SRCREV="9b700a1b6e1c806d8deba64ffb9a804790765678" 19SRCREV="4a8cb4b2041edfa4a166b0a5dd7566874cf7c6f2"
20PV="2014.2.b3+git${SRCPV}" 20PV="2014.2.rc1+git${SRCPV}"
21S = "${WORKDIR}/git" 21S = "${WORKDIR}/git"
22 22
23SERVICECREATE_PACKAGES = "${SRCNAME}-setup ${SRCNAME}-templates ${SRCNAME}-cfn" 23SERVICECREATE_PACKAGES = "${SRCNAME}-setup ${SRCNAME}-templates ${SRCNAME}-cfn"
diff --git a/meta-openstack/recipes-devtools/python/python-keystone_git.bb b/meta-openstack/recipes-devtools/python/python-keystone_git.bb
index 7512742..9bdce3f 100644
--- a/meta-openstack/recipes-devtools/python/python-keystone_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-keystone_git.bb
@@ -17,8 +17,8 @@ SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=master \
17 file://wsgi-keystone.conf \ 17 file://wsgi-keystone.conf \
18 " 18 "
19 19
20SRCREV="73ad4036d62b3aa7cf50e11ddf7bee8278bbe4d0" 20SRCREV="b276f3dbc9ef1a6b2bd952c88eb45fde9b646f68"
21PV="2014.2.b3+git${SRCPV}" 21PV="2014.2.rc1+git${SRCPV}"
22 22
23S = "${WORKDIR}/git" 23S = "${WORKDIR}/git"
24 24
diff --git a/meta-openstack/recipes-devtools/python/python-keystonemiddleware_git.bb b/meta-openstack/recipes-devtools/python/python-keystonemiddleware_git.bb
index f99dcd7..26bba6d 100644
--- a/meta-openstack/recipes-devtools/python/python-keystonemiddleware_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-keystonemiddleware_git.bb
@@ -11,8 +11,8 @@ SRC_URI = "\
11 git://git.openstack.org/openstack/keystonemiddleware;branch=master \ 11 git://git.openstack.org/openstack/keystonemiddleware;branch=master \
12 " 12 "
13 13
14PV="1.1.1+git${SRCPV}" 14PV="1.2.0+git${SRCPV}"
15SRCREV="a4c13473aa09edee3c16733a4ff16f2cc206ad66" 15SRCREV="4434a77e7c679dcad1db67fba4459afa4c5c7c67"
16S = "${WORKDIR}/git" 16S = "${WORKDIR}/git"
17 17
18inherit setuptools 18inherit setuptools
diff --git a/meta-openstack/recipes-devtools/python/python-neutron_git.bb b/meta-openstack/recipes-devtools/python/python-neutron_git.bb
index 6a9e66f..677730f 100644
--- a/meta-openstack/recipes-devtools/python/python-neutron_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-neutron_git.bb
@@ -20,8 +20,8 @@ SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=master \
20 file://uuid_wscheck.patch \ 20 file://uuid_wscheck.patch \
21 file://neutron-test-nec-plugin-extensions-location.patch \ 21 file://neutron-test-nec-plugin-extensions-location.patch \
22 " 22 "
23SRCREV="3cd2550f1bb20dbbc00a01d8dfd8b53e00baa00d" 23SRCREV="90a9e588052c1f96d9f3f0d63de3bdfa3c5b8656"
24PV="2014.2.b3+git${SRCPV}" 24PV="2014.2.rc1+git${SRCPV}"
25 25
26S = "${WORKDIR}/git" 26S = "${WORKDIR}/git"
27 27
diff --git a/meta-openstack/recipes-devtools/python/python-nova_git.bb b/meta-openstack/recipes-devtools/python/python-nova_git.bb
index e79302b..86dca6f 100644
--- a/meta-openstack/recipes-devtools/python/python-nova_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-nova_git.bb
@@ -25,8 +25,8 @@ SRC_URI += "file://nova-all \
25 file://nova.conf \ 25 file://nova.conf \
26 file://openrc \ 26 file://openrc \
27 " 27 "
28SRCREV="a5f09ddddfba65b8fdc6bac994750e5980b27521" 28SRCREV="ba0a08c11535a9cedc07e1329e8bf729af3d4b02"
29PV="2014.2.b3+git${SRCPV}" 29PV="2014.2.rc1+git${SRCPV}"
30 30
31S = "${WORKDIR}/git" 31S = "${WORKDIR}/git"
32 32
diff --git a/meta-openstack/recipes-devtools/python/python-swift_git.bb b/meta-openstack/recipes-devtools/python/python-swift_git.bb
index bac992a..7241be9 100644
--- a/meta-openstack/recipes-devtools/python/python-swift_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-swift_git.bb
@@ -16,8 +16,8 @@ SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=master \
16 file://cluster.conf \ 16 file://cluster.conf \
17" 17"
18 18
19SRCREV="d4da726f6f45187dc053578f11246d6b36679142" 19SRCREV="6986f7272ce6b4ada209bc84f1da19602c9e6b83"
20PV="2.1.0+git${SRCPV}" 20PV="2.2.0.rc1+git${SRCPV}"
21S = "${WORKDIR}/git" 21S = "${WORKDIR}/git"
22 22
23inherit setuptools python-dir update-rc.d hosts identity openstackchef 23inherit setuptools python-dir update-rc.d hosts identity openstackchef