summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2014-10-21 10:14:48 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-10-21 10:14:48 -0400
commit86b80ab2e9cbb3a7dfc1164b0205eaffcf4f2363 (patch)
tree034877b096e0940feea060aab5faef80e15aa533
parent5cd2721115351f45681aecbf2cd6798b7082c2ac (diff)
downloadmeta-cloud-services-86b80ab2e9cbb3a7dfc1164b0205eaffcf4f2363.tar.gz
keystone: update for Juno rc1
We have three changes in a single commit: - A runtime substition fix controller IP values - When the substitions were moved for chef integration, the chef disabled path wasn't tested. This meant that %CONTROLLER_IP% remained in the final config files, and broke keystone startup. - The addition of oathlib to keystone depedencies - oauthlib is a juno dependency - A temporary patch to the apache httpd front end modules - At times keystone would fail to load via apache due to the inability to load localcontext from oslo. To work around these sporadic failures, an explicit import was added to the http front end module. This will be removed in the future. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-keystone/keystone-explicitly-import-localcontext-from-oslo.me.patch32
-rw-r--r--meta-openstack/recipes-devtools/python/python-keystone_git.bb20
2 files changed, 43 insertions, 9 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-keystone/keystone-explicitly-import-localcontext-from-oslo.me.patch b/meta-openstack/recipes-devtools/python/python-keystone/keystone-explicitly-import-localcontext-from-oslo.me.patch
new file mode 100644
index 0000000..5c152e0
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-keystone/keystone-explicitly-import-localcontext-from-oslo.me.patch
@@ -0,0 +1,32 @@
1From 0d6b66b2d5314b454a421bd22fcc8173baf0bc95 Mon Sep 17 00:00:00 2001
2From: Bruce Ashfield <bruce.ashfield@windriver.com>
3Date: Mon, 20 Oct 2014 15:59:33 -0400
4Subject: [PATCH] keystone: explicitly import localcontext from oslo.messaging
5
6When using apache as a front end to keystone, juno has a problem when
7authenticating clients due to a failure to import localcontext from
8oslo.
9
10We can work around this issue by doing the export explicitly in the
11entry routine versus in the library itself.
12
13Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
14---
15 httpd/keystone.py | 1 +
16 1 file changed, 1 insertion(+)
17
18diff --git a/httpd/keystone.py b/httpd/keystone.py
19index f5ce498c5152..b2b9285ad2ab 100644
20--- a/httpd/keystone.py
21+++ b/httpd/keystone.py
22@@ -32,6 +32,7 @@ from keystone.common import sql
23 from keystone import config
24 from keystone.openstack.common import log
25 from keystone import service
26+from oslo.messaging import localcontext
27
28
29 CONF = config.CONF
30--
311.9.1
32
diff --git a/meta-openstack/recipes-devtools/python/python-keystone_git.bb b/meta-openstack/recipes-devtools/python/python-keystone_git.bb
index 9bdce3f..18f77ef 100644
--- a/meta-openstack/recipes-devtools/python/python-keystone_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-keystone_git.bb
@@ -4,7 +4,7 @@ SECTION = "devel/python"
4LICENSE = "Apache-2.0" 4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2" 5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6 6
7PR = "r1" 7PR = "r2"
8SRCNAME = "keystone" 8SRCNAME = "keystone"
9 9
10SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=master \ 10SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=master \
@@ -13,6 +13,7 @@ SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=master \
13 file://keystone \ 13 file://keystone \
14 file://keystone-search-in-etc-directory-for-config-files.patch \ 14 file://keystone-search-in-etc-directory-for-config-files.patch \
15 file://keystone-remove-git-commands-in-tests.patch \ 15 file://keystone-remove-git-commands-in-tests.patch \
16 file://keystone-explicitly-import-localcontext-from-oslo.me.patch \
16 file://convert_keystone_backend.py \ 17 file://convert_keystone_backend.py \
17 file://wsgi-keystone.conf \ 18 file://wsgi-keystone.conf \
18 " 19 "
@@ -103,6 +104,14 @@ do_install_append() {
103 install -d ${D}${sysconfdir}/init.d 104 install -d ${D}${sysconfdir}/init.d
104 install -m 0755 ${WORKDIR}/keystone ${D}${sysconfdir}/init.d/keystone 105 install -m 0755 ${WORKDIR}/keystone ${D}${sysconfdir}/init.d/keystone
105 fi 106 fi
107
108 sed "/# admin_endpoint = .*/a \
109 public_endpoint = http://%CONTROLLER_IP%:8081/keystone/main/ " \
110 -i ${KEYSTONE_CONF_DIR}/keystone.conf
111
112 sed "/# admin_endpoint = .*/a \
113 admin_endpoint = http://%CONTROLLER_IP%:8081/keystone/admin/ " \
114 -i ${KEYSTONE_CONF_DIR}/keystone.conf
106 115
107 if [ -z "${OPENSTACKCHEF_ENABLED}" ]; then 116 if [ -z "${OPENSTACKCHEF_ENABLED}" ]; then
108 sed -e "s:%SERVICE_TOKEN%:${SERVICE_TOKEN}:g" \ 117 sed -e "s:%SERVICE_TOKEN%:${SERVICE_TOKEN}:g" \
@@ -127,14 +136,6 @@ do_install_append() {
127 -i ${D}${sysconfdir}/init.d/keystone 136 -i ${D}${sysconfdir}/init.d/keystone
128 fi 137 fi
129 138
130 sed "/# admin_endpoint = .*/a \
131 public_endpoint = http://%CONTROLLER_IP%:8081/keystone/main/ " \
132 -i ${KEYSTONE_CONF_DIR}/keystone.conf
133
134 sed "/# admin_endpoint = .*/a \
135 admin_endpoint = http://%CONTROLLER_IP%:8081/keystone/admin/ " \
136 -i ${KEYSTONE_CONF_DIR}/keystone.conf
137
138 install -d ${KEYSTONE_PACKAGE_DIR}/tests/tmp 139 install -d ${KEYSTONE_PACKAGE_DIR}/tests/tmp
139 140
140 if [ -e "${KEYSTONE_PACKAGE_DIR}/tests/test_overrides.conf" ];then 141 if [ -e "${KEYSTONE_PACKAGE_DIR}/tests/test_overrides.conf" ];then
@@ -279,6 +280,7 @@ RDEPENDS_${PN} += " \
279 python-dogpile.cache \ 280 python-dogpile.cache \
280 python-pbr \ 281 python-pbr \
281 python-oslo.utils \ 282 python-oslo.utils \
283 python-oauthlib \
282 " 284 "
283 285
284PACKAGECONFIG ?= "${@base_contains('DISTRO_FEATURES', 'OpenLDAP', 'OpenLDAP', '', d)}" 286PACKAGECONFIG ?= "${@base_contains('DISTRO_FEATURES', 'OpenLDAP', 'OpenLDAP', '', d)}"