summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYangHaibo <b40869@freescale.com>2014-12-03 11:00:11 +0800
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-12-18 12:59:52 -0500
commit8106f692daf771d665f4f4cc275f0221c1527210 (patch)
tree518b2d827b71135cd0d4c572ef2ab2fd8d9e5b82
parent0e12d8177e21c85beeb3d8f45699224634047f90 (diff)
downloadmeta-cloud-services-8106f692daf771d665f4f4cc275f0221c1527210.tar.gz
hiera: add recipe for hiera 1.3.4
Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--meta-openstack/recipes-support/hiera/hiera/add_hiera_gemspec.patch23
-rw-r--r--meta-openstack/recipes-support/hiera/hiera_1.3.4.bb20
2 files changed, 43 insertions, 0 deletions
diff --git a/meta-openstack/recipes-support/hiera/hiera/add_hiera_gemspec.patch b/meta-openstack/recipes-support/hiera/hiera/add_hiera_gemspec.patch
new file mode 100644
index 0000000..7e302cf
--- /dev/null
+++ b/meta-openstack/recipes-support/hiera/hiera/add_hiera_gemspec.patch
@@ -0,0 +1,23 @@
1diff -urN hiera-1.3.4_ori/hiera.gemspec hiera-1.3.4/hiera.gemspec
2--- hiera-1.3.4_ori/hiera.gemspec 1970-01-01 08:00:00.000000000 +0800
3+++ hiera-1.3.4/hiera.gemspec 2014-11-12 14:30:07.000000000 +0800
4@@ -0,0 +1,19 @@
5+$:.unshift(File.dirname(__FILE__) + '/lib')
6+require 'hiera/version'
7+
8+Gem::Specification.new do |s|
9+ s.name = 'hiera'
10+ s.version = Hiera::VERSION
11+ s.platform = Gem::Platform::RUBY
12+ s.summary = 'A simple pluggable Hierarchical Database.'
13+ s.description = s.summary
14+ s.author = 'Yang Haibo'
15+ s.email = 'b40869@freescale.com'
16+ s.homepage = 'https://projects.puppetlabs.com/projects/hiera'
17+ s.license = 'Apache 2.0'
18+
19+ s.bindir = 'bin'
20+ s.executables = ['hiera']
21+ s.require_path = 'lib'
22+ s.files = %w(LICENSE README.md Rakefile) + Dir.glob('{lib,spec}/**/*')
23+end
diff --git a/meta-openstack/recipes-support/hiera/hiera_1.3.4.bb b/meta-openstack/recipes-support/hiera/hiera_1.3.4.bb
new file mode 100644
index 0000000..eb633ff
--- /dev/null
+++ b/meta-openstack/recipes-support/hiera/hiera_1.3.4.bb
@@ -0,0 +1,20 @@
1SUMMARY = "A simple pluggable Hierarchical Database"
2HOMEPAGE = "https://projects.puppetlabs.com/projects/hiera"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=8ac92c91fbec097f798223679c1a7491"
5
6SRC_URI = " \
7 https://downloads.puppetlabs.com/hiera/hiera-${PV}.tar.gz \
8 file://add_hiera_gemspec.patch \
9"
10SRC_URI[md5sum] = "6abccc518edb55291a63129ef30888cd"
11SRC_URI[sha256sum] = "d3ecbfedc7d8493fd00c7dd624efbb225705d289442fe7706cb81a3a7230e70e"
12
13
14inherit ruby
15
16DEPENDS += " \
17 ruby \
18"
19
20RUBY_INSTALL_GEMS = "hiera-${PV}.gem"