summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2014-10-21 09:26:22 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-10-21 09:52:25 -0400
commit678848370eac1ed2a9422cb5fd6dfaca025fbb49 (patch)
tree7c73321ae528c5e4b62e3261d49d6d8166379eec
parent187c367ee8797ebe882e70bcad42a4cfb13f7641 (diff)
downloadmeta-cloud-services-678848370eac1ed2a9422cb5fd6dfaca025fbb49.tar.gz
keystone/libs: introduce oauthlib
In the juno release, keystone depends on oauthlib, so we introduce the recipe. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-oauthlib_0.6.3.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-oauthlib_0.6.3.bb b/meta-openstack/recipes-devtools/python/python-oauthlib_0.6.3.bb
new file mode 100644
index 0000000..336de30
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-oauthlib_0.6.3.bb
@@ -0,0 +1,35 @@
1DESCRIPTION = "A generic, spec-compliant, thorough implementation of the OAuth request-signing logic"
2HOMEPAGE = "https://github.com/idan/oauthlib"
3SECTION = "devel/python"
4LICENSE = "Apache-2"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=5ba9ce41463615e082609806255bce1b"
6
7PR = "r1"
8
9SRCNAME = "oauthlib"
10SRC_URI = "http://pypi.python.org/packages/source/o/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
11
12SRC_URI[md5sum] = "3ecba28f991ee58db2aeda8b4e2b56b1"
13SRC_URI[sha256sum] = "0a11ab2311f7a29d0079fe529bde9503fec9a2bdd52db834cf8a284a8c1c52f9"
14
15S = "${WORKDIR}/${SRCNAME}-${PV}"
16
17inherit setuptools
18
19# DEPENDS_default: python-pip
20
21DEPENDS += " \
22 python-pip \
23 "
24
25# RDEPENDS_default:
26RDEPENDS_${PN} += " \
27 "
28
29do_install_append() {
30 perm_files=`find "${D}${PYTHON_SITEPACKAGES_DIR}/" -name "top_level.txt"`
31 for f in $perm_files; do
32 chmod 644 "${f}"
33 done
34}
35