summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2014-10-21 09:25:46 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-10-21 09:25:46 -0400
commit187c367ee8797ebe882e70bcad42a4cfb13f7641 (patch)
treeaff5a799bdff9ecea54d83ffdc430dbbd696eb71
parent9a1a68263712299d6a20942a9446fe0c9432821f (diff)
downloadmeta-cloud-services-187c367ee8797ebe882e70bcad42a4cfb13f7641.tar.gz
oslo: add rootwrap
Integrate oslo.rootwrap to meet juno dependencies for core projects Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-oslo.rootwrap_1.3.0.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-oslo.rootwrap_1.3.0.bb b/meta-openstack/recipes-devtools/python/python-oslo.rootwrap_1.3.0.bb
new file mode 100644
index 0000000..1391dcd
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-oslo.rootwrap_1.3.0.bb
@@ -0,0 +1,27 @@
1DESCRIPTION = "Oslo Rootwrap"
2HOMEPAGE = "https://launchpad.net/oslo"
3SECTION = "devel/python"
4LICENSE = "Apache-2"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=c46f31914956e4579f9b488e71415ac8"
6
7PR = "r0"
8
9SRCNAME = "oslo.rootwrap"
10SRC_URI = "http://pypi.python.org/packages/source/o/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
11
12SRC_URI[md5sum] = "b867d1670d7e744790e9c6b503ec8838"
13SRC_URI[sha256sum] = "42081a30779be0a8e33ee53f4e1235c17080278c4285505a6b65243740aab629"
14
15S = "${WORKDIR}/${SRCNAME}-${PV}"
16
17inherit setuptools
18
19# DEPENDS_default: python-pip
20
21DEPENDS += " \
22 python-pip \
23 "
24
25# RDEPENDS_default:
26RDEPENDS_${PN} += " \
27 "