summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMingli Yu <mingli.yu@windriver.com>2024-04-11 11:03:49 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2024-04-15 20:58:56 +0000
commit42687d8e3094b79b85763916707fba2836ccf2c8 (patch)
treea22f0318edc84c5b4124a2829b2b39af86df20dc
parente17a391cfd9bc9caa6002f4b5283f6da5b7476cf (diff)
downloadmeta-cloud-services-master.tar.gz
python3-ansible-collections: Add new recipeHEADmaster
Ansible is a radically simple model-driven configuration management, multi-node deployment, and remote task execution system. Ansible works over SSH and does not require any software or daemons to be installed on remote nodes. Extension modules can be written in any language and are transferred to managed machines automatically. This recipe provides a curated set of Ansible collections included in addition to ansible-core which provided by python3-ansible. Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--recipes-devtools/python/python3-ansible-collections_9.4.0.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes-devtools/python/python3-ansible-collections_9.4.0.bb b/recipes-devtools/python/python3-ansible-collections_9.4.0.bb
new file mode 100644
index 0000000..94f1af0
--- /dev/null
+++ b/recipes-devtools/python/python3-ansible-collections_9.4.0.bb
@@ -0,0 +1,22 @@
1SUMMARY = "Curated set of Ansible collections included in addition to ansible-core"
2DESCRIPTION = "Ansible is a radically simple model-driven configuration management, \
3multi-node deployment, and remote task execution system. Ansible works \
4over SSH and does not require any software or daemons to be installed \
5on remote nodes. Extension modules can be written in any language and \
6are transferred to managed machines automatically. \
7This package provides a curated set of Ansible collections included in addition \
8to ansible-core."
9HOMEPAGE = "https://pypi.org/project/ansible/"
10LICENSE = "GPL-3.0-or-later"
11LIC_FILES_CHKSUM = "file://COPYING;md5=8f0e2cd40e05189ec81232da84bd6e1a"
12
13PYPI_PACKAGE = "ansible"
14
15inherit pypi setuptools3
16
17SRC_URI[sha256sum] = "dd431c63380e18c3faca3288ebde8ce2f4f992363ab558a3c11c8f2032d90867"
18
19RDEPENDS:${PN} = " \
20 bash \
21 python3-ansible \
22"