diff options
Diffstat (limited to 'recipes-devtools')
-rw-r--r-- | recipes-devtools/clang/compiler-rt_git.bb | 1 | ||||
-rw-r--r-- | recipes-devtools/clang/libcxx_git.bb | 20 | ||||
-rw-r--r-- | recipes-devtools/clang/llvm-libunwind_git.bb | 70 | ||||
-rw-r--r-- | recipes-devtools/clang/openmp_git.bb | 1 |
4 files changed, 14 insertions, 78 deletions
diff --git a/recipes-devtools/clang/compiler-rt_git.bb b/recipes-devtools/clang/compiler-rt_git.bb index 207b8e4..413efd6 100644 --- a/recipes-devtools/clang/compiler-rt_git.bb +++ b/recipes-devtools/clang/compiler-rt_git.bb | |||
@@ -28,7 +28,6 @@ SRCREV_FORMAT = "compiler-rt" | |||
28 | 28 | ||
29 | BASEDEPENDS_remove_toolchain-clang_class-target = "compiler-rt" | 29 | BASEDEPENDS_remove_toolchain-clang_class-target = "compiler-rt" |
30 | BASEDEPENDS_remove_toolchain-clang_class-target = "libcxx" | 30 | BASEDEPENDS_remove_toolchain-clang_class-target = "libcxx" |
31 | BASEDEPENDS_remove_toolchain-clang_class-target = "llvm-libunwind" | ||
32 | 31 | ||
33 | DEPENDS += "ninja-native" | 32 | DEPENDS += "ninja-native" |
34 | 33 | ||
diff --git a/recipes-devtools/clang/libcxx_git.bb b/recipes-devtools/clang/libcxx_git.bb index 26a14d0..2ab7951 100644 --- a/recipes-devtools/clang/libcxx_git.bb +++ b/recipes-devtools/clang/libcxx_git.bb | |||
@@ -14,9 +14,9 @@ PV .= "+git${SRCPV}" | |||
14 | 14 | ||
15 | DEPENDS += "ninja-native" | 15 | DEPENDS += "ninja-native" |
16 | BASEDEPENDS_remove_toolchain-clang_class-target = "libcxx" | 16 | BASEDEPENDS_remove_toolchain-clang_class-target = "libcxx" |
17 | BASEDEPENDS_remove_toolchain-clang_class-target = "llvm-libunwind" | ||
18 | #BASEDEPENDS_remove_toolchain-clang_class-target = "compiler-rt" | ||
19 | 17 | ||
18 | PROVIDES = "libunwind" | ||
19 | PROVIDES_remove_mipsarch = "libunwind" | ||
20 | 20 | ||
21 | LIC_FILES_CHKSUM = "file://projects/libcxx/LICENSE.TXT;md5=7b3a0e1b99822669d630011defe9bfd9; \ | 21 | LIC_FILES_CHKSUM = "file://projects/libcxx/LICENSE.TXT;md5=7b3a0e1b99822669d630011defe9bfd9; \ |
22 | " | 22 | " |
@@ -24,12 +24,13 @@ SRC_URI = "\ | |||
24 | ${LLVM_GIT}/llvm.git;protocol=${LLVM_GIT_PROTOCOL};branch=${BRANCH};name=llvm \ | 24 | ${LLVM_GIT}/llvm.git;protocol=${LLVM_GIT_PROTOCOL};branch=${BRANCH};name=llvm \ |
25 | ${LLVM_GIT}/libcxx.git;protocol=${LLVM_GIT_PROTOCOL};branch=${BRANCH};name=libcxx;destsuffix=git/projects/libcxx \ | 25 | ${LLVM_GIT}/libcxx.git;protocol=${LLVM_GIT_PROTOCOL};branch=${BRANCH};name=libcxx;destsuffix=git/projects/libcxx \ |
26 | ${LLVM_GIT}/libcxxabi.git;protocol=${LLVM_GIT_PROTOCOL};branch=${BRANCH};name=cxxabi;destsuffix=git/projects/libcxxabi \ | 26 | ${LLVM_GIT}/libcxxabi.git;protocol=${LLVM_GIT_PROTOCOL};branch=${BRANCH};name=cxxabi;destsuffix=git/projects/libcxxabi \ |
27 | ${LLVM_GIT}/libunwind.git;protocol=${LLVM_GIT_PROTOCOL};branch=${BRANCH};name=libunwind;destsuffix=git/projects/libunwind \ | ||
27 | ${LLVMPATCHES} \ | 28 | ${LLVMPATCHES} \ |
28 | ${LIBCXXPATCHES} \ | 29 | ${LIBCXXPATCHES} \ |
29 | ${LIBCXXABIPATCHES} \ | 30 | ${LIBCXXABIPATCHES} \ |
30 | " | 31 | " |
31 | 32 | ||
32 | SRCREV_FORMAT = "llvm_libcxx_cxxabi" | 33 | SRCREV_FORMAT = "llvm_libcxx_cxxabi_libunwind" |
33 | 34 | ||
34 | S = "${WORKDIR}/git" | 35 | S = "${WORKDIR}/git" |
35 | 36 | ||
@@ -38,26 +39,33 @@ THUMB_TUNE_CCARGS = "" | |||
38 | 39 | ||
39 | EXTRA_OECMAKE += "\ | 40 | EXTRA_OECMAKE += "\ |
40 | -DLIBCXX_CXX_ABI=libcxxabi \ | 41 | -DLIBCXX_CXX_ABI=libcxxabi \ |
41 | -DLIBCXX_ENABLE_SHARED=ON \ | ||
42 | -DLLVM_BUILD_EXTERNAL_COMPILER_RT=ON \ | 42 | -DLLVM_BUILD_EXTERNAL_COMPILER_RT=ON \ |
43 | -DCXX_SUPPORTS_CXX11=ON \ | 43 | -DCXX_SUPPORTS_CXX11=ON \ |
44 | -DLIBCXXABI_LIBCXX_INCLUDES=${S}/projects/libcxx/include \ | 44 | -DLIBCXXABI_LIBCXX_INCLUDES=${S}/projects/libcxx/include \ |
45 | -DLIBCXX_CXX_ABI_INCLUDE_PATHS=${S}/projects/libcxxabi/include \ | 45 | -DLIBCXX_CXX_ABI_INCLUDE_PATHS=${S}/projects/libcxxabi/include \ |
46 | -DLIBCXX_CXX_ABI_LIBRARY_PATH=${B}/lib \ | 46 | -DLIBCXX_CXX_ABI_LIBRARY_PATH=${B}/lib \ |
47 | -DLIBCXXABI_USE_LLVM_UNWINDER=1 \ | ||
47 | -G Ninja \ | 48 | -G Ninja \ |
48 | ${S} \ | 49 | ${S} \ |
49 | " | 50 | " |
51 | EXTRA_OECMAKE_remove_mipsarch = "-DLIBCXXABI_USE_LLVM_UNWINDER=1" | ||
50 | 52 | ||
51 | EXTRA_OECMAKE_append_libc-musl = " -DLIBCXX_HAS_MUSL_LIBC=ON " | 53 | EXTRA_OECMAKE_append_libc-musl = " -DLIBCXX_HAS_MUSL_LIBC=ON " |
52 | 54 | ||
55 | |||
56 | |||
53 | do_compile() { | 57 | do_compile() { |
54 | NINJA_STATUS="[%p] " ninja -v ${PARALLEL_MAKE} cxxabi cxx | 58 | NINJA_STATUS="[%p] " ninja -v ${PARALLEL_MAKE} unwind cxxabi cxx |
55 | } | 59 | } |
56 | 60 | ||
57 | do_install() { | 61 | do_install() { |
58 | NINJA_STATUS="[%p] " DESTDIR=${D} ninja ${PARALLEL_MAKE} install-cxxabi install-cxx | 62 | NINJA_STATUS="[%p] " DESTDIR=${D} ninja ${PARALLEL_MAKE} projects/libunwind/install install-cxxabi install-cxx |
59 | } | 63 | } |
60 | 64 | ||
65 | PACKAGES =+ "libunwind" | ||
66 | |||
67 | FILES_libunwind += "${libdir}/libunwind.so.*" | ||
68 | |||
61 | ALLOW_EMPTY_${PN} = "1" | 69 | ALLOW_EMPTY_${PN} = "1" |
62 | 70 | ||
63 | BBCLASSEXTEND = "native nativesdk" | 71 | BBCLASSEXTEND = "native nativesdk" |
diff --git a/recipes-devtools/clang/llvm-libunwind_git.bb b/recipes-devtools/clang/llvm-libunwind_git.bb deleted file mode 100644 index cfbff35..0000000 --- a/recipes-devtools/clang/llvm-libunwind_git.bb +++ /dev/null | |||
@@ -1,70 +0,0 @@ | |||
1 | # Copyright (C) 2015 Khem Raj <raj.khem@gmail.com> | ||
2 | # Released under the MIT license (see COPYING.MIT for the terms) | ||
3 | |||
4 | DESCRIPTION = "libunwind implements a stack unwinder, needed to perform C++ exception handling." | ||
5 | HOMEPAGE = "http://llvm.org/" | ||
6 | LICENSE = "MIT | NCSA" | ||
7 | SECTION = "base" | ||
8 | |||
9 | require clang.inc | ||
10 | require common.inc | ||
11 | |||
12 | inherit cmake | ||
13 | PV .= "+git${SRCPV}" | ||
14 | |||
15 | DEPENDS += "libcxx ninja-native" | ||
16 | BASEDEPENDS_remove_toolchain-clang_class-target = "llvm-libunwind" | ||
17 | BASEDEPENDS_remove_toolchain-clang_class-target = "compiler-rt" | ||
18 | PROVIDES += "libunwind" | ||
19 | |||
20 | LIC_FILES_CHKSUM = "file://projects/libcxx/LICENSE.TXT;md5=7b3a0e1b99822669d630011defe9bfd9; \ | ||
21 | " | ||
22 | SRC_URI = "\ | ||
23 | ${LLVM_GIT}/llvm.git;protocol=${LLVM_GIT_PROTOCOL};branch=${BRANCH};name=llvm \ | ||
24 | ${LLVM_GIT}/libcxx.git;protocol=${LLVM_GIT_PROTOCOL};branch=${BRANCH};name=libcxx;destsuffix=git/projects/libcxx \ | ||
25 | ${LLVM_GIT}/libcxxabi.git;protocol=${LLVM_GIT_PROTOCOL};branch=${BRANCH};name=cxxabi;destsuffix=git/projects/libcxxabi \ | ||
26 | ${LLVM_GIT}/libunwind.git;protocol=${LLVM_GIT_PROTOCOL};branch=${BRANCH};name=libunwind;destsuffix=git/projects/libunwind \ | ||
27 | ${LLVMPATCHES} \ | ||
28 | ${LIBCXXPATCHES} \ | ||
29 | ${LIBCXXABIPATCHES} \ | ||
30 | " | ||
31 | |||
32 | SRCREV_FORMAT = "llvm_libcxx_cxxabi_libunwind" | ||
33 | |||
34 | S = "${WORKDIR}/git" | ||
35 | |||
36 | COMPATIBLE_HOST_mips = "null" | ||
37 | COMPATIBLE_HOST_mipsel = "null" | ||
38 | COMPATIBLE_HOST_mips64 = "null" | ||
39 | COMPATIBLE_HOST_mips64el = "null" | ||
40 | |||
41 | THUMB_TUNE_CCARGS = "" | ||
42 | #TUNE_CCARGS += "-nostdlib" | ||
43 | |||
44 | EXTRA_OECMAKE += "-DLIBCXXABI_LIBCXX_PATH=${S}/projects/libcxxabi \ | ||
45 | -DLLVM_PATH=${S} \ | ||
46 | -DLLVM_ENABLE_LIBCXX=True \ | ||
47 | -DLLVM_ENABLE_LIBCXXABI=True \ | ||
48 | -DLLVM_BUILD_EXTERNAL_COMPILER_RT=True \ | ||
49 | -DLIBUNWIND_ENABLE_SHARED=ON \ | ||
50 | -DUNIX=True \ | ||
51 | -G Ninja \ | ||
52 | ${S}/projects/libunwind \ | ||
53 | " | ||
54 | do_configure_prepend () { | ||
55 | (cd ${S}/projects/libunwind/include && ln -sf ../../libcxxabi/include/__cxxabi_config.h) | ||
56 | } | ||
57 | |||
58 | do_compile() { | ||
59 | NINJA_STATUS="[%p] " ninja ${PARALLEL_MAKE} | ||
60 | } | ||
61 | |||
62 | do_install() { | ||
63 | NINJA_STATUS="[%p] " DESTDIR=${D} ninja ${PARALLEL_MAKE} install | ||
64 | } | ||
65 | |||
66 | ALLOW_EMPTY_${PN} = "1" | ||
67 | |||
68 | RPROVIDES_${PN} = "libunwind" | ||
69 | |||
70 | BBCLASSEXTEND = "native nativesdk" | ||
diff --git a/recipes-devtools/clang/openmp_git.bb b/recipes-devtools/clang/openmp_git.bb index 8ca9f32..159a7de 100644 --- a/recipes-devtools/clang/openmp_git.bb +++ b/recipes-devtools/clang/openmp_git.bb | |||
@@ -24,7 +24,6 @@ SRCREV_FORMAT = "openmp" | |||
24 | 24 | ||
25 | BASEDEPENDS_remove_toolchain-clang_class-target = "compiler-rt" | 25 | BASEDEPENDS_remove_toolchain-clang_class-target = "compiler-rt" |
26 | BASEDEPENDS_remove_toolchain-clang_class-target = "libcxx" | 26 | BASEDEPENDS_remove_toolchain-clang_class-target = "libcxx" |
27 | BASEDEPENDS_remove_toolchain-clang_class-target = "llvm-libunwind" | ||
28 | 27 | ||
29 | S = "${WORKDIR}/git/runtime" | 28 | S = "${WORKDIR}/git/runtime" |
30 | 29 | ||