summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/clang/llvm-libunwind_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/clang/llvm-libunwind_git.bb')
-rw-r--r--recipes-devtools/clang/llvm-libunwind_git.bb70
1 files changed, 0 insertions, 70 deletions
diff --git a/recipes-devtools/clang/llvm-libunwind_git.bb b/recipes-devtools/clang/llvm-libunwind_git.bb
deleted file mode 100644
index cfbff35..0000000
--- a/recipes-devtools/clang/llvm-libunwind_git.bb
+++ /dev/null
@@ -1,70 +0,0 @@
1# Copyright (C) 2015 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4DESCRIPTION = "libunwind implements a stack unwinder, needed to perform C++ exception handling."
5HOMEPAGE = "http://llvm.org/"
6LICENSE = "MIT | NCSA"
7SECTION = "base"
8
9require clang.inc
10require common.inc
11
12inherit cmake
13PV .= "+git${SRCPV}"
14
15DEPENDS += "libcxx ninja-native"
16BASEDEPENDS_remove_toolchain-clang_class-target = "llvm-libunwind"
17BASEDEPENDS_remove_toolchain-clang_class-target = "compiler-rt"
18PROVIDES += "libunwind"
19
20LIC_FILES_CHKSUM = "file://projects/libcxx/LICENSE.TXT;md5=7b3a0e1b99822669d630011defe9bfd9; \
21"
22SRC_URI = "\
23 ${LLVM_GIT}/llvm.git;protocol=${LLVM_GIT_PROTOCOL};branch=${BRANCH};name=llvm \
24 ${LLVM_GIT}/libcxx.git;protocol=${LLVM_GIT_PROTOCOL};branch=${BRANCH};name=libcxx;destsuffix=git/projects/libcxx \
25 ${LLVM_GIT}/libcxxabi.git;protocol=${LLVM_GIT_PROTOCOL};branch=${BRANCH};name=cxxabi;destsuffix=git/projects/libcxxabi \
26 ${LLVM_GIT}/libunwind.git;protocol=${LLVM_GIT_PROTOCOL};branch=${BRANCH};name=libunwind;destsuffix=git/projects/libunwind \
27 ${LLVMPATCHES} \
28 ${LIBCXXPATCHES} \
29 ${LIBCXXABIPATCHES} \
30"
31
32SRCREV_FORMAT = "llvm_libcxx_cxxabi_libunwind"
33
34S = "${WORKDIR}/git"
35
36COMPATIBLE_HOST_mips = "null"
37COMPATIBLE_HOST_mipsel = "null"
38COMPATIBLE_HOST_mips64 = "null"
39COMPATIBLE_HOST_mips64el = "null"
40
41THUMB_TUNE_CCARGS = ""
42#TUNE_CCARGS += "-nostdlib"
43
44EXTRA_OECMAKE += "-DLIBCXXABI_LIBCXX_PATH=${S}/projects/libcxxabi \
45 -DLLVM_PATH=${S} \
46 -DLLVM_ENABLE_LIBCXX=True \
47 -DLLVM_ENABLE_LIBCXXABI=True \
48 -DLLVM_BUILD_EXTERNAL_COMPILER_RT=True \
49 -DLIBUNWIND_ENABLE_SHARED=ON \
50 -DUNIX=True \
51 -G Ninja \
52 ${S}/projects/libunwind \
53"
54do_configure_prepend () {
55 (cd ${S}/projects/libunwind/include && ln -sf ../../libcxxabi/include/__cxxabi_config.h)
56}
57
58do_compile() {
59 NINJA_STATUS="[%p] " ninja ${PARALLEL_MAKE}
60}
61
62do_install() {
63 NINJA_STATUS="[%p] " DESTDIR=${D} ninja ${PARALLEL_MAKE} install
64}
65
66ALLOW_EMPTY_${PN} = "1"
67
68RPROVIDES_${PN} = "libunwind"
69
70BBCLASSEXTEND = "native nativesdk"