summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/clang/lldb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/clang/lldb')
-rw-r--r--recipes-devtools/clang/lldb/0001-Include-limits.h-for-PATH_MAX-definition.patch8
-rw-r--r--recipes-devtools/clang/lldb/0002-lldb-Add-lxml2-to-linker-cmdline-of-xml-is-found.patch30
2 files changed, 18 insertions, 20 deletions
diff --git a/recipes-devtools/clang/lldb/0001-Include-limits.h-for-PATH_MAX-definition.patch b/recipes-devtools/clang/lldb/0001-Include-limits.h-for-PATH_MAX-definition.patch
index 3fabbfe..b4b835b 100644
--- a/recipes-devtools/clang/lldb/0001-Include-limits.h-for-PATH_MAX-definition.patch
+++ b/recipes-devtools/clang/lldb/0001-Include-limits.h-for-PATH_MAX-definition.patch
@@ -1,4 +1,4 @@
1From d630a82a405c44843bae28286a09ac5f9fa202bd Mon Sep 17 00:00:00 2001 1From d1b12ce65b563ed5eb0fdd6460d592d829fabc75 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Thu, 18 May 2017 23:12:34 -0700 3Date: Thu, 18 May 2017 23:12:34 -0700
4Subject: [PATCH 1/2] Include limits.h for PATH_MAX definition 4Subject: [PATCH 1/2] Include limits.h for PATH_MAX definition
@@ -11,10 +11,10 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
11 1 file changed, 1 insertion(+), 1 deletion(-) 11 1 file changed, 1 insertion(+), 1 deletion(-)
12 12
13diff --git a/source/Utility/FileSpec.cpp b/source/Utility/FileSpec.cpp 13diff --git a/source/Utility/FileSpec.cpp b/source/Utility/FileSpec.cpp
14index 72f86917b..965ac744f 100644 14index b6952f7e3..2cedf5d90 100644
15--- a/source/Utility/FileSpec.cpp 15--- a/source/Utility/FileSpec.cpp
16+++ b/source/Utility/FileSpec.cpp 16+++ b/source/Utility/FileSpec.cpp
17@@ -31,7 +31,7 @@ 17@@ -29,7 +29,7 @@
18 #include <assert.h> // for assert 18 #include <assert.h> // for assert
19 #include <stdio.h> // for size_t, NULL, snpr... 19 #include <stdio.h> // for size_t, NULL, snpr...
20 #include <string.h> // for strcmp 20 #include <string.h> // for strcmp
@@ -24,5 +24,5 @@ index 72f86917b..965ac744f 100644
24 using namespace lldb_private; 24 using namespace lldb_private;
25 25
26-- 26--
272.16.1 272.18.0
28 28
diff --git a/recipes-devtools/clang/lldb/0002-lldb-Add-lxml2-to-linker-cmdline-of-xml-is-found.patch b/recipes-devtools/clang/lldb/0002-lldb-Add-lxml2-to-linker-cmdline-of-xml-is-found.patch
index 1167b5a..42e75f2 100644
--- a/recipes-devtools/clang/lldb/0002-lldb-Add-lxml2-to-linker-cmdline-of-xml-is-found.patch
+++ b/recipes-devtools/clang/lldb/0002-lldb-Add-lxml2-to-linker-cmdline-of-xml-is-found.patch
@@ -1,4 +1,4 @@
1From 397a9e7dc35a7b360bb8466996ae7755574dc04c Mon Sep 17 00:00:00 2001 1From 479c943c3b87887d2b93c711220894e94d49979d Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Mon, 22 May 2017 17:36:16 -0700 3Date: Mon, 22 May 2017 17:36:16 -0700
4Subject: [PATCH 2/2] lldb: Add -lxml2 to linker cmdline of xml is found 4Subject: [PATCH 2/2] lldb: Add -lxml2 to linker cmdline of xml is found
@@ -19,24 +19,22 @@ Fixes
19 19
20Signed-off-by: Khem Raj <raj.khem@gmail.com> 20Signed-off-by: Khem Raj <raj.khem@gmail.com>
21--- 21---
22 source/Host/CMakeLists.txt | 4 ++++ 22 source/Host/CMakeLists.txt | 2 +-
23 1 file changed, 4 insertions(+) 23 1 file changed, 1 insertion(+), 1 deletion(-)
24 24
25diff --git a/source/Host/CMakeLists.txt b/source/Host/CMakeLists.txt 25diff --git a/source/Host/CMakeLists.txt b/source/Host/CMakeLists.txt
26index 2b6f0e48a..1a910a9af 100644 26index 5a92447ed..22ce6eee4 100644
27--- a/source/Host/CMakeLists.txt 27--- a/source/Host/CMakeLists.txt
28+++ b/source/Host/CMakeLists.txt 28+++ b/source/Host/CMakeLists.txt
29@@ -175,6 +175,10 @@ if (NOT LLDB_DISABLE_LIBEDIT) 29@@ -149,7 +149,7 @@ if (APPLE)
30 list(APPEND EXTRA_LIBS edit) 30 list(APPEND EXTRA_LIBS xml2)
31 endif() 31 else ()
32 32 if (LIBXML2_FOUND)
33+if (LIBXML2_FOUND) 33- list(APPEND EXTRA_LIBS ${LIBXML2_LIBRARIES})
34+ list(APPEND EXTRA_LIBS xml2) 34+ list(APPEND EXTRA_LIBS xml2)
35+endif () 35 endif()
36+ 36 endif ()
37 add_lldb_library(lldbHost 37 if (HAVE_LIBDL)
38 ${HOST_SOURCES}
39
40-- 38--
412.16.1 392.18.0
42 40