summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/clang/compiler-rt
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/clang/compiler-rt')
-rw-r--r--recipes-devtools/clang/compiler-rt/0001-support-a-new-embedded-linux-target.patch10
-rw-r--r--recipes-devtools/clang/compiler-rt/0002-Simplify-cross-compilation.-Don-t-use-native-compile.patch10
-rw-r--r--recipes-devtools/clang/compiler-rt/0003-Disable-tsan-on-OE-glibc.patch20
-rw-r--r--recipes-devtools/clang/compiler-rt/0004-cmake-mips-Do-not-specify-target-with-OE.patch10
-rw-r--r--recipes-devtools/clang/compiler-rt/0005-Pass-march-armv8.1-a-instead-of-mcrc.patch19
5 files changed, 35 insertions, 34 deletions
diff --git a/recipes-devtools/clang/compiler-rt/0001-support-a-new-embedded-linux-target.patch b/recipes-devtools/clang/compiler-rt/0001-support-a-new-embedded-linux-target.patch
index 45bd645..c844119 100644
--- a/recipes-devtools/clang/compiler-rt/0001-support-a-new-embedded-linux-target.patch
+++ b/recipes-devtools/clang/compiler-rt/0001-support-a-new-embedded-linux-target.patch
@@ -1,7 +1,7 @@
1From 489a11bdd48c04983e5d042808b91c9f9844d403 Mon Sep 17 00:00:00 2001 1From 1a82e4a75ef6bf24597e886446ca06aa063a0c7f Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Sun, 19 Apr 2015 15:16:23 -0700 3Date: Sun, 19 Apr 2015 15:16:23 -0700
4Subject: [PATCH 1/4] support a new embedded linux target 4Subject: [PATCH 1/5] support a new embedded linux target
5 5
6Signed-off-by: Khem Raj <raj.khem@gmail.com> 6Signed-off-by: Khem Raj <raj.khem@gmail.com>
7--- 7---
@@ -13,10 +13,10 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
13 create mode 100644 make/platform/clang_linux_embedded_test_input.c 13 create mode 100644 make/platform/clang_linux_embedded_test_input.c
14 14
15diff --git a/lib/builtins/int_util.c b/lib/builtins/int_util.c 15diff --git a/lib/builtins/int_util.c b/lib/builtins/int_util.c
16index 420d1e237..0e4614100 100644 16index de87410db..0d5b56fe1 100644
17--- a/lib/builtins/int_util.c 17--- a/lib/builtins/int_util.c
18+++ b/lib/builtins/int_util.c 18+++ b/lib/builtins/int_util.c
19@@ -48,8 +48,7 @@ void compilerrt_abort_impl(const char *file, int line, const char *function) { 19@@ -58,8 +58,7 @@ void compilerrt_abort_impl(const char *file, int line, const char *function) {
20 #else 20 #else
21 21
22 /* Get the system definition of abort() */ 22 /* Get the system definition of abort() */
@@ -322,5 +322,5 @@ diff --git a/make/platform/clang_linux_embedded_test_input.c b/make/platform/cla
322new file mode 100644 322new file mode 100644
323index 000000000..e69de29bb 323index 000000000..e69de29bb
324-- 324--
3252.13.0 3252.16.1
326 326
diff --git a/recipes-devtools/clang/compiler-rt/0002-Simplify-cross-compilation.-Don-t-use-native-compile.patch b/recipes-devtools/clang/compiler-rt/0002-Simplify-cross-compilation.-Don-t-use-native-compile.patch
index 1a63a9b..ecb3fe7 100644
--- a/recipes-devtools/clang/compiler-rt/0002-Simplify-cross-compilation.-Don-t-use-native-compile.patch
+++ b/recipes-devtools/clang/compiler-rt/0002-Simplify-cross-compilation.-Don-t-use-native-compile.patch
@@ -1,7 +1,7 @@
1From 521311b98ffb4e912a6d863f134856d365eb9d36 Mon Sep 17 00:00:00 2001 1From 6bfcd697851219f35688299c32e7068fad50c6f5 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Thu, 19 May 2016 23:11:45 -0700 3Date: Thu, 19 May 2016 23:11:45 -0700
4Subject: [PATCH 2/4] Simplify cross-compilation. Don't use native-compiled 4Subject: [PATCH 2/5] Simplify cross-compilation. Don't use native-compiled
5 llvm-config. 5 llvm-config.
6 6
7 Note: AddLLVM.cmake does not expose the LLVM source directory. 7 Note: AddLLVM.cmake does not expose the LLVM source directory.
@@ -20,10 +20,10 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
20 1 file changed, 9 insertions(+), 1 deletion(-) 20 1 file changed, 9 insertions(+), 1 deletion(-)
21 21
22diff --git a/CMakeLists.txt b/CMakeLists.txt 22diff --git a/CMakeLists.txt b/CMakeLists.txt
23index b522c340d..7f2e49d17 100644 23index 4b953b212..571aee7ea 100644
24--- a/CMakeLists.txt 24--- a/CMakeLists.txt
25+++ b/CMakeLists.txt 25+++ b/CMakeLists.txt
26@@ -35,7 +35,15 @@ set(COMPILER_RT_BAREMETAL_BUILD OFF CACHE BOOLEAN 26@@ -62,7 +62,15 @@ set(COMPILER_RT_BAREMETAL_BUILD OFF CACHE BOOLEAN
27 "Build for a bare-metal target.") 27 "Build for a bare-metal target.")
28 28
29 if (COMPILER_RT_STANDALONE_BUILD) 29 if (COMPILER_RT_STANDALONE_BUILD)
@@ -41,5 +41,5 @@ index b522c340d..7f2e49d17 100644
41 # Find Python interpreter. 41 # Find Python interpreter.
42 set(Python_ADDITIONAL_VERSIONS 2.7 2.6 2.5) 42 set(Python_ADDITIONAL_VERSIONS 2.7 2.6 2.5)
43-- 43--
442.13.0 442.16.1
45 45
diff --git a/recipes-devtools/clang/compiler-rt/0003-Disable-tsan-on-OE-glibc.patch b/recipes-devtools/clang/compiler-rt/0003-Disable-tsan-on-OE-glibc.patch
index dc2a999..e6c5f9e 100644
--- a/recipes-devtools/clang/compiler-rt/0003-Disable-tsan-on-OE-glibc.patch
+++ b/recipes-devtools/clang/compiler-rt/0003-Disable-tsan-on-OE-glibc.patch
@@ -1,7 +1,7 @@
1From 9390b3a6552d8f122e186797416904066df418be Mon Sep 17 00:00:00 2001 1From 2e8c6df7fe6e120063c3bdb87fb95e1326cf8434 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Mon, 18 Jul 2016 08:05:02 +0000 3Date: Mon, 18 Jul 2016 08:05:02 +0000
4Subject: [PATCH 3/4] Disable tsan on OE/glibc 4Subject: [PATCH 3/5] Disable tsan on OE/glibc
5 5
6It does not build see 6It does not build see
7http://lists.llvm.org/pipermail/llvm-dev/2016-July/102235.html 7http://lists.llvm.org/pipermail/llvm-dev/2016-July/102235.html
@@ -13,30 +13,30 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
13 2 files changed, 1 insertion(+), 2 deletions(-) 13 2 files changed, 1 insertion(+), 2 deletions(-)
14 14
15diff --git a/cmake/config-ix.cmake b/cmake/config-ix.cmake 15diff --git a/cmake/config-ix.cmake b/cmake/config-ix.cmake
16index ae2a262a1..edc6dc63e 100644 16index 9e0c47748..227d661ae 100644
17--- a/cmake/config-ix.cmake 17--- a/cmake/config-ix.cmake
18+++ b/cmake/config-ix.cmake 18+++ b/cmake/config-ix.cmake
19@@ -497,7 +497,7 @@ else() 19@@ -549,7 +549,7 @@ else()
20 endif() 20 endif()
21 21
22 if (COMPILER_RT_HAS_SANITIZER_COMMON AND TSAN_SUPPORTED_ARCH AND 22 if (COMPILER_RT_HAS_SANITIZER_COMMON AND TSAN_SUPPORTED_ARCH AND
23- OS_NAME MATCHES "Darwin|Linux|FreeBSD|Android") 23- OS_NAME MATCHES "Darwin|Linux|FreeBSD|Android|NetBSD")
24+ OS_NAME MATCHES "Darwin|FreeBSD|Android") 24+ OS_NAME MATCHES "Darwin|FreeBSD|Android|NetBSD")
25 set(COMPILER_RT_HAS_TSAN TRUE) 25 set(COMPILER_RT_HAS_TSAN TRUE)
26 else() 26 else()
27 set(COMPILER_RT_HAS_TSAN FALSE) 27 set(COMPILER_RT_HAS_TSAN FALSE)
28diff --git a/test/sanitizer_common/CMakeLists.txt b/test/sanitizer_common/CMakeLists.txt 28diff --git a/test/sanitizer_common/CMakeLists.txt b/test/sanitizer_common/CMakeLists.txt
29index 9b4070b0f..e76f2680c 100644 29index 8b210a08a..50b6f7166 100644
30--- a/test/sanitizer_common/CMakeLists.txt 30--- a/test/sanitizer_common/CMakeLists.txt
31+++ b/test/sanitizer_common/CMakeLists.txt 31+++ b/test/sanitizer_common/CMakeLists.txt
32@@ -8,7 +8,6 @@ if(CMAKE_SYSTEM_NAME MATCHES "Darwin|Linux|FreeBSD" AND NOT ANDROID) 32@@ -8,7 +8,6 @@ if(CMAKE_SYSTEM_NAME MATCHES "Darwin|Linux|FreeBSD|NetBSD")
33 list(APPEND SUPPORTED_TOOLS asan) 33 list(APPEND SUPPORTED_TOOLS asan)
34 endif() 34 endif()
35 if(CMAKE_SYSTEM_NAME MATCHES "Linux" AND NOT ANDROID) 35 if(CMAKE_SYSTEM_NAME MATCHES "Linux" AND NOT ANDROID)
36- list(APPEND SUPPORTED_TOOLS tsan) 36- list(APPEND SUPPORTED_TOOLS tsan)
37 list(APPEND SUPPORTED_TOOLS msan) 37 list(APPEND SUPPORTED_TOOLS msan)
38 list(APPEND SUPPORTED_TOOLS lsan) 38 list(APPEND SUPPORTED_TOOLS lsan)
39 endif() 39 list(APPEND SUPPORTED_TOOLS ubsan)
40-- 40--
412.13.0 412.16.1
42 42
diff --git a/recipes-devtools/clang/compiler-rt/0004-cmake-mips-Do-not-specify-target-with-OE.patch b/recipes-devtools/clang/compiler-rt/0004-cmake-mips-Do-not-specify-target-with-OE.patch
index 0b2e14d..31daad0 100644
--- a/recipes-devtools/clang/compiler-rt/0004-cmake-mips-Do-not-specify-target-with-OE.patch
+++ b/recipes-devtools/clang/compiler-rt/0004-cmake-mips-Do-not-specify-target-with-OE.patch
@@ -1,7 +1,7 @@
1From 0be126894e872108eaa7eae3629a5564598ee25e Mon Sep 17 00:00:00 2001 1From 39e3271f270f75a4d65128f79be1dd3e455f5c85 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 11 Feb 2017 17:54:33 +0000 3Date: Sat, 11 Feb 2017 17:54:33 +0000
4Subject: [PATCH 4/4] cmake/mips: Do not specify --target with OE 4Subject: [PATCH 4/5] cmake/mips: Do not specify --target with OE
5 5
6OE already specifies cross compiler correctly, adding this additional 6OE already specifies cross compiler correctly, adding this additional
7--target confuses the clang driver and it resorts to invoke host assembler 7--target confuses the clang driver and it resorts to invoke host assembler
@@ -20,10 +20,10 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
20 1 file changed, 4 insertions(+), 4 deletions(-) 20 1 file changed, 4 insertions(+), 4 deletions(-)
21 21
22diff --git a/cmake/base-config-ix.cmake b/cmake/base-config-ix.cmake 22diff --git a/cmake/base-config-ix.cmake b/cmake/base-config-ix.cmake
23index 6f9f15139..7002a60ac 100644 23index b208f0852..2555b5e5b 100644
24--- a/cmake/base-config-ix.cmake 24--- a/cmake/base-config-ix.cmake
25+++ b/cmake/base-config-ix.cmake 25+++ b/cmake/base-config-ix.cmake
26@@ -161,11 +161,11 @@ macro(test_targets) 26@@ -169,11 +169,11 @@ macro(test_targets)
27 # clang's default CPU's. In the 64-bit case, we must also specify the ABI 27 # clang's default CPU's. In the 64-bit case, we must also specify the ABI
28 # since the default ABI differs between gcc and clang. 28 # since the default ABI differs between gcc and clang.
29 # FIXME: Ideally, we would build the N32 library too. 29 # FIXME: Ideally, we would build the N32 library too.
@@ -40,5 +40,5 @@ index 6f9f15139..7002a60ac 100644
40 if(WIN32) 40 if(WIN32)
41 test_target_arch(arm "" "" "") 41 test_target_arch(arm "" "" "")
42-- 42--
432.13.0 432.16.1
44 44
diff --git a/recipes-devtools/clang/compiler-rt/0005-Pass-march-armv8.1-a-instead-of-mcrc.patch b/recipes-devtools/clang/compiler-rt/0005-Pass-march-armv8.1-a-instead-of-mcrc.patch
index e6628f5..b2e8e25 100644
--- a/recipes-devtools/clang/compiler-rt/0005-Pass-march-armv8.1-a-instead-of-mcrc.patch
+++ b/recipes-devtools/clang/compiler-rt/0005-Pass-march-armv8.1-a-instead-of-mcrc.patch
@@ -1,4 +1,4 @@
1From ce33b77707e708348311aea2a9b2401ed4685aa2 Mon Sep 17 00:00:00 2001 1From ef9b0bacf7a2fd097c241da674ed726c3dfb11d2 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Thu, 20 Jul 2017 12:14:03 -0700 3Date: Thu, 20 Jul 2017 12:14:03 -0700
4Subject: [PATCH 5/5] Pass -march=armv8.1-a instead of -mcrc 4Subject: [PATCH 5/5] Pass -march=armv8.1-a instead of -mcrc
@@ -20,18 +20,19 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
20 lib/scudo/CMakeLists.txt | 2 +- 20 lib/scudo/CMakeLists.txt | 2 +-
21 1 file changed, 1 insertion(+), 1 deletion(-) 21 1 file changed, 1 insertion(+), 1 deletion(-)
22 22
23Index: git/lib/scudo/CMakeLists.txt 23diff --git a/lib/scudo/CMakeLists.txt b/lib/scudo/CMakeLists.txt
24=================================================================== 24index 4d26a3477..965174727 100644
25--- git.orig/lib/scudo/CMakeLists.txt 25--- a/lib/scudo/CMakeLists.txt
26+++ git/lib/scudo/CMakeLists.txt 26+++ b/lib/scudo/CMakeLists.txt
27@@ -26,7 +26,9 @@ endif() 27@@ -28,7 +28,7 @@ endif()
28 # Enable the AArch64 CRC32 feature for scudo_crc32.cpp, if available. 28 # Enable the AArch64 CRC32 feature for scudo_crc32.cpp, if available.
29 # Note that it is enabled by default starting with armv8.1-a. 29 # Note that it is enabled by default starting with armv8.1-a.
30 if (COMPILER_RT_HAS_MCRC_FLAG) 30 if (COMPILER_RT_HAS_MCRC_FLAG)
31- set_source_files_properties(scudo_crc32.cpp PROPERTIES COMPILE_FLAGS -mcrc) 31- set_source_files_properties(scudo_crc32.cpp PROPERTIES COMPILE_FLAGS -mcrc)
32+ if ("${COMPILER_RT_DEFAULT_TARGET_ARCH}" MATCHES "aarch64") 32+ set_source_files_properties(scudo_crc32.cpp PROPERTIES COMPILE_FLAGS -march=armv8.1-a)
33+ set_source_files_properties(scudo_crc32.cpp PROPERTIES COMPILE_FLAGS -march=armv8.1-a)
34+ endif()
35 endif() 33 endif()
36 34
37 if(COMPILER_RT_HAS_SCUDO) 35 if(COMPILER_RT_HAS_SCUDO)
36--
372.16.1
38