summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/clang/compiler-rt/0005-Pass-march-armv8.1-a-instead-of-mcrc.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/clang/compiler-rt/0005-Pass-march-armv8.1-a-instead-of-mcrc.patch')
-rw-r--r--recipes-devtools/clang/compiler-rt/0005-Pass-march-armv8.1-a-instead-of-mcrc.patch38
1 files changed, 0 insertions, 38 deletions
diff --git a/recipes-devtools/clang/compiler-rt/0005-Pass-march-armv8.1-a-instead-of-mcrc.patch b/recipes-devtools/clang/compiler-rt/0005-Pass-march-armv8.1-a-instead-of-mcrc.patch
deleted file mode 100644
index b2e8e25..0000000
--- a/recipes-devtools/clang/compiler-rt/0005-Pass-march-armv8.1-a-instead-of-mcrc.patch
+++ /dev/null
@@ -1,38 +0,0 @@
1From ef9b0bacf7a2fd097c241da674ed726c3dfb11d2 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Thu, 20 Jul 2017 12:14:03 -0700
4Subject: [PATCH 5/5] Pass -march=armv8.1-a instead of -mcrc
5
6When we pass -mcrc it does not cause driver to
7pass right options to assembler, especially when
8using GNU assembler, is used this causes assembler
9failures to recognise crc instructions since the
10default -march option passed it armv8-a
11
12/tmp/scudo_crc32-9e9612.s:14: Error: selected processor does not support `crc32cx w0,w0,x1'
13
14Adding -march=armv8.1-a forces the driver to pass
15-march=armv8.1-a to assembler as well, which fixes
16this issue
17
18Signed-off-by: Khem Raj <raj.khem@gmail.com>
19---
20 lib/scudo/CMakeLists.txt | 2 +-
21 1 file changed, 1 insertion(+), 1 deletion(-)
22
23diff --git a/lib/scudo/CMakeLists.txt b/lib/scudo/CMakeLists.txt
24index 4d26a3477..965174727 100644
25--- a/lib/scudo/CMakeLists.txt
26+++ b/lib/scudo/CMakeLists.txt
27@@ -28,7 +28,7 @@ endif()
28 # Enable the AArch64 CRC32 feature for scudo_crc32.cpp, if available.
29 # Note that it is enabled by default starting with armv8.1-a.
30 if (COMPILER_RT_HAS_MCRC_FLAG)
31- set_source_files_properties(scudo_crc32.cpp PROPERTIES COMPILE_FLAGS -mcrc)
32+ set_source_files_properties(scudo_crc32.cpp PROPERTIES COMPILE_FLAGS -march=armv8.1-a)
33 endif()
34
35 if(COMPILER_RT_HAS_SCUDO)
36--
372.16.1
38