summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/clang/clang/0029-OpenMP-link-fix.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/clang/clang/0029-OpenMP-link-fix.patch')
-rw-r--r--recipes-devtools/clang/clang/0029-OpenMP-link-fix.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes-devtools/clang/clang/0029-OpenMP-link-fix.patch b/recipes-devtools/clang/clang/0029-OpenMP-link-fix.patch
new file mode 100644
index 0000000..3901268
--- /dev/null
+++ b/recipes-devtools/clang/clang/0029-OpenMP-link-fix.patch
@@ -0,0 +1,26 @@
1From 11bd98436bd7e99fb1fc2c07c150c71e2250a262 Mon Sep 17 00:00:00 2001
2From: Joel Winarske <joel.winarske@gmail.com>
3Date: Wed, 9 Feb 2022 11:11:55 -0800
4Subject: [PATCH] OpenMP link fix
5
6Signed-off-by: Joel Winarske <joel.winarske@gmail.com>
7---
8 openmp/runtime/src/CMakeLists.txt | 2 +-
9 1 file changed, 1 insertion(+), 1 deletion(-)
10
11diff --git a/openmp/runtime/src/CMakeLists.txt b/openmp/runtime/src/CMakeLists.txt
12index 9f46b4bd4..3106e497d 100644
13--- a/openmp/runtime/src/CMakeLists.txt
14+++ b/openmp/runtime/src/CMakeLists.txt
15@@ -168,7 +168,7 @@ endif()
16
17 # Linking command will include libraries in LIBOMP_CONFIGURED_LIBFLAGS
18 libomp_get_libflags(LIBOMP_CONFIGURED_LIBFLAGS)
19-target_link_libraries(omp ${LIBOMP_CONFIGURED_LIBFLAGS} ${CMAKE_DL_LIBS})
20+target_link_libraries(omp ${LIBOMP_CONFIGURED_LIBFLAGS} ${CMAKE_DL_LIBS} "-Wl,--version-script=${CMAKE_CURRENT_SOURCE_DIR}/exports_so.txt")
21
22 # Create *.inc before compiling any sources
23 # objects depend on : .inc files
24--
252.31.1
26