summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/clang/clang/0018-compiler-rt-Disable-tsan-on-OE-glibc.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/clang/clang/0018-compiler-rt-Disable-tsan-on-OE-glibc.patch')
-rw-r--r--recipes-devtools/clang/clang/0018-compiler-rt-Disable-tsan-on-OE-glibc.patch42
1 files changed, 42 insertions, 0 deletions
diff --git a/recipes-devtools/clang/clang/0018-compiler-rt-Disable-tsan-on-OE-glibc.patch b/recipes-devtools/clang/clang/0018-compiler-rt-Disable-tsan-on-OE-glibc.patch
new file mode 100644
index 0000000..4c64d04
--- /dev/null
+++ b/recipes-devtools/clang/clang/0018-compiler-rt-Disable-tsan-on-OE-glibc.patch
@@ -0,0 +1,42 @@
1From 4a9f02d94f311a866b663d5ff163bbea8fde490e Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Mon, 18 Jul 2016 08:05:02 +0000
4Subject: [PATCH 18/18] compiler-rt: Disable tsan on OE/glibc
5
6It does not build see
7http://lists.llvm.org/pipermail/llvm-dev/2016-July/102235.html
8
9Signed-off-by: Khem Raj <raj.khem@gmail.com>
10---
11 compiler-rt/cmake/config-ix.cmake | 2 +-
12 compiler-rt/test/sanitizer_common/CMakeLists.txt | 1 -
13 2 files changed, 1 insertion(+), 2 deletions(-)
14
15diff --git a/compiler-rt/cmake/config-ix.cmake b/compiler-rt/cmake/config-ix.cmake
16index 5b943387717..151b6069e16 100644
17--- a/compiler-rt/cmake/config-ix.cmake
18+++ b/compiler-rt/cmake/config-ix.cmake
19@@ -594,7 +594,7 @@ else()
20 endif()
21
22 if (COMPILER_RT_HAS_SANITIZER_COMMON AND TSAN_SUPPORTED_ARCH AND
23- OS_NAME MATCHES "Darwin|Linux|FreeBSD|Android|NetBSD")
24+ OS_NAME MATCHES "Darwin|FreeBSD|Android|NetBSD")
25 set(COMPILER_RT_HAS_TSAN TRUE)
26 else()
27 set(COMPILER_RT_HAS_TSAN FALSE)
28diff --git a/compiler-rt/test/sanitizer_common/CMakeLists.txt b/compiler-rt/test/sanitizer_common/CMakeLists.txt
29index 23292e54820..cae7e010885 100644
30--- a/compiler-rt/test/sanitizer_common/CMakeLists.txt
31+++ b/compiler-rt/test/sanitizer_common/CMakeLists.txt
32@@ -8,7 +8,6 @@ if(CMAKE_SYSTEM_NAME MATCHES "Darwin|Linux|FreeBSD|NetBSD|SunOS")
33 list(APPEND SUPPORTED_TOOLS asan)
34 endif()
35 if(CMAKE_SYSTEM_NAME MATCHES "NetBSD" OR (CMAKE_SYSTEM_NAME MATCHES "Linux" AND NOT ANDROID))
36- list(APPEND SUPPORTED_TOOLS tsan)
37 list(APPEND SUPPORTED_TOOLS msan)
38 list(APPEND SUPPORTED_TOOLS ubsan)
39 endif()
40--
412.20.1
42