summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/clang/clang/0012-libcxxabi-Find-libunwind-headers-when-LIBCXXABI_LIBU.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/clang/clang/0012-libcxxabi-Find-libunwind-headers-when-LIBCXXABI_LIBU.patch')
-rw-r--r--recipes-devtools/clang/clang/0012-libcxxabi-Find-libunwind-headers-when-LIBCXXABI_LIBU.patch68
1 files changed, 68 insertions, 0 deletions
diff --git a/recipes-devtools/clang/clang/0012-libcxxabi-Find-libunwind-headers-when-LIBCXXABI_LIBU.patch b/recipes-devtools/clang/clang/0012-libcxxabi-Find-libunwind-headers-when-LIBCXXABI_LIBU.patch
new file mode 100644
index 0000000..92fe682
--- /dev/null
+++ b/recipes-devtools/clang/clang/0012-libcxxabi-Find-libunwind-headers-when-LIBCXXABI_LIBU.patch
@@ -0,0 +1,68 @@
1From 058935ad2f27735cedf838b82a8a2d7d1883ab5f Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sun, 27 Aug 2017 10:37:49 -0700
4Subject: [PATCH 12/15] libcxxabi: Find libunwind headers when
5 LIBCXXABI_LIBUNWIND_INCLUDES is set
6
7Currently, when LIBCXXABI_LIBUNWIND_INCLUDES is set via CMake arguments
8then it ends up not searching the specified dir and unwind.h is not found
9especially for ARM targets
10
11This patch makes the searching synthesized directories and then set
12LIBCXXABI_LIBUNWIND_INCLUDES if its there in environment
13
14Signed-off-by: Khem Raj <raj.khem@gmail.com>
15---
16 libcxxabi/CMakeLists.txt | 21 +++++++++++----------
17 1 file changed, 11 insertions(+), 10 deletions(-)
18
19diff --git a/libcxxabi/CMakeLists.txt b/libcxxabi/CMakeLists.txt
20index 92c7dc5dc55..d67bb43aba3 100644
21--- a/libcxxabi/CMakeLists.txt
22+++ b/libcxxabi/CMakeLists.txt
23@@ -434,15 +434,10 @@ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} ${LIBCXXABI_C_FLAGS}")
24 # Setup Source Code
25 #===============================================================================
26
27-set(LIBCXXABI_LIBUNWIND_INCLUDES "${LIBCXXABI_LIBUNWIND_INCLUDES}" CACHE PATH
28- "Specify path to libunwind includes." FORCE)
29-set(LIBCXXABI_LIBUNWIND_PATH "${LIBCXXABI_LIBUNWIND_PATH}" CACHE PATH
30- "Specify path to libunwind source." FORCE)
31-
32 include_directories(include)
33 if (LIBCXXABI_USE_LLVM_UNWINDER OR LLVM_NATIVE_ARCH MATCHES ARM)
34 find_path(
35- LIBCXXABI_LIBUNWIND_INCLUDES_INTERNAL
36+ LIBCXXABI_LIBUNWIND_INCLUDES
37 libunwind.h
38 PATHS ${LIBCXXABI_LIBUNWIND_INCLUDES}
39 ${LIBCXXABI_LIBUNWIND_PATH}/include
40@@ -454,15 +449,21 @@ if (LIBCXXABI_USE_LLVM_UNWINDER OR LLVM_NATIVE_ARCH MATCHES ARM)
41 NO_CMAKE_FIND_ROOT_PATH
42 )
43
44- if (LIBCXXABI_LIBUNWIND_INCLUDES_INTERNAL STREQUAL "LIBCXXABI_LIBUNWIND_INCLUDES_INTERNAL-NOTFOUND")
45- set(LIBCXXABI_LIBUNWIND_INCLUDES_INTERNAL "")
46+ if (LIBCXXABI_LIBUNWIND_INCLUDES STREQUAL "LIBCXXABI_LIBUNWIND_INCLUDES-NOTFOUND")
47+ set(LIBCXXABI_LIBUNWIND_INCLUDES "")
48 endif()
49
50- if (NOT LIBCXXABI_LIBUNWIND_INCLUDES_INTERNAL STREQUAL "")
51- include_directories("${LIBCXXABI_LIBUNWIND_INCLUDES_INTERNAL}")
52+ if (NOT LIBCXXABI_LIBUNWIND_INCLUDES STREQUAL "")
53+ include_directories("${LIBCXXABI_LIBUNWIND_INCLUDES}")
54 endif()
55 endif()
56
57+set(LIBCXXABI_LIBUNWIND_INCLUDES "${LIBCXXABI_LIBUNWIND_INCLUDES}" CACHE PATH
58+ "Specify path to libunwind includes." FORCE)
59+set(LIBCXXABI_LIBUNWIND_PATH "${LIBCXXABI_LIBUNWIND_PATH}" CACHE PATH
60+ "Specify path to libunwind source." FORCE)
61+
62+
63 # Add source code. This also contains all of the logic for deciding linker flags
64 # soname, etc...
65 add_subdirectory(src)
66--
672.20.1
68