summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/clang/clang/0005-compiler-rt-Disable-tsan-on-OE-glibc.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/clang/clang/0005-compiler-rt-Disable-tsan-on-OE-glibc.patch')
-rw-r--r--recipes-devtools/clang/clang/0005-compiler-rt-Disable-tsan-on-OE-glibc.patch40
1 files changed, 0 insertions, 40 deletions
diff --git a/recipes-devtools/clang/clang/0005-compiler-rt-Disable-tsan-on-OE-glibc.patch b/recipes-devtools/clang/clang/0005-compiler-rt-Disable-tsan-on-OE-glibc.patch
deleted file mode 100644
index 59d774c..0000000
--- a/recipes-devtools/clang/clang/0005-compiler-rt-Disable-tsan-on-OE-glibc.patch
+++ /dev/null
@@ -1,40 +0,0 @@
1From 7730422bbca50431386391ed341c5d5ed649d14e Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Mon, 18 Jul 2016 08:05:02 +0000
4Subject: [PATCH] compiler-rt: Disable tsan on OE/glibc
5
6It does not build see
7http://lists.llvm.org/pipermail/llvm-dev/2016-July/102235.html
8
9Signed-off-by: Khem Raj <raj.khem@gmail.com>
10---
11 compiler-rt/cmake/config-ix.cmake | 2 +-
12 compiler-rt/test/sanitizer_common/CMakeLists.txt | 2 +-
13 2 files changed, 2 insertions(+), 2 deletions(-)
14
15diff --git a/compiler-rt/cmake/config-ix.cmake b/compiler-rt/cmake/config-ix.cmake
16index 3aad08e8896..a979d38c7a6 100644
17--- a/compiler-rt/cmake/config-ix.cmake
18+++ b/compiler-rt/cmake/config-ix.cmake
19@@ -653,7 +653,7 @@ else()
20 endif()
21
22 if (COMPILER_RT_HAS_SANITIZER_COMMON AND TSAN_SUPPORTED_ARCH AND
23- OS_NAME MATCHES "Darwin|Linux|FreeBSD|Android|NetBSD")
24+ OS_NAME MATCHES "Darwin|FreeBSD|Android|NetBSD")
25 set(COMPILER_RT_HAS_TSAN TRUE)
26 else()
27 set(COMPILER_RT_HAS_TSAN FALSE)
28diff --git a/compiler-rt/test/sanitizer_common/CMakeLists.txt b/compiler-rt/test/sanitizer_common/CMakeLists.txt
29index fcd651ebe42..821de915be8 100644
30--- a/compiler-rt/test/sanitizer_common/CMakeLists.txt
31+++ b/compiler-rt/test/sanitizer_common/CMakeLists.txt
32@@ -11,7 +11,7 @@ set(SANITIZER_COMMON_TESTSUITES)
33 # FIXME(dliew): We should switch to COMPILER_RT_SANITIZERS_TO_BUILD instead of
34 # the hard coded `SUPPORTED_TOOLS_INIT` list once we know that the other
35 # sanitizers work.
36-set(SUPPORTED_TOOLS_INIT asan lsan msan tsan ubsan)
37+set(SUPPORTED_TOOLS_INIT asan lsan msan ubsan)
38 set(SUPPORTED_TOOLS)
39 foreach(SANITIZER_TOOL ${SUPPORTED_TOOLS_INIT})
40 string(TOUPPER ${SANITIZER_TOOL} SANITIZER_TOOL_UPPER)