summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.20.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.20.0.bb')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.20.0.bb14
1 files changed, 7 insertions, 7 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.20.0.bb b/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.20.0.bb
index 325a6ee..43e828b 100644
--- a/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.20.0.bb
+++ b/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.20.0.bb
@@ -13,10 +13,10 @@ DEPENDS += "bison-native \
13 " 13 "
14 14
15LUAJIT ?= "luajit" 15LUAJIT ?= "luajit"
16LUAJIT_powerpc64le = "" 16LUAJIT:powerpc64le = ""
17LUAJIT_powerpc64 = "" 17LUAJIT:powerpc64 = ""
18 18
19RDEPENDS_${PN} += "bash python3 python3-core python3-setuptools xz" 19RDEPENDS:${PN} += "bash python3 python3-core python3-setuptools xz"
20 20
21SRC_URI = "gitsm://github.com/iovisor/bcc \ 21SRC_URI = "gitsm://github.com/iovisor/bcc \
22 file://0001-python-CMakeLists.txt-Remove-check-for-host-etc-debi.patch \ 22 file://0001-python-CMakeLists.txt-Remove-check-for-host-etc-debi.patch \
@@ -32,7 +32,7 @@ PV .= "+git${SRCPV}"
32S = "${WORKDIR}/git" 32S = "${WORKDIR}/git"
33 33
34PACKAGECONFIG ??= "examples" 34PACKAGECONFIG ??= "examples"
35PACKAGECONFIG_remove_libc-musl = "examples" 35PACKAGECONFIG:remove:libc-musl = "examples"
36 36
37PACKAGECONFIG[manpages] = "-DENABLE_MAN=ON,-DENABLE_MAN=OFF," 37PACKAGECONFIG[manpages] = "-DENABLE_MAN=ON,-DENABLE_MAN=OFF,"
38PACKAGECONFIG[examples] = "-DENABLE_EXAMPLES=ON,-DENABLE_EXAMPLES=OFF," 38PACKAGECONFIG[examples] = "-DENABLE_EXAMPLES=ON,-DENABLE_EXAMPLES=OFF,"
@@ -45,12 +45,12 @@ EXTRA_OECMAKE = " \
45 -DPYTHON_FLAGS=--install-lib=${PYTHON_SITEPACKAGES_DIR} \ 45 -DPYTHON_FLAGS=--install-lib=${PYTHON_SITEPACKAGES_DIR} \
46" 46"
47 47
48do_install_append() { 48do_install:append() {
49 sed -e 's@#!/usr/bin/python@#!/usr/bin/env python3@g' \ 49 sed -e 's@#!/usr/bin/python@#!/usr/bin/env python3@g' \
50 -i $(find ${D}${datadir}/${PN} -type f) 50 -i $(find ${D}${datadir}/${PN} -type f)
51} 51}
52 52
53FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}" 53FILES:${PN} += "${PYTHON_SITEPACKAGES_DIR}"
54FILES_${PN}-doc += "${datadir}/${PN}/man" 54FILES:${PN}-doc += "${datadir}/${PN}/man"
55 55
56COMPATIBLE_HOST = "(x86_64.*|aarch64.*|powerpc64.*)-linux" 56COMPATIBLE_HOST = "(x86_64.*|aarch64.*|powerpc64.*)-linux"