summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--README.md2
-rw-r--r--classes/.clang.bbclass.swpbin0 -> 12288 bytes
-rw-r--r--conf/clang.conf6
-rw-r--r--recipes-devtools/clang/clang-cross_git.bb2
4 files changed, 6 insertions, 4 deletions
diff --git a/README.md b/README.md
index 3d6ac6b..51a18e8 100644
--- a/README.md
+++ b/README.md
@@ -41,7 +41,7 @@ $ runqemu qemuarm
41Currently only few components are building with clang if you want to port/add more then please add 41Currently only few components are building with clang if you want to port/add more then please add
42```shell 42```shell
43TOOLCHAIN_pn-<recipe-name> = "clang" 43TOOLCHAIN_pn-<recipe-name> = "clang"
44DEPENDS_append_pn-<recipe-name> = " clang-cross " 44DEPENDS_append_pn-<recipe-name> = " clang-cross-${TARGET_ARCH} "
45``` 45```
46 46
47to clang.conf 47to clang.conf
diff --git a/classes/.clang.bbclass.swp b/classes/.clang.bbclass.swp
new file mode 100644
index 0000000..bf5e5f7
--- /dev/null
+++ b/classes/.clang.bbclass.swp
Binary files differ
diff --git a/conf/clang.conf b/conf/clang.conf
index ba17970..b4a616f 100644
--- a/conf/clang.conf
+++ b/conf/clang.conf
@@ -6,10 +6,10 @@ CPP_toolchain-clang = "${TARGET_PREFIX}clang ${TOOLCHAIN_OPTIONS} -E"
6CCLD_toolchain-clang = "${TARGET_PREFIX}clang ${TOOLCHAIN_OPTIONS}" 6CCLD_toolchain-clang = "${TARGET_PREFIX}clang ${TOOLCHAIN_OPTIONS}"
7 7
8TOOLCHAIN_pn-lzo = "clang" 8TOOLCHAIN_pn-lzo = "clang"
9DEPENDS_append_pn-lzo = " clang-cross " 9DEPENDS_append_pn-lzo = " clang-cross-${TARGET_ARCH} "
10 10
11TOOLCHAIN_pn-musl = "clang" 11TOOLCHAIN_pn-musl = "clang"
12DEPENDS_append_pn-musl = " clang-cross " 12DEPENDS_append_pn-musl = " clang-cross-${TARGET_ARCH} "
13 13
14TOOLCHAIN_pn-toybox = "clang" 14TOOLCHAIN_pn-toybox = "clang"
15DEPENDS_append_pn-toybox = " clang-cross " 15DEPENDS_append_pn-toybox = " clang-cross-${TARGET_ARCH} "
diff --git a/recipes-devtools/clang/clang-cross_git.bb b/recipes-devtools/clang/clang-cross_git.bb
index 48efe41..15ab38d 100644
--- a/recipes-devtools/clang/clang-cross_git.bb
+++ b/recipes-devtools/clang/clang-cross_git.bb
@@ -7,6 +7,8 @@ LICENSE = "NCSA"
7LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/NCSA;md5=1b5fdec70ee13ad8a91667f16c1959d7" 7LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/NCSA;md5=1b5fdec70ee13ad8a91667f16c1959d7"
8SECTION = "devel" 8SECTION = "devel"
9 9
10PN = "clang-cross-${TARGET_ARCH}"
11
10require clang.inc 12require clang.inc
11inherit cross 13inherit cross
12DEPENDS += "clang-native binutils-cross-${TARGET_ARCH}" 14DEPENDS += "clang-native binutils-cross-${TARGET_ARCH}"