summaryrefslogtreecommitdiffstats
path: root/recipes-graphics
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-11-13 22:59:11 -0800
committerKhem Raj <raj.khem@gmail.com>2019-11-14 07:18:21 -0800
commit003dd05e4c168f7c3cccb9cbfad3fd8f38fe8741 (patch)
tree6eb597b2d29e7c924c07f36124a85e13908c2d17 /recipes-graphics
parentdf21a7d3f29cb49783ff93a9f5ba947832a09e25 (diff)
downloadmeta-clang-003dd05e4c168f7c3cccb9cbfad3fd8f38fe8741.tar.gz
clang: Provide llvm/llvm-native
When using meta-clang, it makes sense to use llvm provided by clang recipe, this ensures that we do not build llvm from oe-core but instead offer the one from clang recipe enable rtti and eh for native/nativesdk clang, this is needed for mesa to build Let clang PROVIDE llvm Build AMDGNU and other targets, this is needed for llvm-config to work properly, since we use llvm-config from clang-native, so its better to build the targets that are built for clang-native atleast create version specific symlinks for tblgen anf llvm-config Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/mesa/mesa_%.bbappend5
1 files changed, 5 insertions, 0 deletions
diff --git a/recipes-graphics/mesa/mesa_%.bbappend b/recipes-graphics/mesa/mesa_%.bbappend
index fadc95c..26c6fe3 100644
--- a/recipes-graphics/mesa/mesa_%.bbappend
+++ b/recipes-graphics/mesa/mesa_%.bbappend
@@ -3,3 +3,8 @@ DEPENDS_append_toolchain-clang = " libatomic-ops"
3 3
4EXTRA_OECONF_append_toolchain-clang_x86 = " --disable-asm" 4EXTRA_OECONF_append_toolchain-clang_x86 = " --disable-asm"
5EXTRA_OECONF_append_toolchain-clang_x86-64 = " --disable-asm" 5EXTRA_OECONF_append_toolchain-clang_x86-64 = " --disable-asm"
6
7export YOCTO_ALTERNATE_EXE_PATH = "${STAGING_LIBDIR}/llvm-config"
8
9PACKAGECONFIG[gallium-llvm] = "-Dllvm=true -Dshared-llvm=true, -Dllvm=false, clang clang-native \
10${@'elfutils' if ${GALLIUMDRIVERS_LLVM33_ENABLED} else ''}"