diff options
author | Michael Davis <michael.davis@essvote.com> | 2018-05-23 11:39:28 -0500 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2018-05-29 13:42:42 -0400 |
commit | b877c3a6412583a5fe5a0647df41ace16b7b4fe2 (patch) | |
tree | cf01dcc65d9fb3f5a352c18ca0ada39e445fee73 /recipes-devtools | |
parent | dae9811447bfd881a13f9017ab5b490d0a3e3e70 (diff) | |
download | meta-clang-b877c3a6412583a5fe5a0647df41ace16b7b4fe2.tar.gz |
clang: Add package config for shared-libs
Allow shared or static libs to be selected by package config. Default to shared.
Signed-off-by: Michael Davis <michael.davis@essvote.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r-- | recipes-devtools/clang/clang_git.bb | 7 |
1 files changed, 4 insertions, 3 deletions
diff --git a/recipes-devtools/clang/clang_git.bb b/recipes-devtools/clang/clang_git.bb index 5730b9b..bd09da5 100644 --- a/recipes-devtools/clang/clang_git.bb +++ b/recipes-devtools/clang/clang_git.bb | |||
@@ -51,11 +51,14 @@ def get_clang_host_arch(bb, d): | |||
51 | def get_clang_target_arch(bb, d): | 51 | def get_clang_target_arch(bb, d): |
52 | return get_clang_arch(bb, d, 'TARGET_ARCH') | 52 | return get_clang_arch(bb, d, 'TARGET_ARCH') |
53 | 53 | ||
54 | PACKAGECONFIG ??= "compiler-rt libcplusplus" | 54 | PACKAGECONFIG ??= "compiler-rt libcplusplus shared-libs" |
55 | PACKAGECONFIG_class-native = "" | 55 | PACKAGECONFIG_class-native = "" |
56 | PACKAGECONFIG_class-nativesdk = "compiler-rt libcplusplus" | ||
56 | 57 | ||
57 | PACKAGECONFIG[compiler-rt] = "-DCLANG_DEFAULT_RTLIB=compiler-rt,,compiler-rt" | 58 | PACKAGECONFIG[compiler-rt] = "-DCLANG_DEFAULT_RTLIB=compiler-rt,,compiler-rt" |
58 | PACKAGECONFIG[libcplusplus] = "-DCLANG_DEFAULT_CXX_STDLIB=libc++,,libcxx" | 59 | PACKAGECONFIG[libcplusplus] = "-DCLANG_DEFAULT_CXX_STDLIB=libc++,,libcxx" |
60 | PACKAGECONFIG[shared-libs] = "-DLLVM_BUILD_LLVM_DYLIB=ON -DLLVM_LINK_LLVM_DYLIB=ON,,," | ||
61 | |||
59 | # | 62 | # |
60 | # Default to build all OE-Core supported target arches (user overridable). | 63 | # Default to build all OE-Core supported target arches (user overridable). |
61 | # | 64 | # |
@@ -92,8 +95,6 @@ EXTRA_OECMAKE_append_class-nativesdk = "\ | |||
92 | " | 95 | " |
93 | EXTRA_OECMAKE_append_class-target = "\ | 96 | EXTRA_OECMAKE_append_class-target = "\ |
94 | -DCMAKE_CROSSCOMPILING:BOOL=ON \ | 97 | -DCMAKE_CROSSCOMPILING:BOOL=ON \ |
95 | -DLLVM_BUILD_LLVM_DYLIB=ON \ | ||
96 | -DLLVM_LINK_LLVM_DYLIB=ON \ | ||
97 | -DLLVM_TABLEGEN=${STAGING_BINDIR_NATIVE}/llvm-tblgen \ | 98 | -DLLVM_TABLEGEN=${STAGING_BINDIR_NATIVE}/llvm-tblgen \ |
98 | -DCLANG_TABLEGEN=${STAGING_BINDIR_NATIVE}/clang-tblgen \ | 99 | -DCLANG_TABLEGEN=${STAGING_BINDIR_NATIVE}/clang-tblgen \ |
99 | -DLLVM_TARGETS_TO_BUILD='${LLVM_TARGETS_TO_BUILD_TARGET}' \ | 100 | -DLLVM_TARGETS_TO_BUILD='${LLVM_TARGETS_TO_BUILD_TARGET}' \ |