summaryrefslogtreecommitdiffstats
path: root/recipes-core
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-08-29 08:51:10 -0700
committerKhem Raj <raj.khem@gmail.com>2017-08-29 08:51:10 -0700
commitb6b9f4a6cf5e2d250f39c58d0f9da6340dac22fb (patch)
treee6db0ab14b2c4cc2633d6e2035a5db573d87f98e /recipes-core
parentee9c6d0459ded61946ff55fb71fd5c7187db4235 (diff)
downloadmeta-clang-b6b9f4a6cf5e2d250f39c58d0f9da6340dac22fb.tar.gz
classes: Do not replace armv7ve with armv7a anymore
clang-5.0 supports the option now Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-core')
-rw-r--r--recipes-core/meta/meta-environment.bbappend2
1 files changed, 0 insertions, 2 deletions
diff --git a/recipes-core/meta/meta-environment.bbappend b/recipes-core/meta/meta-environment.bbappend
index c02877d..734a9e6 100644
--- a/recipes-core/meta/meta-environment.bbappend
+++ b/recipes-core/meta/meta-environment.bbappend
@@ -2,8 +2,6 @@ export TARGET_CLANGCC_ARCH = "${TARGET_CC_ARCH}"
2TARGET_CLANGCC_ARCH_remove = "-mthumb-interwork" 2TARGET_CLANGCC_ARCH_remove = "-mthumb-interwork"
3TARGET_CLANGCC_ARCH_remove = "-mmusl" 3TARGET_CLANGCC_ARCH_remove = "-mmusl"
4TARGET_CLANGCC_ARCH_remove = "-muclibc" 4TARGET_CLANGCC_ARCH_remove = "-muclibc"
5TARGET_CLANGCC_ARCH_remove = "-march=armv7ve"
6TARGET_CLANGCC_ARCH_append = "${@bb.utils.contains("TUNE_FEATURES", "armv7ve", " -march=armv7a", "", d)}"
7TARGET_CLANGCC_ARCH_remove = "-meb" 5TARGET_CLANGCC_ARCH_remove = "-meb"
8TARGET_CLANGCC_ARCH_remove = "-mel" 6TARGET_CLANGCC_ARCH_remove = "-mel"
9TARGET_CLANGCC_ARCH_append = "${@bb.utils.contains("TUNE_FEATURES", "bigendian", " -mbig-endian", " -mlittle-endian", d)}" 7TARGET_CLANGCC_ARCH_append = "${@bb.utils.contains("TUNE_FEATURES", "bigendian", " -mbig-endian", " -mlittle-endian", d)}"