summaryrefslogtreecommitdiffstats
path: root/recipes-core
diff options
context:
space:
mode:
authorDaniel McGregor <daniel.mcgregor@vecima.com>2016-04-04 10:23:30 -0600
committerKhem Raj <raj.khem@gmail.com>2017-02-13 08:41:44 -0800
commit9a73a14da45ffcfa9346760123541f36dde9be2f (patch)
treea13f95847a27b5a8e41a5a73d9bd121057d75266 /recipes-core
parentc08c85989b225c9cdd55371a3c26c6e72c15878f (diff)
downloadmeta-clang-9a73a14da45ffcfa9346760123541f36dde9be2f.tar.gz
ncurses: fix build errors in some clang configurations
ncurses' configure script strips the arguments from $CC when checking if -c and -o can be used together. Clang then doesn't have a default sysroot argument to use, so it checks the host for the existence of certain feature headers in libc. These checks fail, and it assumes that clang can't handle -o and -c together. Example config.log snippet: configure:2524: checking whether arm-poky-linux-gnueabi-clang understands -c and -o together configure:2540: arm-poky-linux-gnueabi-clang -c conftest.c -o conftest2.o >&5 In file included from conftest.c:1: In file included from /usr/include/stdio.h:27: In file included from /usr/include/features.h:399: /usr/include/gnu/stubs.h:7:11: fatal error: 'gnu/stubs-32.h' file not found # include <gnu/stubs-32.h> ^ 1 error generated. configure:2543: $? = 1 configure:2562: result: no Signed-off-by: Daniel McGregor <daniel.mcgregor@vecima.com>
Diffstat (limited to 'recipes-core')
-rw-r--r--recipes-core/ncurses/ncurses_%.bbappend1
1 files changed, 1 insertions, 0 deletions
diff --git a/recipes-core/ncurses/ncurses_%.bbappend b/recipes-core/ncurses/ncurses_%.bbappend
new file mode 100644
index 0000000..096d5bc
--- /dev/null
+++ b/recipes-core/ncurses/ncurses_%.bbappend
@@ -0,0 +1 @@
CACHED_CONFIGUREVARS_append_toolchain-clang = " cf_cv_prog_CC_c_o=yes cf_cv_prog_CXX_c_o=yes"