summaryrefslogtreecommitdiffstats
path: root/recipes-core
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2016-04-01 22:45:41 +0000
committerKhem Raj <raj.khem@gmail.com>2016-04-01 22:45:41 +0000
commit18037e0158dd8956b4851f881acad06c42140a60 (patch)
treeaf262d64c8da11b76ca5b2271d4a990884a65bf3 /recipes-core
parent87642f3356cd5c0d9c3b073f5147317965b90fe7 (diff)
downloadmeta-clang-18037e0158dd8956b4851f881acad06c42140a60.tar.gz
Remove -mmusl and -muclibc
These options were introduced in OE-Core to support multi libc SDKs and added with Author: Richard Purdie <richard.purdie@linuxfoundation.org> Date: Sat Jul 25 14:48:21 2015 +0100 toolchain-scripts: For non-glibc, pass compiler options to ensure the correct libc selection gcc-cross-canadian-<arch> is only built once. It needs to target all the different libcs, not just the currently selected one. This change ensures that if another libc is used, the compiler correctly selects the right one. [YOCTO #8025] (From OE-Core rev: da2e92e256054b137a1646fdad1fe1a47ba3215a) Clang however acts based on crosscompiler name and does not have option to controlled multi libc scene Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-core')
-rw-r--r--recipes-core/meta/meta-environment.bbappend3
1 files changed, 3 insertions, 0 deletions
diff --git a/recipes-core/meta/meta-environment.bbappend b/recipes-core/meta/meta-environment.bbappend
index 86accd2..3149492 100644
--- a/recipes-core/meta/meta-environment.bbappend
+++ b/recipes-core/meta/meta-environment.bbappend
@@ -1,5 +1,8 @@
1export TARGET_CLANGCC_ARCH = "${TARGET_CC_ARCH}" 1export TARGET_CLANGCC_ARCH = "${TARGET_CC_ARCH}"
2TARGET_CLANGCC_ARCH_remove = "-mthumb-interwork" 2TARGET_CLANGCC_ARCH_remove = "-mthumb-interwork"
3TARGET_CLANGCC_ARCH_remove = "-mmusl"
4TARGET_CLANGCC_ARCH_remove = "-muclibc"
5
3create_sdk_files_append() { 6create_sdk_files_append() {
4 script=${SDK_OUTPUT}/${SDKPATH}/environment-setup-${REAL_MULTIMACH_TARGET_SYS} 7 script=${SDK_OUTPUT}/${SDKPATH}/environment-setup-${REAL_MULTIMACH_TARGET_SYS}
5 echo 'export CLANGCC="${TARGET_PREFIX}clang ${TARGET_CLANGCC_ARCH} --sysroot=$SDKTARGETSYSROOT"' >> $script 8 echo 'export CLANGCC="${TARGET_PREFIX}clang ${TARGET_CLANGCC_ARCH} --sysroot=$SDKTARGETSYSROOT"' >> $script