summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo Yan <leo.yan@linaro.org>2020-02-26 03:02:20 +0000
committerKhem Raj <raj.khem@gmail.com>2020-02-26 13:47:37 -0800
commit9351170566354898a97088f280f180471ffc4c39 (patch)
tree9b8ec3d633788353e53f30b50b82777b1d55c32b
parent12d8a553c4890a78fdeb0cd0dec2c48dacafe004 (diff)
downloadmeta-clang-9351170566354898a97088f280f180471ffc4c39.tar.gz
BCC: Upgrade to v0.13.0
Since Clang has been upgraded to 10.0.0, it leads to BCC building failure which is caused by LLVM functions definition mismatching. This patch upgrades BCC to v0.13.0 so can support Clang 10.0.0. Signed-off-by: Leo Yan <leo.yan@linaro.org>
-rw-r--r--recipes-devtools/bcc/bcc/0001-Allow-to-build-with-OE-LLVM-cross-compiled-package.patch11
-rw-r--r--recipes-devtools/bcc/bcc/0001-BCC-Use-python-3.patch83
-rw-r--r--recipes-devtools/bcc/bcc_0.13.0.bb (renamed from recipes-devtools/bcc/bcc_0.12.0.bb)4
3 files changed, 67 insertions, 31 deletions
diff --git a/recipes-devtools/bcc/bcc/0001-Allow-to-build-with-OE-LLVM-cross-compiled-package.patch b/recipes-devtools/bcc/bcc/0001-Allow-to-build-with-OE-LLVM-cross-compiled-package.patch
index b5acadc..7b09df6 100644
--- a/recipes-devtools/bcc/bcc/0001-Allow-to-build-with-OE-LLVM-cross-compiled-package.patch
+++ b/recipes-devtools/bcc/bcc/0001-Allow-to-build-with-OE-LLVM-cross-compiled-package.patch
@@ -1,4 +1,4 @@
1From 93cf25ba663e68a6a6f4237fbe0ef8349b3f37ef Mon Sep 17 00:00:00 2001 1From cb13627f25a7af1b54a395eb59e5d7f7786e609d Mon Sep 17 00:00:00 2001
2From: Sumit Garg <sumit.garg@linaro.org> 2From: Sumit Garg <sumit.garg@linaro.org>
3Date: Fri, 14 Feb 2020 07:40:11 +0000 3Date: Fri, 14 Feb 2020 07:40:11 +0000
4Subject: [PATCH] Allow to build with OE LLVM cross compiled package 4Subject: [PATCH] Allow to build with OE LLVM cross compiled package
@@ -16,7 +16,7 @@ Signed-off-by: Sumit Garg <sumit.garg@linaro.org>
16 1 file changed, 2 deletions(-) 16 1 file changed, 2 deletions(-)
17 17
18diff --git a/CMakeLists.txt b/CMakeLists.txt 18diff --git a/CMakeLists.txt b/CMakeLists.txt
19index 7bd0f3b2..6f1f12c0 100644 19index f1916b55..f16d84c3 100644
20--- a/CMakeLists.txt 20--- a/CMakeLists.txt
21+++ b/CMakeLists.txt 21+++ b/CMakeLists.txt
22@@ -39,8 +39,6 @@ endif() 22@@ -39,8 +39,6 @@ endif()
@@ -26,7 +26,8 @@ index 7bd0f3b2..6f1f12c0 100644
26-find_package(LLVM REQUIRED CONFIG) 26-find_package(LLVM REQUIRED CONFIG)
27-message(STATUS "Found LLVM: ${LLVM_INCLUDE_DIRS} ${LLVM_PACKAGE_VERSION}") 27-message(STATUS "Found LLVM: ${LLVM_INCLUDE_DIRS} ${LLVM_PACKAGE_VERSION}")
28 find_package(LibElf REQUIRED) 28 find_package(LibElf REQUIRED)
29 29
30 # clang is linked as a library, but the library path searching is 30 if(CLANG_DIR)
31-- 31--
322.17.1 322.17.1
33
diff --git a/recipes-devtools/bcc/bcc/0001-BCC-Use-python-3.patch b/recipes-devtools/bcc/bcc/0001-BCC-Use-python-3.patch
index e1db752..7cd4298 100644
--- a/recipes-devtools/bcc/bcc/0001-BCC-Use-python-3.patch
+++ b/recipes-devtools/bcc/bcc/0001-BCC-Use-python-3.patch
@@ -1,4 +1,4 @@
1From 7491be67e0795f00566d46e5f055a955ea0aac8e Mon Sep 17 00:00:00 2001 1From 73fa1159a97204c124b3ebd9024c68006f3dfc31 Mon Sep 17 00:00:00 2001
2From: Leo Yan <leo.yan@linaro.org> 2From: Leo Yan <leo.yan@linaro.org>
3Date: Sat, 22 Feb 2020 16:22:33 +0000 3Date: Sat, 22 Feb 2020 16:22:33 +0000
4Subject: [PATCH] BCC: Use python 3 4Subject: [PATCH] BCC: Use python 3
@@ -50,6 +50,7 @@ Signed-off-by: Leo Yan <leo.yan@linaro.org>
50 examples/usdt_sample/scripts/latency.py | 2 +- 50 examples/usdt_sample/scripts/latency.py | 2 +-
51 tools/argdist.py | 2 +- 51 tools/argdist.py | 2 +-
52 tools/bashreadline.py | 2 +- 52 tools/bashreadline.py | 2 +-
53 tools/bindsnoop.py | 2 +-
53 tools/biolatency.py | 2 +- 54 tools/biolatency.py | 2 +-
54 tools/biosnoop.py | 2 +- 55 tools/biosnoop.py | 2 +-
55 tools/biotop.py | 2 +- 56 tools/biotop.py | 2 +-
@@ -60,6 +61,7 @@ Signed-off-by: Leo Yan <leo.yan@linaro.org>
60 tools/cachestat.py | 2 +- 61 tools/cachestat.py | 2 +-
61 tools/cachetop.py | 2 +- 62 tools/cachetop.py | 2 +-
62 tools/capable.py | 2 +- 63 tools/capable.py | 2 +-
64 tools/compactsnoop.py | 2 +-
63 tools/cpudist.py | 2 +- 65 tools/cpudist.py | 2 +-
64 tools/cpuunclaimed.py | 2 +- 66 tools/cpuunclaimed.py | 2 +-
65 tools/criticalstat.py | 2 +- 67 tools/criticalstat.py | 2 +-
@@ -101,6 +103,7 @@ Signed-off-by: Leo Yan <leo.yan@linaro.org>
101 tools/offwaketime.py | 2 +- 103 tools/offwaketime.py | 2 +-
102 tools/old/bashreadline.py | 2 +- 104 tools/old/bashreadline.py | 2 +-
103 tools/old/biosnoop.py | 2 +- 105 tools/old/biosnoop.py | 2 +-
106 tools/old/compactsnoop.py | 2 +-
104 tools/old/filelife.py | 2 +- 107 tools/old/filelife.py | 2 +-
105 tools/old/gethostlatency.py | 2 +- 108 tools/old/gethostlatency.py | 2 +-
106 tools/old/killsnoop.py | 2 +- 109 tools/old/killsnoop.py | 2 +-
@@ -155,7 +158,7 @@ Signed-off-by: Leo Yan <leo.yan@linaro.org>
155 tools/xfsslower.py | 2 +- 158 tools/xfsslower.py | 2 +-
156 tools/zfsdist.py | 2 +- 159 tools/zfsdist.py | 2 +-
157 tools/zfsslower.py | 2 +- 160 tools/zfsslower.py | 2 +-
158 150 files changed, 150 insertions(+), 150 deletions(-) 161 153 files changed, 153 insertions(+), 153 deletions(-)
159 162
160diff --git a/examples/hello_world.py b/examples/hello_world.py 163diff --git a/examples/hello_world.py b/examples/hello_world.py
161index bb52f3e7..e36c09b0 100755 164index bb52f3e7..e36c09b0 100755
@@ -208,7 +211,7 @@ index 943dca59..47d99453 100755
208 from __future__ import print_function 211 from __future__ import print_function
209 from bcc import BPF 212 from bcc import BPF
210diff --git a/examples/networking/http_filter/http-parse-complete.py b/examples/networking/http_filter/http-parse-complete.py 213diff --git a/examples/networking/http_filter/http-parse-complete.py b/examples/networking/http_filter/http-parse-complete.py
211index f1e5e0a2..e364d9aa 100644 214index 0f995105..e6c68690 100644
212--- a/examples/networking/http_filter/http-parse-complete.py 215--- a/examples/networking/http_filter/http-parse-complete.py
213+++ b/examples/networking/http_filter/http-parse-complete.py 216+++ b/examples/networking/http_filter/http-parse-complete.py
214@@ -1,4 +1,4 @@ 217@@ -1,4 +1,4 @@
@@ -348,7 +351,7 @@ index 4d7c7958..ea793f94 100755
348 # bitehist.py Block I/O size histogram. 351 # bitehist.py Block I/O size histogram.
349 # For Linux, uses BCC, eBPF. Embedded C. 352 # For Linux, uses BCC, eBPF. Embedded C.
350diff --git a/examples/tracing/dddos.py b/examples/tracing/dddos.py 353diff --git a/examples/tracing/dddos.py b/examples/tracing/dddos.py
351index 5b544241..2b77725e 100755 354index 09e9f6d8..30856260 100755
352--- a/examples/tracing/dddos.py 355--- a/examples/tracing/dddos.py
353+++ b/examples/tracing/dddos.py 356+++ b/examples/tracing/dddos.py
354@@ -1,4 +1,4 @@ 357@@ -1,4 +1,4 @@
@@ -607,6 +610,16 @@ index b7d98272..4a01e50d 100755
607 # 610 #
608 # bashreadline Print entered bash commands from all running shells. 611 # bashreadline Print entered bash commands from all running shells.
609 # For Linux, uses BCC, eBPF. Embedded C. 612 # For Linux, uses BCC, eBPF. Embedded C.
613diff --git a/tools/bindsnoop.py b/tools/bindsnoop.py
614index 4d3133fc..41da267b 100755
615--- a/tools/bindsnoop.py
616+++ b/tools/bindsnoop.py
617@@ -1,4 +1,4 @@
618-#!/usr/bin/python
619+#!/usr/bin/python3
620 #
621 # bindsnoop Trace IPv4 and IPv6 binds()s.
622 # For Linux, uses BCC, eBPF. Embedded C.
610diff --git a/tools/biolatency.py b/tools/biolatency.py 623diff --git a/tools/biolatency.py b/tools/biolatency.py
611index 86d99437..f9abfd8b 100755 624index 86d99437..f9abfd8b 100755
612--- a/tools/biolatency.py 625--- a/tools/biolatency.py
@@ -648,7 +661,7 @@ index f4cea7cd..569630af 100755
648 # bitehist.py Block I/O size histogram. 661 # bitehist.py Block I/O size histogram.
649 # For Linux, uses BCC, eBPF. See .c file. 662 # For Linux, uses BCC, eBPF. See .c file.
650diff --git a/tools/bpflist.py b/tools/bpflist.py 663diff --git a/tools/bpflist.py b/tools/bpflist.py
651index f73e945a..118fd00d 100755 664index 2d9793e6..3d14248f 100755
652--- a/tools/bpflist.py 665--- a/tools/bpflist.py
653+++ b/tools/bpflist.py 666+++ b/tools/bpflist.py
654@@ -1,4 +1,4 @@ 667@@ -1,4 +1,4 @@
@@ -688,7 +701,7 @@ index bb949493..a83e6615 100755
688 # cachestat Count cache kernel function calls. 701 # cachestat Count cache kernel function calls.
689 # For Linux, uses BCC, eBPF. See .c file. 702 # For Linux, uses BCC, eBPF. See .c file.
690diff --git a/tools/cachetop.py b/tools/cachetop.py 703diff --git a/tools/cachetop.py b/tools/cachetop.py
691index 59de3912..5e07ae81 100755 704index 00b11a8c..bc793794 100755
692--- a/tools/cachetop.py 705--- a/tools/cachetop.py
693+++ b/tools/cachetop.py 706+++ b/tools/cachetop.py
694@@ -1,4 +1,4 @@ 707@@ -1,4 +1,4 @@
@@ -698,7 +711,7 @@ index 59de3912..5e07ae81 100755
698 # 711 #
699 # cachetop Count cache kernel function calls per processes 712 # cachetop Count cache kernel function calls per processes
700diff --git a/tools/capable.py b/tools/capable.py 713diff --git a/tools/capable.py b/tools/capable.py
701index bb4a8435..bf8bc5a8 100755 714index 69fef3de..324bdb1b 100755
702--- a/tools/capable.py 715--- a/tools/capable.py
703+++ b/tools/capable.py 716+++ b/tools/capable.py
704@@ -1,4 +1,4 @@ 717@@ -1,4 +1,4 @@
@@ -707,6 +720,16 @@ index bb4a8435..bf8bc5a8 100755
707 # @lint-avoid-python-3-compatibility-imports 720 # @lint-avoid-python-3-compatibility-imports
708 # 721 #
709 # capable Trace security capabilitiy checks (cap_capable()). 722 # capable Trace security capabilitiy checks (cap_capable()).
723diff --git a/tools/compactsnoop.py b/tools/compactsnoop.py
724index 7f9ce7ee..3a43e1f2 100755
725--- a/tools/compactsnoop.py
726+++ b/tools/compactsnoop.py
727@@ -1,4 +1,4 @@
728-#!/usr/bin/python
729+#!/usr/bin/python3
730 # @lint-avoid-python-3-compatibility-imports
731 #
732 # compactsnoop Trace compact zone and print details including issuing PID.
710diff --git a/tools/cpudist.py b/tools/cpudist.py 733diff --git a/tools/cpudist.py b/tools/cpudist.py
711index 4e549ac4..663d2b87 100755 734index 4e549ac4..663d2b87 100755
712--- a/tools/cpudist.py 735--- a/tools/cpudist.py
@@ -798,7 +821,7 @@ index c77f5206..c640b3d6 100755
798 # 821 #
799 # drsnoop Trace direct reclaim and print details including issuing PID. 822 # drsnoop Trace direct reclaim and print details including issuing PID.
800diff --git a/tools/execsnoop.py b/tools/execsnoop.py 823diff --git a/tools/execsnoop.py b/tools/execsnoop.py
801index e5a04903..ea3295fc 100755 824index 57dfab29..fe35ea85 100755
802--- a/tools/execsnoop.py 825--- a/tools/execsnoop.py
803+++ b/tools/execsnoop.py 826+++ b/tools/execsnoop.py
804@@ -1,4 +1,4 @@ 827@@ -1,4 +1,4 @@
@@ -858,7 +881,7 @@ index 31e3adf9..2a564045 100755
858 # 881 #
859 # fileslower Trace slow synchronous file reads and writes. 882 # fileslower Trace slow synchronous file reads and writes.
860diff --git a/tools/filetop.py b/tools/filetop.py 883diff --git a/tools/filetop.py b/tools/filetop.py
861index 552367a9..632b4d78 100755 884index dbe7a7da..1bb703e7 100755
862--- a/tools/filetop.py 885--- a/tools/filetop.py
863+++ b/tools/filetop.py 886+++ b/tools/filetop.py
864@@ -1,4 +1,4 @@ 887@@ -1,4 +1,4 @@
@@ -918,7 +941,7 @@ index 589a890d..02bddc79 100755
918 # 941 #
919 # hardirqs Summarize hard IRQ (interrupt) event time. 942 # hardirqs Summarize hard IRQ (interrupt) event time.
920diff --git a/tools/inject.py b/tools/inject.py 943diff --git a/tools/inject.py b/tools/inject.py
921index fa2d3887..948832c1 100755 944index 9d6b85f8..c9ebec9f 100755
922--- a/tools/inject.py 945--- a/tools/inject.py
923+++ b/tools/inject.py 946+++ b/tools/inject.py
924@@ -1,4 +1,4 @@ 947@@ -1,4 +1,4 @@
@@ -938,7 +961,7 @@ index 2fb1dcb5..8439a539 100755
938 # 961 #
939 # killsnoop Trace signals issued by the kill() syscall. 962 # killsnoop Trace signals issued by the kill() syscall.
940diff --git a/tools/klockstat.py b/tools/klockstat.py 963diff --git a/tools/klockstat.py b/tools/klockstat.py
941index 343d4362..db4715d0 100755 964index e2047880..80278638 100755
942--- a/tools/klockstat.py 965--- a/tools/klockstat.py
943+++ b/tools/klockstat.py 966+++ b/tools/klockstat.py
944@@ -1,4 +1,4 @@ 967@@ -1,4 +1,4 @@
@@ -1068,7 +1091,7 @@ index ff78506f..27631ade 100755
1068 # 1091 #
1069 # nfsdist Summarize NFS operation latency 1092 # nfsdist Summarize NFS operation latency
1070diff --git a/tools/nfsslower.py b/tools/nfsslower.py 1093diff --git a/tools/nfsslower.py b/tools/nfsslower.py
1071index 36918ca0..bddfe6ab 100755 1094index 5e344b9b..de21ef60 100755
1072--- a/tools/nfsslower.py 1095--- a/tools/nfsslower.py
1073+++ b/tools/nfsslower.py 1096+++ b/tools/nfsslower.py
1074@@ -1,4 +1,4 @@ 1097@@ -1,4 +1,4 @@
@@ -1078,7 +1101,7 @@ index 36918ca0..bddfe6ab 100755
1078 # 1101 #
1079 # nfsslower Trace slow NFS operations 1102 # nfsslower Trace slow NFS operations
1080diff --git a/tools/offcputime.py b/tools/offcputime.py 1103diff --git a/tools/offcputime.py b/tools/offcputime.py
1081index ac3b7281..fbaa37a4 100755 1104index 50ce1cc1..f28249ba 100755
1082--- a/tools/offcputime.py 1105--- a/tools/offcputime.py
1083+++ b/tools/offcputime.py 1106+++ b/tools/offcputime.py
1084@@ -1,4 +1,4 @@ 1107@@ -1,4 +1,4 @@
@@ -1088,7 +1111,7 @@ index ac3b7281..fbaa37a4 100755
1088 # offcputime Summarize off-CPU time by stack trace 1111 # offcputime Summarize off-CPU time by stack trace
1089 # For Linux, uses BCC, eBPF. 1112 # For Linux, uses BCC, eBPF.
1090diff --git a/tools/offwaketime.py b/tools/offwaketime.py 1113diff --git a/tools/offwaketime.py b/tools/offwaketime.py
1091index 4809a3b6..3d3ba8be 100755 1114index 665b6666..148233ff 100755
1092--- a/tools/offwaketime.py 1115--- a/tools/offwaketime.py
1093+++ b/tools/offwaketime.py 1116+++ b/tools/offwaketime.py
1094@@ -1,4 +1,4 @@ 1117@@ -1,4 +1,4 @@
@@ -1117,6 +1140,16 @@ index 37ee3f9c..7eddf518 100755
1117 # @lint-avoid-python-3-compatibility-imports 1140 # @lint-avoid-python-3-compatibility-imports
1118 # 1141 #
1119 # biosnoop Trace block device I/O and print details including issuing PID. 1142 # biosnoop Trace block device I/O and print details including issuing PID.
1143diff --git a/tools/old/compactsnoop.py b/tools/old/compactsnoop.py
1144index c5440417..42cfc9c0 100755
1145--- a/tools/old/compactsnoop.py
1146+++ b/tools/old/compactsnoop.py
1147@@ -1,4 +1,4 @@
1148-#!/usr/bin/python
1149+#!/usr/bin/python3
1150 # @lint-avoid-python-3-compatibility-imports
1151 #
1152 # compactsnoop Trace compact zone and print details including issuing PID.
1120diff --git a/tools/old/filelife.py b/tools/old/filelife.py 1153diff --git a/tools/old/filelife.py b/tools/old/filelife.py
1121index 075be087..733ff86b 100755 1154index 075be087..733ff86b 100755
1122--- a/tools/old/filelife.py 1155--- a/tools/old/filelife.py
@@ -1198,7 +1231,7 @@ index 5df3b417..2eabd50a 100755
1198 # 1231 #
1199 # opensnoop Trace open() syscalls. 1232 # opensnoop Trace open() syscalls.
1200diff --git a/tools/old/profile.py b/tools/old/profile.py 1233diff --git a/tools/old/profile.py b/tools/old/profile.py
1201index 7c768f43..84091007 100755 1234index 0abcf576..95dfc110 100755
1202--- a/tools/old/profile.py 1235--- a/tools/old/profile.py
1203+++ b/tools/old/profile.py 1236+++ b/tools/old/profile.py
1204@@ -1,4 +1,4 @@ 1237@@ -1,4 +1,4 @@
@@ -1298,7 +1331,7 @@ index 4f3b6ce7..c9fde155 100755
1298 # oomkill Trace oom_kill_process(). For Linux, uses BCC, eBPF. 1331 # oomkill Trace oom_kill_process(). For Linux, uses BCC, eBPF.
1299 # 1332 #
1300diff --git a/tools/opensnoop.py b/tools/opensnoop.py 1333diff --git a/tools/opensnoop.py b/tools/opensnoop.py
1301index 60d11c63..a4a49d93 100755 1334index 6d1388b3..f087c895 100755
1302--- a/tools/opensnoop.py 1335--- a/tools/opensnoop.py
1303+++ b/tools/opensnoop.py 1336+++ b/tools/opensnoop.py
1304@@ -1,4 +1,4 @@ 1337@@ -1,4 +1,4 @@
@@ -1318,7 +1351,7 @@ index c4490043..38f41960 100755
1318 # 1351 #
1319 # pidpersec Count new processes (via fork). 1352 # pidpersec Count new processes (via fork).
1320diff --git a/tools/profile.py b/tools/profile.py 1353diff --git a/tools/profile.py b/tools/profile.py
1321index dfbced6a..7ff9a93b 100755 1354index 11f3e98d..c6922160 100755
1322--- a/tools/profile.py 1355--- a/tools/profile.py
1323+++ b/tools/profile.py 1356+++ b/tools/profile.py
1324@@ -1,4 +1,4 @@ 1357@@ -1,4 +1,4 @@
@@ -1348,7 +1381,7 @@ index b56a5916..aec8a8af 100755
1348 # 1381 #
1349 # runqlen Summarize scheduler run queue length as a histogram. 1382 # runqlen Summarize scheduler run queue length as a histogram.
1350diff --git a/tools/runqslower.py b/tools/runqslower.py 1383diff --git a/tools/runqslower.py b/tools/runqslower.py
1351index b6785330..8b24d6b0 100755 1384index 8f790602..89021466 100755
1352--- a/tools/runqslower.py 1385--- a/tools/runqslower.py
1353+++ b/tools/runqslower.py 1386+++ b/tools/runqslower.py
1354@@ -1,4 +1,4 @@ 1387@@ -1,4 +1,4 @@
@@ -1418,7 +1451,7 @@ index e48fbb47..5e01d7c1 100755
1418 # sslsniff Captures data on read/recv or write/send functions of OpenSSL, 1451 # sslsniff Captures data on read/recv or write/send functions of OpenSSL,
1419 # GnuTLS and NSS 1452 # GnuTLS and NSS
1420diff --git a/tools/stackcount.py b/tools/stackcount.py 1453diff --git a/tools/stackcount.py b/tools/stackcount.py
1421index a58f9e31..0d5b9be0 100755 1454index 2afb91ff..15b028b8 100755
1422--- a/tools/stackcount.py 1455--- a/tools/stackcount.py
1423+++ b/tools/stackcount.py 1456+++ b/tools/stackcount.py
1424@@ -1,4 +1,4 @@ 1457@@ -1,4 +1,4 @@
@@ -1458,7 +1491,7 @@ index 7ba08dd3..94b7ad34 100755
1458 # syscount Summarize syscall counts and latencies. 1491 # syscount Summarize syscall counts and latencies.
1459 # 1492 #
1460diff --git a/tools/tcpaccept.py b/tools/tcpaccept.py 1493diff --git a/tools/tcpaccept.py b/tools/tcpaccept.py
1461index 914d5183..c9ef7678 100755 1494index 7c104208..245e796e 100755
1462--- a/tools/tcpaccept.py 1495--- a/tools/tcpaccept.py
1463+++ b/tools/tcpaccept.py 1496+++ b/tools/tcpaccept.py
1464@@ -1,4 +1,4 @@ 1497@@ -1,4 +1,4 @@
@@ -1478,7 +1511,7 @@ index eb12667e..7ba92394 100755
1478 # 1511 #
1479 # tcpconnect Trace TCP connect()s. 1512 # tcpconnect Trace TCP connect()s.
1480diff --git a/tools/tcpconnlat.py b/tools/tcpconnlat.py 1513diff --git a/tools/tcpconnlat.py b/tools/tcpconnlat.py
1481index 8f686211..657a8cea 100755 1514index be6bbbfa..0aad5ccc 100755
1482--- a/tools/tcpconnlat.py 1515--- a/tools/tcpconnlat.py
1483+++ b/tools/tcpconnlat.py 1516+++ b/tools/tcpconnlat.py
1484@@ -1,4 +1,4 @@ 1517@@ -1,4 +1,4 @@
@@ -1498,7 +1531,7 @@ index 14515f75..2076aeb0 100755
1498 # 1531 #
1499 # tcpdrop Trace TCP kernel-dropped packets/segments. 1532 # tcpdrop Trace TCP kernel-dropped packets/segments.
1500diff --git a/tools/tcplife.py b/tools/tcplife.py 1533diff --git a/tools/tcplife.py b/tools/tcplife.py
1501index ed251553..c62c1fc5 100755 1534index d4e679dd..e7e9055a 100755
1502--- a/tools/tcplife.py 1535--- a/tools/tcplife.py
1503+++ b/tools/tcplife.py 1536+++ b/tools/tcplife.py
1504@@ -1,4 +1,4 @@ 1537@@ -1,4 +1,4 @@
@@ -1518,7 +1551,7 @@ index 1b2636ae..936028f6 100755
1518 # 1551 #
1519 # tcpretrans Trace or count TCP retransmits and TLPs. 1552 # tcpretrans Trace or count TCP retransmits and TLPs.
1520diff --git a/tools/tcpstates.py b/tools/tcpstates.py 1553diff --git a/tools/tcpstates.py b/tools/tcpstates.py
1521index 3c78b1c4..0d3e9a0f 100755 1554index b9a64387..e0aeefaf 100755
1522--- a/tools/tcpstates.py 1555--- a/tools/tcpstates.py
1523+++ b/tools/tcpstates.py 1556+++ b/tools/tcpstates.py
1524@@ -1,4 +1,4 @@ 1557@@ -1,4 +1,4 @@
@@ -1538,7 +1571,7 @@ index 5f2a8062..302f7200 100755
1538 # 1571 #
1539 # tcpsubnet Summarize TCP bytes sent to different subnets. 1572 # tcpsubnet Summarize TCP bytes sent to different subnets.
1540diff --git a/tools/tcptop.py b/tools/tcptop.py 1573diff --git a/tools/tcptop.py b/tools/tcptop.py
1541index 5f09bed4..0eb45c54 100755 1574index 330d5bbb..e87172a6 100755
1542--- a/tools/tcptop.py 1575--- a/tools/tcptop.py
1543+++ b/tools/tcptop.py 1576+++ b/tools/tcptop.py
1544@@ -1,4 +1,4 @@ 1577@@ -1,4 +1,4 @@
@@ -1568,7 +1601,7 @@ index 6ec2fbe1..e20eb0c3 100755
1568 # tplist Display kernel tracepoints or USDT probes and their formats. 1601 # tplist Display kernel tracepoints or USDT probes and their formats.
1569 # 1602 #
1570diff --git a/tools/trace.py b/tools/trace.py 1603diff --git a/tools/trace.py b/tools/trace.py
1571index 9afd6726..b370f8bd 100755 1604index 8b2ca358..54badc01 100755
1572--- a/tools/trace.py 1605--- a/tools/trace.py
1573+++ b/tools/trace.py 1606+++ b/tools/trace.py
1574@@ -1,4 +1,4 @@ 1607@@ -1,4 +1,4 @@
diff --git a/recipes-devtools/bcc/bcc_0.12.0.bb b/recipes-devtools/bcc/bcc_0.13.0.bb
index 1da699e..2a346c1 100644
--- a/recipes-devtools/bcc/bcc_0.12.0.bb
+++ b/recipes-devtools/bcc/bcc_0.13.0.bb
@@ -20,7 +20,7 @@ SRC_URI = "git://github.com/iovisor/bcc \
20 file://0001-Allow-to-build-with-OE-LLVM-cross-compiled-package.patch \ 20 file://0001-Allow-to-build-with-OE-LLVM-cross-compiled-package.patch \
21 file://0001-BCC-Use-python-3.patch \ 21 file://0001-BCC-Use-python-3.patch \
22 " 22 "
23SRCREV = "368a5b0714961953f3e3f61607fa16cb71449c1b" 23SRCREV = "942227484d3207f6a42103674001ef01fb5335a0"
24 24
25S = "${WORKDIR}/git" 25S = "${WORKDIR}/git"
26 26
@@ -36,3 +36,5 @@ EXTRA_OECMAKE = " \
36" 36"
37 37
38FILES_${PN} += "${libdir}/python*/dist-packages" 38FILES_${PN} += "${libdir}/python*/dist-packages"
39
40COMPATIBLE_HOST = "(x86_64.*|aarch64.*|powerpc64.*)-linux"