summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-09-28 08:41:50 -0700
committerKhem Raj <raj.khem@gmail.com>2019-09-28 16:55:57 -0700
commit9a2dcdf3b1b0576e7ae754b63dae81091e2417bf (patch)
tree0c2a29cace440c999b61e77e83ae64867008dcca
parent3ae77709d22d2f608f1984a73386067d4dcdaea0 (diff)
downloadmeta-clang-9a2dcdf3b1b0576e7ae754b63dae81091e2417bf.tar.gz
llvm-libunwind: Fix linunwind providers
libunwind can be either nongnu libunwind ( from OE-Core ) or from llvm and when using clang and using --unwindlib=libunwind we know we have to use llvm libunwind implementation, so remove libunwind from DEPENDS and add llvm-libunwind to depends Drop providing libunwind from llvm-libunwind since its not needed anymore Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--classes/clang.bbclass8
-rw-r--r--recipes-devtools/clang/llvm-libunwind.bb2
2 files changed, 8 insertions, 2 deletions
diff --git a/classes/clang.bbclass b/classes/clang.bbclass
index 6d99b45..a8f2c90 100644
--- a/classes/clang.bbclass
+++ b/classes/clang.bbclass
@@ -77,4 +77,12 @@ def clang_dep_prepend(d):
77 return ret 77 return ret
78 return "" 78 return ""
79 79
80def clang_remove_deps(d):
81 ret = ""
82 if (d.getVar('COMPILER_RT').find('--unwindlib=libunwind') != -1):
83 ret += "libunwind"
84 return ret
85
80BASE_DEFAULT_DEPS_toolchain-clang_class-target = "${@clang_dep_prepend(d)}" 86BASE_DEFAULT_DEPS_toolchain-clang_class-target = "${@clang_dep_prepend(d)}"
87DEPENDS_remove_toolchain-clang_class-target = "${@clang_remove_deps(d)}"
88
diff --git a/recipes-devtools/clang/llvm-libunwind.bb b/recipes-devtools/clang/llvm-libunwind.bb
index 1bcad96..7dbdf4f 100644
--- a/recipes-devtools/clang/llvm-libunwind.bb
+++ b/recipes-devtools/clang/llvm-libunwind.bb
@@ -10,8 +10,6 @@ require common-source.inc
10 10
11inherit cmake pythonnative 11inherit cmake pythonnative
12 12
13PROVIDES += "libunwind"
14
15DEPENDS += "ninja-native" 13DEPENDS += "ninja-native"
16 14
17LIBCPLUSPLUS = "" 15LIBCPLUSPLUS = ""