summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Tworek <tworaz@tworaz.net>2019-07-26 21:47:48 +0200
committerKhem Raj <raj.khem@gmail.com>2019-07-26 14:36:06 -0700
commit4babecabc58ec64a5a12c180165996ea34f9e48a (patch)
treea3fc10ade977288cce26cfa6923b754858280de8
parentb70965490d26c49771704addc27d9dbb31362b14 (diff)
downloadmeta-clang-yoe/mut.tar.gz
clang: Move libclang into its own dedicated package.yoe/mut
This library has a few potential consimers (ex, qttools) which don't need whole clang install. Distributions like debian already package lbiclang separately as libclang1. This makes even more sense for embedded systems. Do the same for OE/Yocto. Signed-off-by: Piotr Tworek <tworaz@tworaz.net>
-rw-r--r--recipes-devtools/clang/clang_git.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/recipes-devtools/clang/clang_git.bb b/recipes-devtools/clang/clang_git.bb
index 484e85c..a550031 100644
--- a/recipes-devtools/clang/clang_git.bb
+++ b/recipes-devtools/clang/clang_git.bb
@@ -179,7 +179,7 @@ do_install_append_class-nativesdk () {
179 179
180PACKAGE_DEBUG_SPLIT_STYLE_class-nativesdk = "debug-without-src" 180PACKAGE_DEBUG_SPLIT_STYLE_class-nativesdk = "debug-without-src"
181 181
182PACKAGES =+ "${PN}-libllvm" 182PACKAGES =+ "${PN}-libllvm libclang"
183 183
184BBCLASSEXTEND = "native nativesdk" 184BBCLASSEXTEND = "native nativesdk"
185 185
@@ -198,6 +198,10 @@ FILES_${PN}-libllvm += "\
198 ${libdir}/libLLVM-${MAJOR_VER}.${MINOR_VER}svn.so \ 198 ${libdir}/libLLVM-${MAJOR_VER}.${MINOR_VER}svn.so \
199" 199"
200 200
201FILES_libclang = "\
202 ${libdir}/libclang.so.${MAJOR_VER} \
203"
204
201FILES_${PN}-dev += "\ 205FILES_${PN}-dev += "\
202 ${datadir}/llvm/cmake \ 206 ${datadir}/llvm/cmake \
203 ${libdir}/cmake \ 207 ${libdir}/cmake \