summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-02-04 12:54:44 -0800
committerKhem Raj <raj.khem@gmail.com>2022-02-04 12:54:44 -0800
commit25eb19092ff4df6c9d0dc443c85c4f4b2066f855 (patch)
treed809959b5ba1c17b6b00c955c51b55ec6b8bad4c
parent92abd44335b84fc895ddc166694fe8b2a2783ae6 (diff)
parent5ac36e49ab0f4b9bc72a3c747841c1f9e54e640a (diff)
downloadmeta-clang-25eb19092ff4df6c9d0dc443c85c4f4b2066f855.tar.gz
Merge remote-tracking branch 'upstream/dunfell' into clang12
-rw-r--r--conf/layer.conf4
-rw-r--r--dynamic-layers/chromium-browser-layer/recipes-browser/chromium-ozone-wayland_%.bbappend10
-rw-r--r--dynamic-layers/chromium-browser-layer/recipes-browser/chromium-x11_%.bbappend10
-rw-r--r--dynamic-layers/chromium-browser-layer/recipes-browser/gn-native_%.bbappend6
-rw-r--r--recipes-devtools/clang/common.inc1
5 files changed, 28 insertions, 3 deletions
diff --git a/conf/layer.conf b/conf/layer.conf
index 2f9d6f8..19e348b 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -11,8 +11,8 @@ LAYERSERIES_COMPAT_clang-layer = "dunfell hardknott honister"
11LAYERDEPENDS_clang-layer = "core" 11LAYERDEPENDS_clang-layer = "core"
12 12
13BBFILES_DYNAMIC += " \ 13BBFILES_DYNAMIC += " \
14 browser-layer:${LAYERDIR}/dynamic-layers/chromium-browser-layer/*/*/*.bb \ 14 chromium-browser-layer:${LAYERDIR}/dynamic-layers/chromium-browser-layer/*/*.bb \
15 browser-layer:${LAYERDIR}/dynamic-layers/chromium-browser-layer/*/*/*.bbappend \ 15 chromium-browser-layer:${LAYERDIR}/dynamic-layers/chromium-browser-layer/*/*.bbappend \
16 openembedded-layer:${LAYERDIR}/dynamic-layers/openembedded-layer/*/*/*.bb \ 16 openembedded-layer:${LAYERDIR}/dynamic-layers/openembedded-layer/*/*/*.bb \
17 openembedded-layer:${LAYERDIR}/dynamic-layers/openembedded-layer/*/*/*.bbappend \ 17 openembedded-layer:${LAYERDIR}/dynamic-layers/openembedded-layer/*/*/*.bbappend \
18 networking-layer:${LAYERDIR}/dynamic-layers/networking-layer/*/*/*.bb \ 18 networking-layer:${LAYERDIR}/dynamic-layers/networking-layer/*/*/*.bb \
diff --git a/dynamic-layers/chromium-browser-layer/recipes-browser/chromium-ozone-wayland_%.bbappend b/dynamic-layers/chromium-browser-layer/recipes-browser/chromium-ozone-wayland_%.bbappend
new file mode 100644
index 0000000..ff82a79
--- /dev/null
+++ b/dynamic-layers/chromium-browser-layer/recipes-browser/chromium-ozone-wayland_%.bbappend
@@ -0,0 +1,10 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3GN_ARGS += "use_lld=true use_gold=false"
4
5UNWINDLIB_toolchain-clang = "--unwindlib=libgcc"
6
7DEPENDS_remove = "compiler-rt-native libcxx-native"
8
9BUILD_CPPFLAGS_remove = "-isysroot=${STAGING_DIR_NATIVE} -stdlib=libc++"
10BUILD_LDFLAGS_remove = "-rtlib=libgcc -unwindlib=libgcc -stdlib=libc++ -lc++abi -rpath ${STAGING_LIBDIR_NATIVE}"
diff --git a/dynamic-layers/chromium-browser-layer/recipes-browser/chromium-x11_%.bbappend b/dynamic-layers/chromium-browser-layer/recipes-browser/chromium-x11_%.bbappend
new file mode 100644
index 0000000..ff82a79
--- /dev/null
+++ b/dynamic-layers/chromium-browser-layer/recipes-browser/chromium-x11_%.bbappend
@@ -0,0 +1,10 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3GN_ARGS += "use_lld=true use_gold=false"
4
5UNWINDLIB_toolchain-clang = "--unwindlib=libgcc"
6
7DEPENDS_remove = "compiler-rt-native libcxx-native"
8
9BUILD_CPPFLAGS_remove = "-isysroot=${STAGING_DIR_NATIVE} -stdlib=libc++"
10BUILD_LDFLAGS_remove = "-rtlib=libgcc -unwindlib=libgcc -stdlib=libc++ -lc++abi -rpath ${STAGING_LIBDIR_NATIVE}"
diff --git a/dynamic-layers/chromium-browser-layer/recipes-browser/gn-native_%.bbappend b/dynamic-layers/chromium-browser-layer/recipes-browser/gn-native_%.bbappend
new file mode 100644
index 0000000..cd60c58
--- /dev/null
+++ b/dynamic-layers/chromium-browser-layer/recipes-browser/gn-native_%.bbappend
@@ -0,0 +1,6 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3DEPENDS_remove = "compiler-rt-native libcxx-native"
4
5CXXFLAGS_remove = "-isysroot=${STAGING_DIR_NATIVE} -stdlib=libc++"
6LDFLAGS_remove = "-rtlib=libgcc -unwindlib=libgcc -stdlib=libc++ -lc++abi -rpath ${STAGING_LIBDIR_NATIVE}"
diff --git a/recipes-devtools/clang/common.inc b/recipes-devtools/clang/common.inc
index e211258..c94dd69 100644
--- a/recipes-devtools/clang/common.inc
+++ b/recipes-devtools/clang/common.inc
@@ -25,7 +25,6 @@ SRC_URI = "\
25 file://0014-clang-Fix-ldso-for-musl-on-x86-and-x32-architectures.patch \ 25 file://0014-clang-Fix-ldso-for-musl-on-x86-and-x32-architectures.patch \
26 file://0015-clang-scan-view-needs-python-2.x.patch \ 26 file://0015-clang-scan-view-needs-python-2.x.patch \
27 file://0016-clang-Add-lpthread-and-ldl-along-with-lunwind-for-st.patch \ 27 file://0016-clang-Add-lpthread-and-ldl-along-with-lunwind-for-st.patch \
28 file://0017-Pass-PYTHON_EXECUTABLE-when-cross-compiling-for-nati.patch \
29 file://0018-Check-for-atomic-double-intrinsics.patch \ 28 file://0018-Check-for-atomic-double-intrinsics.patch \
30 file://0019-clang-Enable-SSP-and-PIE-by-default.patch \ 29 file://0019-clang-Enable-SSP-and-PIE-by-default.patch \
31 file://0020-libcxx-Add-compiler-runtime-library-to-link-step-for.patch \ 30 file://0020-libcxx-Add-compiler-runtime-library-to-link-step-for.patch \