summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-07-08 15:03:43 -0700
committerKhem Raj <raj.khem@gmail.com>2019-07-11 14:07:48 -0700
commita06a370188e121b1e10aac03b698116055e79525 (patch)
treeae5d583375522a9812f014a501058997aa87b397
parent34579b120b05d0495fe9e435deb83c56b9162248 (diff)
downloadmeta-clang-a06a370188e121b1e10aac03b698116055e79525.tar.gz
musl: Use gcc to compile always
clang needs built-ins from compiler-rt to build musl and compiler-rt needs a full toolchain to build which means we have a catch-22 on x32 with clang/musl, for now use gcc to compile musl to break the jinx Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes-core/musl/musl_%.bbappend1
1 files changed, 1 insertions, 0 deletions
diff --git a/recipes-core/musl/musl_%.bbappend b/recipes-core/musl/musl_%.bbappend
index 652982c..2fdef3e 100644
--- a/recipes-core/musl/musl_%.bbappend
+++ b/recipes-core/musl/musl_%.bbappend
@@ -1,2 +1,3 @@
1DEPENDS_append_toolchain-clang = " clang-cross-${TARGET_ARCH}" 1DEPENDS_append_toolchain-clang = " clang-cross-${TARGET_ARCH}"
2TOOLCHAIN_x86-x32 = "gcc"
2inherit lto 3inherit lto