summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-01-26 13:44:18 -0800
committerKhem Raj <raj.khem@gmail.com>2019-01-26 19:56:44 -0500
commit9fd4604241d39e019eb969ec2e61b159623c56d1 (patch)
treef9571d1c1dcd2fde5d0adb8dd6f22fae6fb49c7e
parentb284fb3a3108bab58e2e2cdfc2b9ee0c902b36fa (diff)
downloadmeta-clang-9fd4604241d39e019eb969ec2e61b159623c56d1.tar.gz
compiler-rt,libcxx: Remove --rtlib=compiler-rt
This avoids catch-22 Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes-devtools/clang/compiler-rt_git.bb1
-rw-r--r--recipes-devtools/clang/libcxx_git.bb1
2 files changed, 2 insertions, 0 deletions
diff --git a/recipes-devtools/clang/compiler-rt_git.bb b/recipes-devtools/clang/compiler-rt_git.bb
index 2cfbf71..e59a65d 100644
--- a/recipes-devtools/clang/compiler-rt_git.bb
+++ b/recipes-devtools/clang/compiler-rt_git.bb
@@ -18,6 +18,7 @@ LIC_FILES_CHKSUM = "file://compiler-rt/LICENSE.TXT;md5=f981c4637a4cd67915ac527b3
18BASEDEPENDS_remove_toolchain-clang_class-target = "compiler-rt libcxx" 18BASEDEPENDS_remove_toolchain-clang_class-target = "compiler-rt libcxx"
19CXX_remove_toolchain-clang = "-stdlib=libc++" 19CXX_remove_toolchain-clang = "-stdlib=libc++"
20TARGET_CXXFLAGS_remove_toolchain-clang = "-stdlib=libc++" 20TARGET_CXXFLAGS_remove_toolchain-clang = "-stdlib=libc++"
21TUNE_CCARGS_remove_toolchain-clang = "--rtlib=compiler-rt"
21TUNE_CCARGS_remove = "-no-integrated-as" 22TUNE_CCARGS_remove = "-no-integrated-as"
22DEPENDS += "ninja-native" 23DEPENDS += "ninja-native"
23DEPENDS_append_class-nativesdk = " clang-native" 24DEPENDS_append_class-nativesdk = " clang-native"
diff --git a/recipes-devtools/clang/libcxx_git.bb b/recipes-devtools/clang/libcxx_git.bb
index 28ea5eb..b36dede 100644
--- a/recipes-devtools/clang/libcxx_git.bb
+++ b/recipes-devtools/clang/libcxx_git.bb
@@ -15,6 +15,7 @@ DEPENDS += "ninja-native"
15BASEDEPENDS_remove_toolchain-clang = "libcxx" 15BASEDEPENDS_remove_toolchain-clang = "libcxx"
16CXX_remove_toolchain-clang = "-stdlib=libc++" 16CXX_remove_toolchain-clang = "-stdlib=libc++"
17TARGET_CXXFLAGS_remove_toolchain-clang = "-stdlib=libc++" 17TARGET_CXXFLAGS_remove_toolchain-clang = "-stdlib=libc++"
18TUNE_CCARGS_remove_toolchain-clang = "--rtlib=compiler-rt"
18 19
19PACKAGECONFIG ??= "unwind" 20PACKAGECONFIG ??= "unwind"
20PACKAGECONFIG_powerpc = "" 21PACKAGECONFIG_powerpc = ""